Installing linux-lts54 (pre-compiled) official

Hi Guys,

Could you please help me on how to install linux-lts54 (pre-compiled) official.

I have tried the unofficial one, from below link:

but with that wifi is not working.

I can only game on my system with the kernel linux-lts54.

With other kernels, while launching a game system crashes.

please find below system information for your reference:

  Kernel: 6.1.37-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=36783d40-29a1-424c-9dab-0f8a82216c57 rw rootflags=subvol=@
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3 ibt=off
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: Dell product: Inspiron 15-3567 v: N/A
    serial: <superuser required> Chassis: type: 9 serial: <superuser required>
  Mobo: Dell model: 0D53F5 v: A00 serial: <superuser required> UEFI: Dell
    v: 2.20.0 date: 07/12/2022
  ID-1: BAT0 charge: 28.6 Wh (100.0%) condition: 28.6/41.4 Wh (69.0%)
    volts: 16.4 min: 14.8 model: LGC-LGC2.80 DELL 7PY0D0A type: Li-ion
    serial: <filter> status: full
  Info: model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber/Kaby Lake
    note: check gen: core 7 level: v3 note: check built: 2017
    process: Intel 14nm family: 6 model-id: 0x8E (142) stepping: 9
    microcode: 0xF2
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 2198 high: 2700 min/max: 400/3100 scaling:
    driver: intel_pstate governor: powersave cores: 1: 692 2: 2700 3: 2700
    4: 2700 bogomips: 21607
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel HD Graphics 620 vendor: Dell driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1
    empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:5916 class-ID: 0300
  Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 M430 Radeon
    520 Mobile] vendor: Dell driver: radeon v: kernel alternate: amdgpu
    arch: GCN-1 code: Southern Islands process: TSMC 28nm built: 2011-20 pcie:
    gen: 3 speed: 8 GT/s lanes: 4 link-max: lanes: 8 bus-ID: 01:00.0
    chip-ID: 1002:6660 class-ID: 0380 temp: 37.0 C
  Device-3: Realtek Integrated_Webcam_HD driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:3 chip-ID: 0bda:5769
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 compositor: xfwm v: 4.18.0 driver: X:
    loaded: modesetting,radeon alternate: fbdev,intel,vesa dri: iris,radeonsi
    gpu: i915 display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 model: BOE Display 0x0671 built: 2016 res: 1366x768
    hz: 60 dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1366x768
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_soc_avs bus-ID: 00:1f.3
    chip-ID: 8086:9d71 class-ID: 0403
  API: ALSA v: k6.1.37-1-lts status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.72 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:3165 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
    bus-ID: 03:00.0 chip-ID: 10ec:8136 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-8:5 chip-ID: 8087:0a2a
    class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 931.51 GiB used: 105.55 GiB (11.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 5400 serial: <filter> fw-rev: SDM3 scheme: GPT
  ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 6.36 GiB (6.4%)
    fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /boot/efi raw-size: 310.2 MiB size: 309.6 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/sda3 maj-min: 8:3
  ID-3: /home raw-size: 831.21 GiB size: 831.21 GiB (100.00%)
    used: 99.19 GiB (11.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 100 GiB size: 100 GiB (100.00%)
    used: 6.36 GiB (6.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-5: /var/tmp raw-size: 100 GiB size: 100 GiB (100.00%)
    used: 6.36 GiB (6.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.63 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 41.0 C pch: 39.5 C mobo: 39.0 C gpu: radeon
    temp: 37.0 C
  Fan Speeds (RPM): cpu: 0
  Processes: 221 Uptime: 1h 15m wakeups: 10389 Memory: available: 7.63 GiB
  used: 2.06 GiB (27.0%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 13.1.1 Packages: pm: pacman pkgs: 1126
  libs: 335 tools: paru,yay Shell: Bash v: 5.1.16 running-in: xfce4-terminal
  inxi: 3.3.27
Garuda (2.6.16-1):
  System install date:     2023-07-02
  Last full system update: 2023-07-02 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            systemd-backlight@leds:dell::kbd_backlight.service

Kindly let me know if you require any further information.

Also please provide instruction on how to fetch the required information.

This might not be entirely useful to your case but can you tell us why exactly do you want to go with unofficial kernels? If you just want linux-lts kernel you can

sudo pacman -S linux-lts linux-lts-headers

Why go out of your way to download a obscure kernel that isn't even in the arch repo and not just use the regular lts kernel instead?

1 Like

Earlier I was using Manjaro linux, there they have maintained official linux-lts54 kernal and well maintained, but I faced many issues with manjaro so I quit manjaro, then installed arch, in arch there were no official linux-lts54 kernal.

If i try to play games on system with kernal other than linux-lts54 my system crashes, that is why i am in need of kernal linux-lts54.

is there a officialy supported linux-lts54 (pre-compiled) in garuda?

and also currently i am on LTS kernal.

6.1.37-1-lts, system crashes while launching a game (steam-games).

Yeah I don't think you have any way out with this one. It seems you only have two options either add the kernel-lts repo to your device and pull the precompiled package from their repo or do it on your own using,

paru -S linux-lts54 linux-lts54-headers

Which I think would take a lot of time and hence why you might wanna avoid.

Can you check if your Network Manager is up and working though? or if it is being terminated thus rendering you unable to use your wifi. You can do that with

systemctl status NetworkManager.service

which should show you something like this:

╰─λ systemctl status NetworkManager.service
● NetworkManager.service - Network Manager
Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; preset: disabled)
Active: active (running) since Sun 2023-07-02 22:54:46 IST; 2h 30min ago
Docs: man:NetworkManager(8)
Main PID: 733 (NetworkManager)
Tasks: 4 (limit: 18628)
Memory: 17.2M
CPU: 4.408s
CGroup: /system.slice/NetworkManager.service
└─733 /usr/bin/NetworkManager --no-daemon

Jul 03 01:19:43 siddharth NetworkManager[733]: <info>  [1688327383.7204] device (wlp0s20f3): supplicant inter>
Jul 03 01:19:43 siddharth NetworkManager[733]: <info>  [1688327383.7224] device (wlp0s20f3): ip:dhcp4: restar>
Jul 03 01:19:43 siddharth NetworkManager[733]: <info>  [1688327383.7341] dhcp4 (wlp0s20f3): canceled DHCP tra>
Jul 03 01:19:43 siddharth NetworkManager[733]: <info>  [1688327383.7342] dhcp4 (wlp0s20f3): activation: begin>
Jul 03 01:19:43 siddharth NetworkManager[733]: <info>  [1688327383.7342] dhcp4 (wlp0s20f3): state changed no >
Jul 03 01:19:43 siddharth NetworkManager[733]: <info>  [1688327383.7342] dhcp4 (wlp0s20f3): activation: begin>
Jul 03 01:19:43 siddharth NetworkManager[733]: <info>  [1688327383.7344] device (p2p-dev-wlp0s20f3): supplica>
Jul 03 01:19:43 siddharth NetworkManager[733]: <info>  [1688327383.8005] dhcp4 (wlp0s20f3): state changed new>
Jul 03 01:20:57 siddharth NetworkManager[733]: <info>  [1688327457.7408] dhcp6 (wlp0s20f3): activation: begin>
Jul 03 01:20:57 siddharth NetworkManager[733]: <info>  [1688327457.7419] policy: set 'XXXXXl_XXXX_5554' (wlp0>

As you can see the network manager's service should be enabled, active and running for wifi to work.

If you ask very nicely in this thread, they may be willing to add it to the Chaotic AUR for you. :slightly_smiling_face:

I have installed linux-lts54 from AUR.

But after installing, while rebooting I see a error message

failed to start apply kernel variable

and also a failed service has been listed

 UNIT                   LOAD   ACTIVE SUB    DESCRIPTION           
● systemd-sysctl.service loaded failed failed Apply Kernel Variables

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.
1 loaded units listed.

Google says…

1 Like

Now I have Installed arch, and installed the linux-lts54 from AUR .

the issue systemd-sysctl.service loaded failed failed Apply Kernel Variables was solved

but could not find Wpl2s0 wifi module

when I run if config :

enp3s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 10:7d:1a:24:27:11  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet  netmask
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 18  bytes 1284 (1.2 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 18  bytes 1284 (1.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

You run Garuda, not Arch, according to your garuda-inxi. :slight_smile: But, anyway, have you checked the current kernels lately? They change so rapidly, even the LTS.

1 Like

I unable to game in other kernals other than lts54

Whenever I play games with other kernals my system freezes, had to force shutdown.

1 Like