Installing bootloader stuck at 91%

Hey everyone,

I use garuda Linux KDE Dragonized Gaming edition

Every time my installer hits 91% it stops.

It says installing bootloader, at 91% how should I proceed?

I am a newbie to arch and garuda so I don't know much.
I've tried insalling it manually using: sudo grub-install --target=i386-pc --recheck --debug /dev/nvme0n1
but it fails

I've tried leaving it there for about 2 hours and nothing has changed. I've tried installing garuda at least 6 times now and is has always the same issue.

I should also say that I'm installing /boot, linuxswap and / on the nvme as well as the bootloader while my /home is on another hdd. In the past i've never encountered issues with that. The /home and everything else is BTRFS.

Edit: to install garuda i'm following this tutorial

Welcome, @Anulo2 :wave:

You can press Esc when booting and tell the members what warnings you see, for starters.

1 Like

Boot in UEFI mode and try again.


This didn't solve the issue :confused:

What didn't solve what issue?

1 Like

when booting what? the live usb or the ssd with garuda?
When booting garuda from the ssd it just goes straight to:

Booting in uefi mode. Still gets stuck at 91%

As the title suggested, (Installing bootloader stuck at 91%) my comment was intended for use booting the install/live USB.

I've solved the issue! It appears as it has something to do with my bios settings and my other disks. What I did is: disconnect every drive except the one on which I want to install windows, the one for the /home and the one for garuda (the nvme). I then updated my bios and reset every settings to default. After that I created the usb for windows and installed it as usual without any issue. I then created the usb for garuda dargonized gaming kde and installed by doing partitions manually: swap (16384mb since I have 16gb ram), /boot/efi (512mb - fat32), root (rest of disk - btrfs)
The /home took up the whole space on the other disk (btrfs)
Installed it as efi - gpt and everything went fine. I'm now happily using garuda with a dualboot with windows ;D
Hope this can help people in my same situation


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.