Installing amdgpu-pro-core-meta (20.45_1188099-3) breaks dependency 'amdgpu-pro-core-meta=20.40_1147286-1'

I get this error when I try
sudo pacman -Syu

The error is

:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 chaotic-aur is up to date
:: Starting full system upgrade...
warning: libldac: local (2.0.2.3-3) is newer than extra (2.0.2.3-1)
warning: python-ufoprocessor: local (1.9.0-3) is newer than chaotic-aur (1.9.0-2)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing amdgpu-pro-core-meta (20.45_1188099-2) breaks dependency 'amdgpu-pro-core-meta=20.40_1147286-1' required by hip-amdgpu-pro
:: installing amdgpu-pro-core-meta (20.45_1188099-2) breaks dependency 'amdgpu-pro-core-meta=20.40_1147286-1' required by lib32-opencl-amdgpu-pro-orca
:: installing amdgpu-pro-core-meta (20.45_1188099-2) breaks dependency 'amdgpu-pro-core-meta=20.40_1147286-1' required by opencl-amdgpu-pro-comgr
:: installing amdgpu-pro-core-meta (20.45_1188099-2) breaks dependency 'amdgpu-pro-core-meta=20.40_1147286-1' required by opencl-amdgpu-pro-orca
:: installing amdgpu-pro-core-meta (20.45_1188099-2) breaks dependency 'amdgpu-pro-core-meta=20.40_1147286-1' required by opencl-amdgpu-pro-pal

Anyone know what the issue is?

Did you try refreshing database? Try

sudo pacman -Syyu
3 Likes

Is their a specific reason for using the pro drivers as they are not as good as the free driver,
Also the terminal output is telling you what is wrong you have to remove the old versions 1st

2 Likes

Thank you for the reply.
I guess my computer is running on amdgpu-pro. So I might use the open source "amdgpu" instead.
I verified this by doing

glxinfo | grep "OpenGL vendor string" | cut -f2 -d":" | xargs

which outputs

AMD

Sorry if this is an elementary question, but how would you install amdgpu and replace it with amdgpu-pro? I tried this out once and it crashed and I had to fix it by booting into tty2. It would be great to have a descriptive solution because I can't stand having it crash again.

You possibly need to update your mirrors properly.
This meta package should update properly, if your repos/mirrors are up-to-date.

If your system needs this driver configuration, changing to normal amdgpu, doesn't make sense. You either need it or not.

2 Likes

and probably the rest of conflicts are valid for normal AUR packages.
I don't know how you got having newer packages than AUR (and chaotic-aur).

YOU have to explain.... I am not your system administrator.

What's your installed version?

pacman -Qi amdgpu-pro-core-meta
1 Like

Yes, that is the part that I am not understanding as well.

This is what I got

Name            : amdgpu-pro-core-meta
Version         : 20.40_1147286-1
Description     : Config file /etc/ld.so.conf.d/10-amdgpu-pro.conf
Architecture    : any
URL             : https://www.amd.com/en/support/kb/release-notes/rn-amdgpu-unified-linux-20-40
Licenses        : custom: AMDGPU-PRO EULA
Groups          : Radeon_Software_for_Linux
Provides        : None
Depends On      : amdgpu-core-meta=20.40_1147286-1
Optional Deps   : None
Required By     : amf-amdgpu-pro  hip-amdgpu-pro  lib32-opencl-amdgpu-pro-orca
                  lib32-vulkan-amdgpu-pro  opencl-amdgpu-pro-comgr  opencl-amdgpu-pro-orca
                  opencl-amdgpu-pro-pal  vulkan-amdgpu-pro
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 9.33 KiB
Packager        : Unknown Packager
Build Date      : Sun 20 Dec 2020 09:09:47 PM EST
Install Date    : Sun 20 Dec 2020 09:11:58 PM EST
Install Reason  : Explicitly installed
Install Script  : Yes
Validated By    : None

You can explicitly uninstall it and re-install (hopefully successfully) to the new version.
But the question is still unanswered

1 Like

Uninstalling and reinstalling amdgpu-pro-core-meta solved the error. But still I had the issue of

So I downgraded python-ufoprocessor to version 1.9.0-2. And that fixed the issue.

I don't know how I got a version newer than chaotic-aur though unfortunately.

Thank you very much for the help

I am glad you solved this, although I think you have to secure your room, so nobody does stuff to your PC without you know :stuck_out_tongue_winking_eye:

3 Likes