Installer gets stuck at Plymouth Boot Screen

Hello Garuda users!

I am having trouble installing Garuda (and Manjaro for that matter) on my computer.

I was initially trying to make my bootable USB drive for Garuda with Rufus, Unetbootin, and etcher. All of those options resulted in the same result.

I am able to boot into the installation image, which runs all the way until it reaches the line "Starting Terminate Plymouth Boot Screen" where the installer appears to get stuck and no longer progresses.

I am able to use the F1-F6 keys to access a terminal.

I verified I can install Linux by installing the latest distribution of Ubuntu which I am currently running and writing this forum post with. The purpose was to be able to try and write the Garuda DR460NIZED GAMING KDE iso to my USB drive using the dd command. Which resulted in the same issue I listed above.

CPU: AMD Ryzen 7 3800x
Motherboard: Asus ROG Strix X570
GPU: Radeon Vega 64
RAM: 32GB 3200mhz DDR4

Any help would be very appreciated. I am assuming this has something to do with a newer linux kernal as I am able to install Ubuntu, but am unable to install an Arch based linux distro as of yet.

Thank you all.

Please share the image where it stucked

Hi. Have you tried both options, free and proprietary drivers?
If both do not work, try also removing splash from the grub line (button E, remove splash, ctrl+x).
I don't think it will really help, but that's my only idea...
Also, did you wait enough time at every try?
I think the HW detection can take up to some five minutes.


After many hours of research and testing I could only boot into the installer using "nomodeset". This caused my AMD driver to not be able to load and thus I was unable to ever reach the desktop environment on the live usb to install Garuda.

My fix for this was using an HDMI cable. I had read on an Arch forum a user was having the same issue I was with a blank screen on installation boot with a Vega graphics card. Turns out using the DisplayPort causes some problems here, where when switching to an HDMI cable allows for the display to work as intended.

I am not sure why that is or what causes that issue in the first place. I do now have Garuda installed and I am able to use the DisplayPort cable only after I am logged into my user on Garuda. Otherwise I can only get passed the boot menu using the HDMI connection. Again I do not know why this is but that is my solution. Any insight into this would be appreciated. If I have to start a new thread for it let me know.

Thank you all who replied to help.


This reminds me of AMD GPUs often having problems with iommu.
If you just want to give It a try, you could try with boot parameter iommu=soft or maybe iommu=off

Make sure you have amdgpu in mkinitcpio.conf MODULES array.
Check MB and GPU manuals for relevant settings.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.