Installed arch, grub can't find garuda

First of all please please dont throw docs, i looked up, and i am panicking
I installed arch following archiwiki, now simply i only see arch in my grub menu, garuda is not there. What do i do? Please help

The fix is to change the default boot entry to be garuda.

You can do that from your BIOS menu where boot options are set.

I have only 5 partition

  1. Efi
  2. Garuda root filesystem
  3. Arch filesystem
  4. Arch swap
  5. Garuda swap

I have overwriten 1efi partition. So i don't see garuda in my bios list either.

I am still in the chroot. I can format any drive (well except garuda filesystem)
I am willing to do everything fromt the start.

I am even willing to format my new arch. I want my garuda back :slightly_smiling_face:

You did not search well, this is an excessively documented topic in our forum.

If you are in the chroot with your Garuda Btrfs partition and the EFI partition mounted, an easy fix is to just reinstall Grub.


may be enough, or

grub-install --target=x86_64-efi --efi-directory=*esp* --bootloader-id=GRUB

or if you have legacy BIOS,

grub-install --target=i386-pc /dev/sdX

or whatever method is specifically appropriate for your system, see here: GRUB - ArchWiki

Then regenerate the configuration file.


Exit the chroot, reboot.

1 Like


/usr/bin/grub-probe: error: cannot find a device for / (is /dev mountes?)

I'm assuming they have BTRFS as the file system on the OS who's grub isn't showing Garuda. If yes just make sure you have op-prober-btrfs installed and not just os-prober. For some reason op-prober will not detect secondary OS's that are on BTRFS hence why the need to install os-prober-btrfs.

It looks like one of the preceding steps (setting up the chroot or installing Grub) failed or was not done correctly. If you want help, you need to post the terminal input and output of your commands into the thread so we can see what is happening.

Another option, as others have mentioned, is to change the default boot option either in the BIOS menu or from a booted system with efibootmgr because Garuda is probably still there, just no longer set to the primary boot option.

Do you have os-prober installed? If not, perhaps do so?

Please, post every time the output from


as text, possible also from live ISO.

1 Like

Yes btrfs was enabled. My file system was like @, @home, @root etc etc.
Currently isntalling os-prober-btrfs in arch
Hope that finds, or else i would just ditch garuda :slightly_smiling_face:

1 Like

"No problem, just change the boot order."


By the way:

Only one swap partition is needed, on a multiboot setup all OS's can share the same swap partition.


6 posts were merged into an existing topic: Off Topic Chit Chat - (Silliness factor 5)

Unless you are using hibernation/suspend to disk

Do you mean in case you needed to allow both systems to be suspended to disk at the same time? Or in what situation would having two swap partitions be needed?

If you suspend A and then boot B, the suspend data for A would be lost. Even if they are not suspended at the same time, the problem would be there.

I don't have garuda in my boot order either.

I tried os-prober-btrfs
Yes it detected other distros. Like debian and ubuntu
Which were two docker container in garuda.
Garuda is still not found.

I think i have to manually put garuda. By writing cfg file myself. But at this point i am toi scared

That makes sense. I would not have thought to boot into another system while the first one is suspended, but I can see how that would be useful. I stand corrected!

Don't worry about it, I wouldn't say that statement was necessarily accurate to begin with unless you are short on disk space, especially with Btrfs.

What is the output of efibootmgr?

output of efibootmgr

BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0001,000A,000B
Boot0001* GRUB	HD(1,GPT,3dd158b5-def8-2e4c-a5d9-0b84c89d36a1,0x1000,0x96000)/File(\EFI\GRUB\grubx64.efi)
Boot000A* ADATA SX6000PNP	BBS(HD,,0x0)0000424f
Boot000B* ST1000DM010-2EP102	BBS(HD,,0x0)0000424f

BootA,B is same as GRUB HD, it just the namme of my drive, idk why there is two but there is. all of them lead to grub hd

Try booting into Arch, from there make sure the Garuda partition is mounted then try:

sudo update-grub
1 Like