Installation, not able to make required partitions during install

Hello everyone, My name is Sumod and I am absolutely new to the Linux community.
Garuda Linux is my first trial dip into the world of Linux distributions.
I tried to install Garuda Linux (as Dual Boot) onto my Dell Vostro desktop
.......... that is running Windows 10, has Bios mode of "Legacy", Hard Disk Volume property of "MBR", 4 GB RAM and 1TB Hard Drive.

The 1 TB hard disk presently has the below mentioned partitions...

  1. System Reserved 500 MB
  2. C: 194.82 GB NTFS
  3. E: 486.20 GB NTFS
  4. 250.00 GB Unallocated

Attempting to install Garduda Linux from a bootable USB, I reached as far as the disk partitioning where after I created the "swap" partition I got a prompt saying more than 4 primary partitions are not allowed on a MBR Hard Drive..
What do I do now?

Have been researching on the web from 2 days now and not able to find anything .. I am not that tech savy ...sorry!!

Kindly assist and let me know if any more information is required from my side.

Thankyou all..

Make Extended Partitions within your 4. 250.00 GB Unallocated.


I'm assuming you want to keep Windows. If that is the case then when you get to the partition section select replace a partition and then click on the free space. You should be good to go. Let Garuda automatically do the rest from there. I believe with Zram you really don't need either a swap partition or swap file. foregoing the swap partition will solve your issue.

Thank you for responding so soon... Will try as soon as possible

1 Like

Hi guys ... I tried to install Garuda Linux in the 250GB unallocated space as logical partitions in the extended partition, but I got an install error that the Boot loader was not able to install.
So I deleted the /boot/efi (fat34) partition and created a /boot (fat34) partition and this time it told me Gradua Linux boot loader needs to be installed in a /boot/efi partition ...
So I thought I'll come back here and ask about it but I find that my Windows bootloader was corrupted during the process ..
What do I do now ... My HDD is in MBR format and BIOS is operating on Legacy mode.
Do I need a try a version that is can be installed with /boot or /legacyboot partitions?
Please assist

Again see below. If you do what I suggested instead of pretending I didn't post Garuda will install to you free space and create what it needs to boot in your current boot partition.

1 Like

I am trying to get a hang of the technical requirements and workings of the Garuda installation, hence went with the manual installation method.
Also the above mentioned post does not address the bootloader issue...
Can you assure that the Garuda Linux will install without issue using the "replace a partition" method given that the warning msg I received said "Garuda needs a /boot/efi partition to install the Garuda bootloader"

Once again the specs of my system are given below

  • Dell Vostro desktop running Windows 10, has Bios mode of "Legacy",

  • Hard Disk Volume farmatted as "MBR", (was informed by the technician who fixed the "bootloader not found issue" for Windows 10 after my first attempt to install Garuda that a bootloader requiring /boot/efi partition cannot be installed on MBR formatted HDD)

  • 4 GB RAM

  • The 1 TB hard disk presently has the below mentioned partitions...

      1. System Reserved 500 MB
      2. C: 194.82 GB NTFS
      3. E: 486.20 GB NTFS
      4. 250.00 GB Unallocated

Will make another attempt with "replace partition method" once I'm confident the issue I just faced does not strike again...

The other option I know of is to run Garuda Linux off of an external SSD/HHD. But that requires additional investment hence holding off on that for now.

Please assist ...

1 Like

Create a partition there using either your Windows tools or while booted into a Garuda LiveISO, then go from there.

1 Like

Thanks c00ter!!! .. Would you be kind enough to share the live steps ..

What approach do you propose? Replace Partition or Manual Partition
Keep in mind that it's a MBR format HDD that got corrupted when I used Manual Partition approach
This is what happened on my first attempt
In the 250 GB Extended Partition I created

  1. 1GB /boot/efi partition - Logical - Fat34
  2. 8 GB swap partition - Logical - linuxswap
  3. 30 GB root partitoin - Logical - btrfs
  4. Remaining as home partition - Logical - btrfs

I got the error that "/boot/efi section failed to install".
So thinking that it's because of my HDD not supporting /efi I tried changing the first logical partition to 1GB /boot partition - Fat34 but even before the installation started I got the message that /boot/efi partition is required to install Garuda Raptor Eagle
So I decided to do a little more research, removed the USB and restarted the system but the windows bootloader was corrupted.

Spent money to get that fixed so now I would really like to be sure of the path I walk..
Please assist

No. This is basic computing knowledge. Go buy a Dummies book.

EDIT: Partitioning - ArchWiki MBR

You should not have an EFI partition at all if you are running a MBR disk on a legacy mobo.

If the installer is insisting you need to set up an EFI partition, check in your BIOS settings that you do not have any features enabled that will "trick" the Calamares installer into thinking you have a UEFI board. See this thread for example:

1 Like

You can ignore the error message. Once the install starts Garuda will tell you it's creating that partition, but it's actually just adding it's boot information to that partition. I've don't this TOO many times to even count.

BluishHumility I believe that is just the default message at that point irregardless of MBR or GPT.