Installation failed due to EFI partition not found

Error :

Boost Python error in job bootloader

Grub-install : error: /boot/efi doesn't look like an EFI partition

I have data on sda4. How to change file system to fat32 and mount point to /mnt/boot/efi for sda1 without formatting whole data on disk?

First read


then post.


1 Like

Are you sure your system is UEFI and you have booted installer in UEFI?


As petsam mentioned, make sure you booted into UEFI. My own UEFI partition is fat32 with 2 flags, boot and esp. Every single distro I've tried ( over 20 ) works fine. I also have secure boot disabled.

I had this problem or a very similar one initially when trying to install Garuda.

I worked out that while KDE Partition Manager was flagging 'boot', there was no option that I could see to flag 'esp' in the FAT32 /boot/efi partition. So I used GParted to flag both, and the next attempt at installation went perfectly.

I never use anything other than GParted. :grinning: It's extremely reliable.

1 Like

Me love KDE long time.

However, I'd also always rather use gparted myself for stability reasons. KPM isn't quite there yet IMO, especially if doing complex partition resize operations. I like KPM, but I'm always leery of using it for advanced operations as it has failed in the past for me.

Gparted is a little more solid IMO.