Installation | FaceFusion

System:
  Kernel: 6.9.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1 clocksource: tsc
    avail: hpet,acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=4f64013a-7f46-4dc0-a552-be58d9224a85 rw rootflags=subvol=@ quiet loglevel=3 ibt=off
  Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.2.0 wm: kwin_wayland vt: 1
    dm: SDDM Distro: Garuda base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS (WI-FI) v: Rev X.0x
    serial: <superuser required> part-nu: SKU uuid: <superuser required> UEFI: American Megatrends
    v: 5003 date: 10/07/2023
CPU:
  Info: model: AMD Ryzen 7 5800X3D bits: 64 type: MT MCP arch: Zen 3+ gen: 4 level: v3 note: check
    built: 2022 process: TSMC n6 (7nm) family: 0x19 (25) model-id: 0x21 (33) stepping: 2
    microcode: 0xA20120E
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache: L1: 512 KiB
    desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 96 MiB desc: 1x96 MiB
  Speed (MHz): avg: 3591 high: 4350 min/max: 2200/4549 boost: enabled scaling:
    driver: acpi-cpufreq governor: performance cores: 1: 3475 2: 3505 3: 3479 4: 3476 5: 3400 6: 3593
    7: 3484 8: 3594 9: 3695 10: 3846 11: 3480 12: 3608 13: 4350 14: 3479 15: 3524 16: 3478
    bogomips: 108796
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3
  Vulnerabilities: <filter>
Graphics:
  Device-1: NVIDIA AD102 [GeForce RTX 4090] vendor: Micro-Star MSI driver: nvidia v: 555.42.02
    alternate: nouveau,nvidia_drm non-free: 550.xx+ status: current (as of 2024-04) arch: Lovelace
    code: AD1xx process: TSMC n4 (5nm) built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
    active: none off: DP-1 empty: DP-2,DP-3,HDMI-A-1 bus-ID: 0b:00.0 chip-ID: 10de:2684
    class-ID: 0300
  Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0 compositor: kwin_wayland
    driver: X: loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa gpu: nvidia
    display-ID: 0
  Monitor-1: DP-1 res: 5120x1440 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2 drv: swrast gbm:
    drv: nvidia surfaceless: drv: nvidia wayland: drv: nvidia x11: drv: zink inactive: device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 555.42.02 glx-v: 1.4
    direct-render: yes renderer: NVIDIA GeForce RTX 4090/PCIe/SSE2 memory: 23.43 GiB display-ID: :1.0
  API: Vulkan v: 1.3.279 layers: 11 device: 0 type: discrete-gpu name: NVIDIA GeForce RTX 4090
    driver: nvidia v: 555.42.02 device-ID: 10de:2684 surfaces: xcb,xlib,wayland
Audio:
  Device-1: NVIDIA AD102 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0b:00.1 chip-ID: 10de:22ba class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0d:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: Blue Microphones Yeti Stereo Microphone driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-2:2 chip-ID: b58e:9e84
    class-ID: 0300 serial: <filter>
  Device-4: FiiO BTR7 driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 7-4.1:4 chip-ID: 2972:0047 class-ID: 0300
  API: ALSA v: k6.9.2-zen1-1-zen status: kernel-api with: aoss type: oss-emulator tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Intel Wi-Fi 5 Wireless-AC 9x6x [Thunder Peak] driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 06:00.0 chip-ID: 8086:2526 class-ID: 0280
  IF: wlp6s0 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK
    driver: r8169 v: ke
rnel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 07:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Bluetooth:
  Device-1: Intel Wireless-AC 9260 Bluetooth Adapter driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 5-5:3 chip-ID: 8087:0025 class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.1 lmp-v: 10 status:
    discoverable: no pairing: no class-ID: 6c0104
Drives:
  Local Storage: total: 15.46 TiB used: 2.64 TiB (17.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:3 vendor: Western Digital model: WD BLACK SN850X 4000GB
    size: 3.64 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD
    serial: <filter> fw-rev: 624311WD temp: 54.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Samsung model: SSD 990 PRO 4TB size: 3.64 TiB
    block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 4B2QJXD7 temp: 48.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST4000VN008-2DR166 size: 3.64 TiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5980 serial: <filter>
    fw-rev: SC60 scheme: GPT
  ID-4: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter>
    fw-rev: 3B6Q scheme: GPT
  ID-5: /dev/sdc maj-min: 8:32 vendor: Western Digital model: WD2003FZEX-00SRLA0 size: 1.82 TiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
    fw-rev: 1A01 scheme: GPT
  ID-6: /dev/sdd maj-min: 8:48 vendor: Western Digital model: WD20EZRZ-00Z5HB0 size: 1.82 TiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 0A80 scheme: MBR
Partition:
  ID-1: / raw-size: 3.64 TiB size: 3.64 TiB (100.00%) used: 1.45 TiB (39.9%) fs: btrfs
    dev: /dev/nvme1n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 588 KiB (0.2%) fs: vfat
    dev: /dev/nvme1n1p1 maj-min: 259:1
  ID-3: /home raw-size: 3.64 TiB size: 3.64 TiB (100.00%) used: 1.45 TiB (39.9%) fs: btrfs
    dev: /dev/nvme1n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 3.64 TiB size: 3.64 TiB (100.00%) used: 1.45 TiB (39.9%) fs: btrfs
    dev: /dev/nvme1n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 3.64 TiB size: 3.64 TiB (100.00%) used: 1.45 TiB (39.9%) fs: btrfs
    dev: /dev/nvme1n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 31.25 GiB used: 25.8 MiB (0.1%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 58.5 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 32 GiB available: 31.25 GiB used: 5.15 GiB (16.5%)
  Processes: 425 Power: uptime: 4h 57m states: freeze,mem,disk suspend: deep avail: s2idle
    wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume image: 12.46 GiB
    services: org_kde_powerdevil, power-profiles-daemon, upowerd Init: systemd v: 255
    default: graphical tool: systemctl
  Packages: 1967 pm: pacman pkgs: 1952 libs: 545 tools: gnome-software, octopi, pacseek, pamac,
    paru pm: flatpak pkgs: 15 Compilers: clang: 17.0.6 gcc: 14.1.1 alt: 13 Client: shell wrapper
    v: 5.2.26-release inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2024-05-10
  Last full system update: 2024-05-31 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:            

I’m really new to Linux , can anyone assist me on how to get this installed ; I tried another application named roop unleashed but I am stuck at one portion where I need cuda 11.8 sadly on pacseek that’s the only one I’m missing , Also I have this application link below on windows it was a lot easier to install but now That I fully switched to Linux I want to know if this version is able to install this. also if possible can you explain why you type certain words in the konsole , thank you

This is going to be quite complex and might make your system unstable (e.g. starting installing conda packages).
An AUR package would have helped a lot. But it’s not available.
It is not clear where you are having troubles in the facefusion process.
In preparation, ffmpeg should not be a problem, miniconda3 is also available in the AUR.
mesa-va-drivers is a debian package for VA-API I think. In Arch what you need depends on your platform (btw your garuda-inxi, required in the template, is missing).
Read here about it
https://wiki.archlinux.org/title/Hardware_video_acceleration
Environment and accelerator are conda stuff…
I’m afraid you’ll have to make an effort to walk through that process by yourself and provide specific questions/errors, with terminal text.
But this is very very far from Garuda standard and official support…
In case of troubles maybe check if there are Arch users in their Discord channel and ask for their help.
Good luck!

2 Likes

will do and my apologies forgetting to add the inxi, yah I will be asking on their discord; one question outside of this application, Another application I needed just cuda 11.8 issue is on pacseek or AUR there are all types of cuda even 11.7 and 12 but not 11.8 how would you get 11.8 cuda because officially on nvidia site their linux support has almost all linux but Arch

Maybe try this

It can be used also for 11.8

1 Like

Will do; technically I’m not doing this for me but my younger brother wants to leave windows too but these specific apps he uses a lot and he needs to see it running to hop; I basically told him to just dual boot since I mostly game on my pc lol; will test out 11.7

cuda-11.7 is still in the AUR anyway if it can help

2 Likes

tried installing fails every time, going to rest for tonight will work tomorrow morning

If the problem is building the cuda package from AUR, it should be due to its dependency on an old gcc compiler version:
https://aur.archlinux.org/packages/cuda-11.7#comment-971392
You could try the version in the Arch archive suggested in the post above.

2 Likes