Install won't boot - snapshots say "root device mounted but /sbin/init does not exist"

I'm glad to see that you were able to fix the issue because I ran into the same thing

root device mounted but /sbin/init does not exist

shortly before I had to leave and couldn't dig in any deeper to see what was going on. All I know for sure is that in my instance, I couldn't boot into the base install OR snapshots. The base install wouldn't get passed the kernel loading screen that pops up right after GRUB and the snapshots were met with the above "/sbin/init does not exist" error message.

I booted onto a live environment and tried fixing things via chroot but was met with error after error, the predominant one that kept me from updating the system from the live install/chroot alternated between Chaotic-AUR timing out/404/maximum file size exceeded errors and issues with signing keys despite running pacman-key --init / --populate / --refresh (all separately, ofc. The latter from multiple different keyservers) and even adding the offending keys individually. I had to give up here though to attend to a prior commitment.

Hopefully when I get back, I'll be able to quickly address and rectify the issue once and for all :crossed_fingers:

Not sure if I should start a new thread for the same issue, albeit slightly different in that I am not able to boot into even the base install. I've tried everything I can think of/that I found to remedy. The overwhelming majority of suggestions (that also seemed to solve a similar large majority of the original issues they were in response to) was 2 part; add/re-add systemd-sysvcompat and add init=/lib/systems/systems to kernel arguments, either by hitting the 'E' key on grub menu screen or, for a persistent remedy, edit /etc/default/grub. I tried both. I also tried with init=/usr/lib/systemd/systemd and init=/@/use/init/lib/systemd/systemd, none worked. All of this was done by chrooting into the borked install from a Garuda live environment. Speaking of, I've been able to add packages on an individual basis going this route however I cannot for the life of me run a full update due to issues with Chaotic-AUR. As mentioned above, the issues varied between timing out/404 but most often revolved around signature issues, which persisted even after issuing pacman-key --init/--populate/refresh-keys (and specifying a current keyservers since GDPR has resulted in a great deal of them going offline/being deprecated. I didn't want to bug anyone for help with this but I've been at it for ≈3 days now and am seemingly no closer to was resolving whatever the issue is than I was before I put forth any effort.

As for what I did to cause this mess, the only thing I can think of possibly causing it was deleting a package conflict - when attempting to install realtek-firmware I was denied due to a conflict with Linux-firmware. However, I have my doubts because I have since reinstalled it and still can't boot into anything other than a live environment.

here's my garuda-inxi, though it would appear that despite being in the chroot environment, it still printed out the info corresponding to the live environment.

i would be very gratedul for any insight/advice etc. that anyone is able to provide and if there's anything i can provide that would be more helpful please just let me know.

Thanks!

 garuda-inxi
12System:
  12Kernel 5.14.14-zen1-1-zen 12arch x86_64 12bits 64 12compiler gcc 12v 11.1.0
    12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=garuda
    misolabel=GARUDA_DR460NIZEDGAMING_HARPYEAG quiet systemd.show_status=1 driver=free
    nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
  12Desktop KDE Plasma 12v 5 12tk Qt 12v 5.15.4 12info latte-dock 12wm kwin_x11 12vt 1 12dm N/A
    12Distro Garuda Linux 12base Arch Linux
12Machine:
  12Type Desktop 12Mobo ASRock 12model 4X4-4000 Series 12serial N/A 12BIOS American Megatrends 12v P1.30
    12date 11/27/2020

(upower:42): UPower-WARNING **: 01:23:57.077: Cannot connect to upowerd: Could not connect: No such file or directory
12Battery:
  12Device-1 hidpp_battery_0 12model Logitech M720 Triathlon Multi-Device Mouse 12serial <filter>
    12charge Normal 12status discharging
  12Device-2 hidpp_battery_1 12model Logitech Wireless Mouse M510 12serial <filter> 12charge N/A
    12status N/A
12CPU:
  12Info 12model AMD Ryzen 5 4500U with Radeon Graphics 12bits 64 12type MCP 12arch Zen 2 12family 0x17 (23)
    12model-id 0x60 (96) 12stepping 1 12microcode 0x8600103
  12Topology 12cpus 1x 12cores 6 12smt <unsupported> 12cache 12L1 384 KiB 12desc d-6x32 KiB; i-6x32 KiB
    12L2 3 MiB 12desc 6x512 KiB 12L3 8 MiB 12desc 2x4 MiB
  12Speed (MHz) 12avg 2208 12high 2371 12min/max N/A 12base/boost 2375/4000 12volts 1.2 V 12ext-clock 100 MHz
    12cores 121 2370 122 2371 123 2371 124 2371 125 1397 126 2371 12bogomips 28447
  12Flags avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  12Vulnerabilities
  12Type itlb_multihit 12status Not affected
  12Type l1tf 12status Not affected
  12Type mds 12status Not affected
  12Type meltdown 12status Not affected
  12Type spec_store_bypass 12mitigation Speculative Store Bypass disabled via prctl and seccomp
  12Type spectre_v1 12mitigation usercopy/swapgs barriers and __user pointer sanitization
  12Type spectre_v2
    12mitigation Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling
  12Type srbds 12status Not affected
  12Type tsx_async_abort 12status Not affected
12Graphics:
  12Device-1 AMD Renoir 12driver amdgpu 12v kernel 12pcie 12gen 4 12speed 16 GT/s 12lanes 16 12ports
    12active DP-1, DP-2, DP-3, DP-4 12empty none 12bus-ID 05:00.0 12chip-ID 1002:1636 12class-ID 0300
  12Display x11 12server X.org 12v 1.21.1.3 12with Xwayland 12v 22.1.2 12compositor kwin_x11 12driver 12X
    12loaded amdgpu 12unloaded modesetting 12alternate fbdev,vesa 12gpu amdgpu 12display-ID :0
  12Monitor-1 DP-1 12model Sony TV XV 12serial <filter> 12built 2007 12res 1920x1080 12dpi 30 12gamma 1.2
    12size 1600x900mm (62.99x35.43") 12diag 1836mm (72.3") 12ratio 16:9 12modes 12max 1920x1080 12min 640x480
  12Monitor-2 DP-2 12model D32hn-E4 12serial <filter> 12built 2018 12res 1366x768 12gamma 1.2
    12size 575x323mm (22.64x12.72") 12modes 12max 1366x768 12min 720x400
  12Monitor-3 DP-3 12model Sony TV 12serial <filter> 12built 2010 12res 1920x1080 12dpi 30 12gamma 1.2
    12size 1600x900mm (62.99x35.43") 12diag 1836mm (72.3") 12ratio 16:9 12modes 12max 1920x1080 12min 640x480
  12Monitor-4 DP-4 12model Panasonic PanasonicTV0 12serial <filter> 12built 2012 12res 1920x1080 12gamma 1.2
    12size 698x392mm (27.48x15.43") 12modes 12max 1920x1080 12min 640x480
  12Message GL data unavailable for root.
12Audio:
  12Device-1 AMD Renoir Radeon High Definition Audio 12vendor ASRock 12driver snd_hda_intel 12v kernel
    12pcie 12gen 4 12speed 16 GT/s 12lanes 16 12bus-ID 05:00.1 12chip-ID 1002:1637 12class-ID 0403
  12Device-2 AMD ACP/ACP3X/ACP6x Audio Coprocessor 12vendor ASRock 12driver N/A 12pcie 12gen 4
    12speed 16 GT/s 12lanes 16 12bus-ID 05:00.5 12chip-ID 1022:15e2 12class-ID 0480
  12Device-3 AMD Family 17h/19h HD Audio 12vendor ASRock 12driver snd_hda_intel 12v kernel 12pcie 12gen 4
    12speed 16 GT/s 12lanes 16 12bus-ID 05:00.6 12chip-ID 1022:15e3 12class-ID 0403
  12Device-4 GN Netcom Jabra EVOLVE LINK 12type USB 12driver jabra,snd-usb-audio,usbhid 12bus-ID 2-2.4:8
    12chip-ID 0b0e:0306 12class-ID 0300 12serial <filter>
  12Sound Server-1 ALSA 12v k5.14.14-zen1-1-zen 12running yes
  12Sound Server-2 PulseAudio 12v 16.0 12running no
  12Sound Server-3 PipeWire 12v 0.3.51 12running yes
12Network:
  12Device-1 Realtek RTL8125 2.5GbE 12vendor ASRock 12driver r8169 12v kernel 12pcie 12gen 2 12speed 5 GT/s
    12lanes 1 12port f000 12bus-ID 01:00.0 12chip-ID 10ec:8125 12class-ID 0200
  12IF enp1s0 12state down 12mac <filter>
  12Device-2 Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 12vendor ASRock 12driver r8169
    12v kernel 12pcie 12gen 1 12speed 2.5 GT/s 12lanes 1 12port ec00 12bus-ID 02:00.0 12chip-ID 10ec:8168
    12class-ID 0200
  12IF enp2s0f0 12state down 12mac <filter>
  12Device-3 Intel Wi-Fi 6 AX200 12driver iwlwifi 12v kernel 12pcie 12gen 2 12speed 5 GT/s 12lanes 1
    12bus-ID 03:00.0 12chip-ID 8086:2723 12class-ID 0280
  12IF wlp3s0 12state down 12mac <filter>
12Bluetooth:
  12Device-1 Intel AX200 Bluetooth 12type USB 12driver btusb 12v 0.8 12bus-ID 4-3:3 12chip-ID 8087:0029
    12class-ID e001
  12Report bt-adapter 12ID hci0 12rfk-id 0 12state up 12address N/A
12Drives:
  12Local Storage 12total 10.06 TiB 12used 222.41 GiB (2.2%)
  12ID-1 /dev/nvme0n1 12maj-min 259:0 12vendor Crucial 12model CT500P2SSD8 12size 465.76 GiB 12block-size
    12physical 512 B 12logical 512 B 12speed 31.6 Gb/s 12lanes 4 12type SSD 12serial <filter> 12rev P2CR010
    12temp 3.9 C
  12SMART yes 12health PASSED 12on 1y 96d 20h 12cycles 682 12read-units 50,508,482 [25.8 TB]
    12written-units 39,243,101 [20.0 TB]
  12ID-2 /dev/sda 12maj-min 8:0 12vendor Crucial 12model CT500MX500SSD1 12family Micron Client SSDs
    12size 465.76 GiB 12block-size 12physical 4096 B 12logical 512 B 12sata 3.3 12speed 6.0 Gb/s 12type SSD
    12serial <filter> 12rev 020 12temp 40 C
  12SMART yes 12state enabled 12health PASSED 12on 2y 18d 6h 12cycles 1691 12written 46.09 TiB
  12ID-3 /dev/sdb 12maj-min 8:16 12type USB 12vendor Western Digital 12model WD easystore 25FB
    12drive model WD100EMAZ-00WJTA0 12family Ultrastar He10/12 12size 9.1 TiB 12block-size 12physical 4096 B
    12logical 512 B 12sata 3.2 12speed 6.0 Gb/s 12type HDD 12rpm 5400 12serial <filter> 12drive serial <filter>
    12rev 3004 12drive rev 83.H0A83 12temp 44 C
  12SMART yes 12state enabled 12health PASSED 12on 206d 10h 12cycles 3776
  12ID-4 /dev/sdc 12maj-min 8:32 12type USB 12vendor SanDisk 12model Ultra Trek 12size 57.28 GiB 12block-size
    12physical 512 B 12logical 512 B 12type N/A 12serial <filter> 12rev 1.00
  12SMART Message Unknown USB bridge. Flash drive/Unsupported enclosure?
12Partition:
  12ID-1 / 12raw-size 432.15 GiB 12size 432.15 GiB (100.00%) 12used 222.41 GiB (51.5%) 12fs btrfs
    12block-size 4096 B 12dev /dev/sda2 12maj-min 8:2
  12ID-2 /boot/efi 12raw-size 300 MiB 12size 299.4 MiB (99.80%) 12used 576 KiB (0.2%) 12fs vfat
    12block-size 512 B 12dev /dev/sda1 12maj-min 8:1
  12ID-3 /home 12raw-size 432.15 GiB 12size 432.15 GiB (100.00%) 12used 222.41 GiB (51.5%) 12fs btrfs
    12block-size 4096 B 12dev /dev/sda2 12maj-min 8:2
  12ID-4 /var/log 12raw-size 432.15 GiB 12size 432.15 GiB (100.00%) 12used 222.41 GiB (51.5%) 12fs btrfs
    12block-size 4096 B 12dev /dev/sda2 12maj-min 8:2
  12ID-5 /var/tmp 12raw-size 432.15 GiB 12size 432.15 GiB (100.00%) 12used 222.41 GiB (51.5%) 12fs btrfs
    12block-size 4096 B 12dev /dev/sda2 12maj-min 8:2
12Swap:
  12Kernel 12swappiness 133 (default 60) 12cache-pressure 100 (default)
  12ID-1 swap-1 12type zram 12size 30.28 GiB 12used 0 KiB (0.0%) 12priority 100 12dev /dev/zram0
12Sensors:
  12System Temperatures 12cpu 43.1 C 12mobo N/A 12gpu amdgpu 12temp 35.0 C
  12Fan Speeds (RPM) N/A
12Info:
  12Processes 263 12Uptime 31m 12wakeups 13 12Memory 30.28 GiB 12used 3.75 GiB (12.4%) 12Init systemd 12v 251
  12tool systemctl 12Compilers 12gcc 12.1.0 12clang 13.0.1 12Packages 1892 12note see --pkg 12apt 0 12pacman 1879
  12lib 475 12flatpak 13 12Client Unknown Client: cpuhp/ 12inxi 3.3.16
Garuda (2.6.3-2):
  System install date:     2022-01-26
  Last full system update: 2022-06-07
  Is partially upgraded:   No
  Relevant software:       NetworkManager connman
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
Running in chroot, ignoring command 'list-units'
  Failed units:   

PS - I really should know this for certain and I'm ≈95% sure that I know the answer but since the other 5% represents my data being cast into Oblivion, I wanted to double check;

if I use the Garuda Installer in the live environment and select "manual partitioning", will it simply install Garuda over/in place of the FAT32 boot partition and leave my BTRFS partition with the home folder from the borked install and other data alone? Or at least not delete it and subsequently it would be accessible from within the install after the fact?

I would imagine that if this is the case that it would come with the risk of potentially having a borked new install as well . If that were to happen, my next step would probably be to go through the BTRFS partition and decide what I'd like to keep which is pretty minimal to be honest. Just a few folders within the home folder and back those up separately for later inclusion once the install has completed and I've been able to successfully boot to it.. any thoughts? As always, they're appreciated

Thanks
PC

Hi @Boognish_Mang, I put this into a new thread because it does seem like a different set of issues than the previous thread, despite having the error message in common when trying to boot a snapshot.

This might be a good issue to focus on; it is possible the partially upgraded state is part (or all) of the reason you cannot boot.

I can see you have investigated the errors you are getting, but if you can paste the full output from the update command into the thread then the rest of us can get a better sense of what you are up against.

The installer will format over whatever data you tell it to, and likewise will leave anything you want untouched alone. You need to mount an EFI partition at /boot/efi and a root partition at /, and the root partition will need to be freshly formatted during the installation. Other than that you can basically do whatever you want.

If you want to leave the install on there alone, you will have to make sure there is another partition to install to. If you need to reduce the size of the existing partition to do that, you need to make sure you do it correctly or you will lose data (btrfs filesystem resize first, then change partition size). I recommend making any changes you need to make to the disk before getting into the installer.

If this is possible and you are considering a fresh installation, this will be the easiest way to go. If you do decide to reinstall, I would advise setting up a fresh ISO on your thumb drive. I realize that might be complicated with your broken system, but if you have a way to do it (a second thumb drive, perhaps?) I think you should.

:point_up_2: This image is pretty old. The new ISOs are better, and less chance of things going sideways if you don't have to drag the install so far to take it up to date.

4 Likes

@BluishHumility dude, THANK YOU. Sorry for the long delay. This issue has had me ripping my hair out and as such, also making many concessions that I normally wouldn't. Actually thought I had responded to this a few days ago, but apparently I never hit submit/reply on this novel length response, which full disclosure has only increased in length since.

I will (try to) post the content of the error messages I receive when trying to update via chroot as you requested/suggested, however, I may not be able to as a new development seems to be that the install that was on my NVMe drive suddenly became lost for a lack of a better way to explain it. Essentially it no longer knew what and where its mount points were. Note that while this was the case I confirmed that the content/data was all still there ...

Fast forward a day or so and suddenly I see my NVMe drive is mounted so I think, "Yay! The "lost mount points" issue seems to have corrected itself," which wouldn't have been all that surprising seeing a s how each time I would boot into the live environment, the status and location of the content/ data associated with the borked install seemed to bounce all over the place. However, on this occasion, what I came to find was that inexplicably the content of my regular SATAIII 2.5" SSD had made it's way onto the NVMe drive, seemingly doing so at the expense of all of the content that had been previously stored there.

I'm quite literally at a loss for how exactly this might have happened. The only thing I've done at all recently with that SATA 3 SSD was try to perform a fresh install over the old Garuda install that was on it and no longer needed. However this attempt failed,I believe while trying to incorporate (an already shared) grub/boot partition. There were several devices capable of booting that were sharing the NVMe drive's boot partition and there was never any issue. For that install attempt I didn't end up trying to get fancy with a manual partitioning scheme on the NVMe, electing to instead just do a "from scratch" install, i.e., erasing/formatting the entire (SATAIII SSD) disk.

The strange thing here is that while I can't access any of the data that was previously on the NVMe drive, the numbers or rather the USED% / FREE% of the drive's 500GiB leads me to believe that there may be hope yet. Though, I'm not holding my breathe and odds are looking pretty bleak

As you could probably guess, at this point I was thoroughly frustrated and fed up so in the interest of just having an install that I could boot to that was not a live environment and would persist, I performed an installation onto a 512 GB USB 3.2 flash drive. In retrospect, I should have just attempted the install in the SATAIII SSD again only creating a separate boot partition on the device rather than attempting to share the previously used GRUB, but this was to be a very temporary solution as it just so happened that while all of this was going down I had a new 2 terabyte NVMe Samsung 970 Evo Plus on its way to me, which has since arrived and is just waiting to be put to work.

I've had TAILS and other similar lightweight OS's installed on a flash drive in the past, in some cases even using ⁵ a USB 2.0 drive but Garuda is not exactly "lightweight." For this reason, I take responsibility for any performance issues that arose for no reason other than the fact that the OS was installed to a flash drive. However, despite this recognition, my tolerance for just about any issue is very low at present and in light of everything else, I'm well into the red and ready to blow a gasket (to be fair, running Garuda off of this particular flash drive has actually worked better than I had anticipated and in a lot of ways is indistinguishable from running off of a more appropriate, installed storage medium, but there were still too many hangs and random stutters to be comfortable with and combined with current frustration levels with my machine, which has basically turned me into a powder keg) and as such, I think it's probably in my own personal and in the best interest of my computers that as soon as I hit reply/submit on this post, I'm going to install the newly acquired 2TB NVMe. My machine only has room for one NVMe drive (being a 4" x 4" HTPC and all) but I have an old Intel NUC that, until recently I had been using as a LibreELEC / OpenELEC / CoreELEC box (which was running off of a 16GB USB 3.0 Flash Drive :stuck_out_tongue_closed_eyes:) so I'll be able to continue troubleshooting the problem drive from there.

I know there's a lot to digest here but my biggest concern/question now at this point - do you think there's any hope that the data that was present on the troubled NVMe might still exist somewhere and more importantly, be retrievable? I need to perform a fresh install on this new drive anyway, so fixing the original/broken install (if even possible) is no longer a priority but there were a few folders in particular that I have backed up but foolishly didn't update the backup copies that I have hosted off-device

Thanks a million for any help or insight you're able to provide! I'll see if it's still possible to chroot into the offending install to provide the pacman/Chaotic-AUR errors I was receiving, though if chroot is possible that would suggest that my concern regarding the data should be put to rest.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.