Install unreal-engine through Add/Remove Software

I want to install unreal-engine through the AUR repository with Add/Remove, and followed the steps on the wiki. The wiki doesn't cover how to do this when working outside the terminal (makes sense this is for Arch after all). I get the following error when running the build after following the steps on the wiki:

==> ERROR: You must register at unrealengine.com and link your github account to access this private repo. See the wiki for more info: https://wiki.archlinux.org/index.php/Unreal_Engine_4
Failed to build unreal-engine

This makes me think that ssh-agent is not used in this transaction during the AUR build:
git ls-remote [email protected]:EpicGames/UnrealEngine

The transaction is successful when I run this line in Konsole. Maybe go into the make PKGBUILD file and link the ssh-agent (how?).

Note: My github account ssh key is added to the ssh-agent, I did this through Konsole fish. I am also signed up to Epic's creator program and have access to the source of UE4.

Use a different helper, or ideally just use makepkg .

2 Likes

That would certainly be the easiest solution, but I wanted to solve it this way for educational purposes.

By the way I tried with pamac, and got the same error: pamac build unreal-engine

Pamac is the GUI that's also behind "Add/Remove Software", which means this could just be an issue with Pamac.

If it is then you can report it as a bug to the Pamac developers so they can fix the issue. However, the only way to check that is to try a different approach.

4 Likes

When installing a package requires user's inputs, Pamac cannot handle it yet. For such applications installing from terminal is the only way.

3 Likes

Why would there be any user input? pamac should simply use ssh-agent + git to pull from the private repository.

This guy seems to have been successful in passing this part of the build using pamac.

1 Like

Totally unrelated to your issue.

The only way to improve knowledge on this issue is to report to pamac devs, as suggested already :wink:

3 Likes

His thread subsumes my issue.

Explicit:
It is related in that he installed unreal-engine with pamac. He even wrote "fixed", at the bottom of the thread, which means he performed the task successfully.

I don't get why your post gets two likes, what is this? You just repeated what other people said, and patronized me.

Don't worry. It's just a forum bot.

Can you show me what was repeated?

The posted link points to a closed issue that even the title is self-explanatory. That one is an old issue which is fixed/embedded feature long time ago.

Your issue is about user interaction with pamac during package installation.

If you understand the above, then we have nothing else to discuss.
If you don't, DDG it.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.