Install issue for newbie

I had finally had enough of Windows garbage and decided to make the switch. Before jumping in I made an install USB of Dragonized Garuda Gaming package using Rufus and installed on an older laptop I had to get familiar and test some games and things. Everything went perfectly without issue.

Time to install on my main PC on a brand new 2TB SSD, using the same media USB, and after selecting either open source or proprietary Nvidia drivers the screen shows “Starting systemd-udevd version 254.5-1-arch” with a blinking cursor for about 30 seconds and then the PC locks up with that same message on the screen and I have no choice but to kill the power.

I’m a complete beginner to Linux in general but did a bunch of reading and tried the following things I found online:

  1. add nomodeset before quiet
  2. disabled fastboot and secure boot in my BIOS
  3. Disabled the onboard WiFi controller in the BIOS (I was getting desperate)

My system is older, using an ASUS Z170 Deluxe MB, nVidia RTX 3060Ti, and Intel i7-6700K

I’d really like to make the switch and start learning but I’m stuck at this point. Any pointers or ideas would be greatly appreciated. Please be specific and assume I know nothing lol. Thanks!

Use normal Dragon (dowload from Garuda home page) check shasum, install later over garuda-gamer app what you need.
Use for easy USB handling.
Use also Nvidia. No need for disabling onboard WiFi.

Start using the garuda-wiki and forum search, procedure is explained 1 million times :slight_smile:


Thanks for the reply. I followed your suggestion and made a new USB using Ventoy, with out the gaming edition, and verified. Booted up great and I ran the installer on my new SSD with all defaults. Feeling pretty good when I clicked restart at the end of the install and then it rebooted to this:

Booting Garuda Linux
Loading linux linux-zen…
Loading initial ramdisk…
and the box locks up hard again :confounded:

Tried restarting, same thing. I figured maybe something with the install went bad even though it didn’t say, so I tried booting to my USB again and now I am back to the same issue I started this post with:

systemd-udevd locks up. I even made a new USB from scratch the same way and get the same lock up. Maybe this hardware just isn’t compatible and I should try again next year when I plan on building a new machine.

Thanks for the help anyway, I do appreciate the effort.

Just post the garuda-inxi from live ISO, so we can check your hardware, if live ISO boot there is away to install Garuda :slight_smile:


Just a shot in the dark: make sure in your BIOS the SATA controller is set to AHCI, as opposed to RAID or similar


@filo I had found that on the forums before I posted and checked it but forgot to mention it in my post, sorry that’s on me. I’m going to make a brand new USB using the same steps I did the 1 time it loaded the live ISO and I was able to install. If that works I will grab the file SGS requested before it locks up but if not maybe this is a sign I should update my machine sooner rather than later :grin:

Thank you for the advice

1 Like

Are you certain it is locked up? See if you can switch to a TTY.

Ctrl+Alt+F2 (or other F keys).


Unfortunately it’s locked up, no keys work, I can even change any of the lock keys (num lock) until it locks up, then nothing. I made a brand new USB at work and tried that but same results.

My last attempt was to try the (recovery mode) option in the startup menu from the SSD that installed once and that starts to run commands but then gets to the last line:

“A stop job is running for Rule-based Manager for Device Events and Files” with a counter but after about 30 to 34 seconds it locks up the PC again and I have to power it off.

I use a gaming keyboard and mouse and even though they are USB I tried just generic ones as well as disabling some of the on board devices I don’t need but it just doesn’t like my hardware I guess and I don’t know enough to keep going. Thanks for all the advice and hopefully I’ll be back later this year when I build my new machine.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.