Inspiron blank screen after boot splash with later kernels

After an update a month or more ago, I think when the the switch to the 6.2 kernel series occurred, I stopped being able to boot my system, an Inspiron 7610. I get the boot menu, then the loading splash screen, then a blank screen (apart from a KDFONTOP message or similar). I can boot an LTS kernel, and that is what I'm using now. Unfortunately, I can't post a garuda-inxi of the failed system as I can't access it. The data for my working system is below. I haven't found any similar references, which is surprising, but does anyone have any ideas? I have tried with both the latest zen kernel and a recent vanilla kernel with the same result.

The boot parameters for the problem boot and the current system appear to be the same.

  Kernel: 6.1.28-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=f02c5d5a-67c0-42e2-bb12-69a48f130c56 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: KDE Plasma v: 5.27.5 tk: Qt v: 5.15.9 info: latte-dock
    wm: kwin_x11 dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: Dell product: Inspiron 16 7610 v: N/A serial: <filter>
    Chassis: type: 10 serial: <filter>
  Mobo: Dell model: 1VFRT8 v: A01 serial: <filter> UEFI: Dell v: 1.8.0
    date: 05/09/2022
  ID-1: BAT0 charge: 44.2 Wh (100.0%) condition: 44.2/54.9 Wh (80.4%)
    volts: 12.5 min: 11.4 model: SMP DELL P8P1P95 type: Li-poly serial: <filter>
    status: full
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: 11th Gen Intel Core i5-11400H socket: U3E1 bits: 64
    type: MT MCP arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
    process: Intel 10nm family: 6 model-id: 0x8D (141) stepping: 1
    microcode: 0x44
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 480 KiB desc: d-6x48 KiB; i-6x32 KiB L2: 7.5 MiB desc: 6x1.2 MiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2013 high: 2700 min/max: 800/4500 base/boost: 2673/4500
    scaling: driver: intel_pstate governor: powersave volts: 0.8 V
    ext-clock: 100 MHz cores: 1: 1064 2: 2700 3: 2700 4: 2700 5: 1119 6: 2700
    7: 2700 8: 2700 9: 1032 10: 1031 11: 2700 12: 1017 bogomips: 64536
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Dell driver: i915
    v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports:
    active: HDMI-A-1,eDP-1 empty: DP-1, DP-2, DP-3, DP-4 bus-ID: 0000:00:02.0
    chip-ID: 8086:9a68 class-ID: 0300
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: Dell
    driver: nouveau v: kernel non-free: 530.xx+ status: current (as of 2023-05)
    arch: Ampere code: GAxxx process: TSMC n7 (7nm) built: 2020-22
    bus-ID: 0000:01:00.0 chip-ID: 10de:25a2 class-ID: 0302
  Device-3: Sunplus Innovation Integrated_Webcam_HD driver: uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-5:3
    chip-ID: 1bcf:2a02 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
    compositor: kwin_x11 driver: X: loaded: modesetting,nouveau
    alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 6912x2160 s-dpi: 96 s-size: 1827x571mm (71.93x22.48")
    s-diag: 1914mm (75.36")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: top-right model: Philips PHL 288E2
    serial: <filter> built: 2022 res: 3840x2160 hz: 60 dpi: 157 gamma: 1.2
    size: 621x341mm (24.45x13.43") diag: 708mm (27.9") ratio: 16:9 modes:
    max: 3840x2160 min: 720x400
  Monitor-2: eDP-1 pos: primary,bottom-l model: AU Optronics 0xc99e
    built: 2020 res: 3072x1920 hz: 60 dpi: 227 gamma: 1.2
    size: 344x215mm (13.54x8.46") diag: 406mm (16") ratio: 16:10
    modes: 3072x1920
  API: OpenGL v: 4.6 Mesa 23.0.3 renderer: Mesa Intel UHD Graphics (TGL GT1)
    direct-render: Yes
  Device-1: Intel Tiger Lake-H HD Audio vendor: Dell
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
    chip-ID: 8086:43c8 class-ID: 0401
  API: ALSA v: k6.1.28-1-lts status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 0.3.70 status: n/a (root, process) with:
    1: pipewire-pulse status: active 2: wireplumber status: active
    3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:43f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-14:5 chip-ID: 8087:0026
    class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev: class-ID: 0104
  Local Storage: total: 6.83 TiB used: 585.68 GiB (8.4%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 2TB size: 1.82 TiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 2B2QEXM7 temp: 44.9 C scheme: GPT
  SMART: yes health: PASSED on: 12d 14h cycles: 416
    read-units: 11,648,360 [5.96 TB] written-units: 6,811,326 [3.48 TB]
  ID-2: /dev/nvme1n1 maj-min: 259:6 vendor: Toshiba model: KBG40ZNS512G
    NVMe KIOXIA 512GB size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 10410106 temp: 55.9 C scheme: GPT
  SMART: yes health: PASSED on: 186d 4h cycles: 419
    read-units: 24,814,856 [12.7 TB] written-units: 22,270,179 [11.4 TB]
  ID-3: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD50NMZM-59A8XS1 size: 4.55 TiB block-size: physical: 4096 B
    logical: 512 B type: USB rev: 3.1 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1
    tech: HDD rpm: 5400 serial: <filter> fw-rev: 2007 scheme: GPT
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 39.96 GiB size: 39.96 GiB (100.00%)
    used: 25.16 GiB (62.9%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%)
    used: 110.8 MiB (22.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  ID-3: /home raw-size: 1.72 TiB size: 1.72 TiB (100.00%)
    used: 560.41 GiB (31.8%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p3
    maj-min: 259:3
  ID-4: /var/log raw-size: 39.96 GiB size: 39.96 GiB (100.00%)
    used: 25.16 GiB (62.9%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-5: /var/tmp raw-size: 39.96 GiB size: 39.96 GiB (100.00%)
    used: 25.16 GiB (62.9%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.1 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 32.27 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p4 maj-min: 259:4
  System Temperatures: cpu: 38.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 350 Uptime: 1h 5m wakeups: 8 Memory: available: 31.1 GiB
  used: 5.44 GiB (17.5%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1642 libs: 399 tools: octopi,pamac,paru,yay pm: flatpak pkgs: 0
  Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: alacritty
  inxi: 3.3.27
Garuda (2.6.16-1):
  System install date:     2023-04-21
  Last full system update: 2023-05-14
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio
  Windows dual boot:       Yes
  Failed units:

Welcome :slight_smile:

Just try this

1 Like

Text consoles are not available with the current kernel, so I can't run commands from that environment. The absence of text consoles also suggests to me that the boot has stalled or failed at some early stage. I have run all the suggested commands from the working installation.

Another note: I can boot into recovery mode from the current kernel, so the basic kernel is working. In consequence, I think it is likely to be some sort of graphics driver problem.

The problem has persisted for an extended period through many updates, so cannot really be incomplete mirrors. sudo dkms autoinstall does nothing. garuda-update has been run multiple times without impact on the issue.

Did you chroot via live ISO?

1 Like

The live ISO I used was bootable after install as long as the install disk was booted using free drivers. The problem only shows after the first update following install. I've done this experiment a couple of times.

Ok, I have no experience with dual GPU notebooks, did you check the forum about?

1 Like

since you have no problems booting with the lts kernel could it be that you have a corrupt download for that other kernel. :thinking:

try reinstalling that kernel along with its headers for eg if the name of kernel is linux-zen then

first you should clean your cache directory so that pacman pulls a fresh copy of linux-zen instead of just reinstalling the corrupt package

sudo paccache -rk0

then redownload the package

garuda-update -- linux-zen linux-zen-headers

Try rebuilding the initramfs. From the chroot, run:

mkinitcpio -P


This should automatically kick off the initramfs generation as well.

If you rebuild the image and still cannot boot, we will have to take a look at /etc/mkinitcpio.conf to check for a bad hooks configuration.


Ok, so I think I have this fixed. Re-installing the kernel didn't work, but blacklisting and completely disabling the nouveau driver seems to have fixed the issue - for me at least as at the moment I don't use the nvidia card. Thanks to SGS for prompting this experiment. This will also likely save some watts when on battery as the nvidia card is now powered down.

Interesting--that's an odd one.

If you ever want to start using the driver, installing the proprietary version is likely to work since it also blacklists Nouveau as part of the installation.

You may also be interested in this guide, which explains how to set up the dGPU so it is only used when you explicitly call for it (starting a game or something, for example)--otherwise the iGPU is used, to conserve resources as you mentioned:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.