Insert key toggles airplane mode

  Kernel: 5.16.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=0db6fcc5-4934-4f6b-862c-21893cbeec24 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: GNOME 41.3 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.3
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 82LM v: IdeaPad 5 14ALC05
    serial: <superuser required> Chassis: type: 10 v: IdeaPad 5 14ALC05
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN
    serial: <superuser required> UEFI: LENOVO v: G5CN20WW(V1.08)
    date: 06/30/2021
Battery:
  ID-1: BAT1 charge: 50.9 Wh (87.0%) condition: 58.5/56.5 Wh (103.6%)
    volts: 12.4 min: 11.5 model: 0x53 0x4D 0x50 0x00 0x32 0x30 0x 0x4C 0x31
    0x39 0x4D 0x33 0x50 0x5650
    type: Li-ion serial: <filter> status: Discharging cycles: 4
CPU:
  Info: model: AMD Ryzen 5 5500U with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 family: 0x17 (23) model-id: 0x68 (104) stepping: 1
    microcode: 0x8608103
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 8 MiB desc: 2x4 MiB
  Speed (MHz): avg: 1398 high: 1418 min/max: 1400/4056 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1397 2: 1397
    3: 1397 4: 1397 5: 1397 6: 1397 7: 1397 8: 1397 9: 1397 10: 1418 11: 1397
    12: 1397 bogomips: 50307
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Lucienne vendor: Lenovo driver: amdgpu v: kernel
    bus-ID: 04:00.0 chip-ID: 1002:164c class-ID: 0300
  Device-2: Syntek Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-3:2 chip-ID: 174f:2459 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org 1.21.1.3 compositor: gnome-shell driver:
    loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
    display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 158 size: 309x173mm (12.2x6.8")
    diag: 354mm (13.9")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 04:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
    vendor: Lenovo driver: snd_rn_pci_acp3x v: kernel
    alternate: snd_pci_acp3x,snd_pci_acp5x,snd_pci_acp6x bus-ID: 04:00.5
    chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.8-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.45 running: yes
Network:
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
    vendor: Lenovo driver: rtw_8822ce v: N/A modules: rtw88_8822ce port: 2000
    bus-ID: 03:00.0 chip-ID: 10ec:c822 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 3-4:3 chip-ID: 0bda:c123 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 18 state: up address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 18.61 GiB (3.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: MTFDHBA512QFD
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 0002P6LN
    temp: 36.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 18.61 GiB (3.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 18.61 GiB (3.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 18.61 GiB (3.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 18.61 GiB (3.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.03 GiB used: 882.8 MiB (5.7%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 46.0 C mobo: N/A gpu: amdgpu temp: 42.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 355 Uptime: 2d 18h 3m wakeups: 21592 Memory: 15.03 GiB
  used: 5.15 GiB (34.3%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.1 Packages: pacman: 1147 lib: 311 Shell: fish
  v: 3.3.1 default: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.12
Garuda (2.5.4-2):
  System install date:     2022-02-10
  Last full system update: 2022-02-15
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units: 

Hey there! On my Lenovo Ideapad 5 14 something, when i press the insert key it toggles airplane mode, i have to press fn. The issue actually persists when i hit the FnLock key, which should invert having to press fn for the actual actions. Is there any place where i can disable this functionality? I would like for my insert key to work as normal, without it running the airplane mode command.

Any help will be much appreciated :slight_smile:

Read the manual or try FN + Esc

and
:slight_smile:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.