Inkscape Will Not Start

As the title says. I have tried reinstalling it but no luck. Here is the output when I run it in terminal;

inkscape: symbol lookup error: /usr/bin/../lib/inkscape/../libpoppler-gli undefined symbol: _ZN22MarkedContentOutputDevC1EiRK6Object

Apps going crazy lately. :crazy_face:

Wow, you sure have been experiencing a lot of problems lately. I've started to wonder if you've fundamentally messed your system somehow by tinkering with something you shouldn't have.

I'm not trying to be insulting. I know you are a very compent long time Linux user, and that makes it all the more baffling. I have no idea what's going on with your system of late, but something seems amiss.

Anyways, back to your current dilemma. Perhaps try installing inkscape-git to see if it provides any improvement.

Good luck with your issues @RodneyCK

1 Like

I am messy. Just say it. :rofl:

Actually, after lots of toiling and bubbling brews, I found a solution, and the problem....which is kind of on Garuda, I guess.

I did try and build the .git version, gave me Gentoo PTSD, as it takes ...FOREVER. It ended in errors, so it never worked. I then looked at Poppler and noticed that on my laptop where Inkscape works I was using the 'Poppler-glib' from the extra/repo. My PC was using the version from Chaotic-aur. I switched it out to the extra version, and boom...BOOM, Inkscape opened and ran. So, someone on the G-team might want to look into it.

Thanks for your reply and help. I am off to vector-ize some art. :stuck_out_tongue_winking_eye:


I will ping @dr460nf1r3 for you and perhaps Nico can look into this issue.

Nice detective work on your part. Sorry for putting it on you, if this was a distro created problem.


No problem, I would pin it on my shady arse too. :rofl:



What version(s) of poppler packages do you have installed, and are they up-to-date?

I now have poppler-glib version 21.10.0-1on both systems from the "extra" repos .

The one that breaks Inkscape is from chaotic-aur 'poppler-glib-git' version 21.10.0.r14.g24d0445a-1. I think this is the version that is pulled in when you select Inkscape for install with Garuda's setup assistant.


I'd avoid -git packages unless you have a specific need for them.

In this case, it looks like the package in Chaotic-AUR needs a rebuild.

Hmm. Tooling should only really pull in standard packages... :thinking:

1 Like

I updated to add, it is pulled in automatically via Garuda's setup assistant.

1 Like

So did I. :grin:

If this is a package selection issue then it needs to be looked into, though it might be something caused by an older installer image (I know there were various -git packages included previously).


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.