Initial ramdisk

Hello. I use MacBook pro and have garuda and mac in the same laptop and I use grub2. But after i updated my graphic card in garuda assistant, and reboot, it stuck on the initial ramdisk. So i think the problem is grub2 somehow. I read lots of articles but i couldn't make it work. I find Linux line and add 'nomodest' after quiet ( also i have 2 quiet after each other and some lines after that. ). When i go in recovery-mode, my garuda works. But when I reboot and start normally, It stuck in the initial ramdisk. So now how can i change it so that my garuda works?

I’m not sure the following solution matches with your issue (yours could be related to GPU drivers, I see), but recently we had an issue occurring on most of the KDE implementations.
By-the-way, we would need your garuda-inxi, as requested by the template.

If you don’t have a KDE edition, or anyway the solution above does not work for you, maybe the best thing would be restoring the latest working snapshot, provide the garuda-inxi, and describe better what you did when the issue occurred.

1 Like

nope. it doesn't work for me. As I search the initial ramdisk is related to GPU somehow.
I try to add nomodeset . but it doesn't work

linux /boot/vmlinuz-linux root=/dev/sdXY rw quiet nomodeset quite splash rd.udev.log_priority=3 .....

Well the post says to remove the "splash" parameter.

1 Like

yes I know and i did that . and not work for me. but I update my grub (in recovery mode) with 'sudo update-grub' (and also restored my garuda to my previous restore) & after restarting, my garuda come up .but somehow I can not change my resolution. and stuck on 2880x1800. but Linux recognizes my graphic card.

It looks like a recently recurring and still unsolved issue:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.