Infinite Bootlooping when trying to load Garuda

I wanted to try to download Garuda on my Thinkpad dualbooted with Windows since I still need it for reasons.

However, when I downloaded the iso and loaded it onto my pendrive using Rufus, and tried to load it from my bootloader menu, it returned me back to my bootloader menu (I can send a video if it's needed) and it leads to this infinite bootlooping.

One of my friends told me that it might be due to a bug in the later models of grub, because the loading process worked very well with Linux Mint.

Is there a fix to this in any way, or will I have to wait for the grub issue to be fixed?

Thank you

Welcome :slight_smile:

Use Ventoy not Rufus.


Do you mean the menu with Garuda Linux icon with choices like Nvidia, No nvidia or UEFI menu?
Do you get any error messages?


Just to confirm have you:

1. Disable fastboot and secure boot. It may not be possible to disable the latter explicitly - try clearing the secure boot keys instead. Check the manual of your device/motherboard for further info.
2. Make sure that your device's SATA controller is set to AHCI mode in your device's setup utility. Otherwise, the Linux kernel may not be able to detect your drive.
3. If your firmware supports UEFI then configure your device to use UEFI only in its setup utility. UEFI is much preferred over BIOS whenever possible.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.