Improve sound quality

Hey Guys,

i need your help and knowledge again, sorry for that.

I run Garadu Linux and i have noticed, that the sound output over the internal speaker is very bad.
With very bad i mean to much bass, dull (i don’t know that this is right the right word for that) and the speaker begins to clutter around 40 till 50 %.

I have installed besides pipewire the JACK Support. But it doesn’t help. And other combinations doesn’t work on my laptop.

Here are the output of garuda-inxi

Kernel: 6.6.0-rc1-1-mainline arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-mainline
root=UUID=2b867869-1b5c-433f-84da-0008fde9aaf5 rw rootflags=subvol=@
intel_pstate=passive intel_pstate=no_hwp usbcore.autosuspend=-1
ipv6.disable=1 quiet quiet rd.udev.log_priority=3
vt.global_cursor_default=0 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: ASUSTeK product: ROG Strix G733ZW_G733ZW v: 1.0
serial: <superuser required>
Mobo: ASUSTeK model: G733ZW v: 1.0 serial: <superuser required>
UEFI: American Megatrends LLC. v: G733ZW.324 date: 02/21/2023
ID-1: BAT0 charge: 83.2 Wh (100.0%) condition: 83.2/90.0 Wh (92.5%)
volts: 17.0 min: 15.9 model: AS3GWYF3KC GA50358 type: Unknown
serial: <filter> status: full
Info: model: 12th Gen Intel Core i9-12900H bits: 64 type: MST AMCP
arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
microcode: 0x42C
Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 930 high: 5000 min/max: 400/5000 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 773 2: 400 3: 400 4: 400
5: 711 6: 400 7: 400 8: 400 9: 400 10: 400 11: 736 12: 400 13: 400
14: 1070 15: 400 16: 400 17: 2300 18: 2820 19: 400 20: 5000
bogomips: 116780
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Alder Lake-P Integrated Graphics vendor: ASUSTeK
driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
ports: active: none empty: DP-1,DP-2 bus-ID: 00:02.0 chip-ID: 8086:46a6
class-ID: 0380
Device-2: NVIDIA GA104 [Geforce RTX 3070 Ti Laptop GPU] vendor: ASUSTeK
driver: nvidia v: 535.104.05 alternate: nouveau,nvidia_drm non-free: 535.xx+
status: current (as of 2023-08) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 2 speed: 5 GT/s lanes: 8
link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.0
chip-ID: 10de:24a0 class-ID: 0300
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0
compositor: kwin_x11 driver: X: loaded: modesetting,nouveau,nvidia
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915,nvidia display-ID: :0
screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 171 s-size: 380x210mm (14.96x8.27")
s-diag: 434mm (17.09")
Monitor-1: DP-2 pos: primary res: 2560x1440 dpi: 171
size: 380x210mm (14.96x8.27") diag: 434mm (17.09") modes: N/A
Monitor-2: None-2-1 size-res: N/A modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 535.104.05 renderer: NVIDIA GeForce RTX 3070
Ti Laptop GPU/PCIe/SSE2 direct-render: Yes
Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 00:1f.3 chip-ID: 8086:51c8 class-ID: 0403
Device-2: NVIDIA GA104 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 8
link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:228b class-ID: 0403
API: ALSA v: k6.6.0-rc1-1-mainline status: kernel-api tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.80 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
pcie: speed: Unknown lanes: 63 link-max: gen: 6 speed: 64 GT/s port: 3000
bus-ID: 2e:00.0 chip-ID: 10ec:8125 class-ID: 0200
IF: enp46s0 state: down mac: <filter>
Device-1: Intel driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 3-10:4 chip-ID: 8087:0033 class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.3
lmp-v: 12 status: discoverable: no pairing: no class-ID: 7c010c
Local Storage: total: 1.86 TiB used: 52.67 GiB (2.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:3 vendor: Micron model: 3400 MTFDKBA1T0TFH
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: P7MA001 temp: 29.9 C
scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Western Digital model: PC SN530
SDBPNPZ-1T00-1014 size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 21103900 temp: 28.9 C scheme: GPT
ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 52.67 GiB (5.5%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 580 KiB (0.2%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:1
ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 52.67 GiB (5.5%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 52.67 GiB (5.5%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 52.67 GiB (5.5%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 31.01 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 20 dev: /dev/zram0
System Temperatures: cpu: 40.0 C mobo: N/A gpu: nvidia temp: 44 C
Fan Speeds (rpm): cpu: 5600
Processes: 408 Uptime: 10m wakeups: 2 Memory: total: 32 GiB
available: 31.01 GiB used: 4.25 GiB (13.7%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 alt: 12
clang: 16.0.6 Packages: 1584 pm: pacman pkgs: 1511 libs: 367
tools: gnome-software,octopi,pamac,paru pm: flatpak pkgs: 73 Shell: fish
v: 3.6.1 running-in: konsole inxi: 3.3.29
Garuda (2.6.16-1):
System install date:     2023-09-14
Last full system update: 2023-09-17
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

What i can try to get an louder, clearer sound with more heights and less bass?

Thank you very much for reading and answering. Greetings from Germany.

have u tried this wiki

1 Like

He is using Pipewire not ALSA, so that Wiki might not help a lot.

Sorry OP but I don’t have any advice because I’ve actually experienced the opposite. Granted, I’m using a USB DAC, but my sound quality has been vastly superior on Linux compared to Windows. Crystal clear highs and mids, like a night and day difference.

1 Like

You could try use a program like jamesDSP or easyeffects to compensate by reducing the bass and whatever else you might need, but they might end up introducing problems of their own.


I think this is a good suggestion. Check out @dr460nf1r3’s links on this other thread to set yourself up with some pre-configured options that have been popular in the community:


Thank you guys for all your input. That’s awesome.
This is unusual, that i don’t see your answers until now.
Is it may be usefull to try other kernels? Or can’t be my problem kernel releated?

Thanks again for the hint with JamesDSP and Easyeffects.
I will try this too.

Doubt it will make a difference but what’s the harm in trying? Easy to switch in Garuda Assistant.

1 Like

Hey guys,

so, i make some progress on my sound problem.
First i play around with JamesDSP first and then withEasyeffect only.
The results - we say here in Germany - are not the yellow from the egg. That means, yes you can hear improvements but - in short - thats not enough that you can say yeah the sound is now good or great.

Then i make changes on the pipewire.conf in /usr/share/pipewire and set this values:

default.clock.quantum = 32
default.clock.min-quantum = 32
default.clock.max-quantum = 768

With this changes i can hear big improvements.
Then i installed JamesDSP again und copied the presets for JamesDSP in .config/jamesdsp/irs.
I choose voice.irs and set the all bands from the equalizer to 12 db.

What i should say: now i have a very good sound experience. May be i will play around with the values in the pipewire.conf later, but for now it’s an awesome result.

Many thanks from the buttom of my heart for your help and sharing your knowledge to me.

One quick question at last: can i mark more than one post as a solution? Or is that not possible?


Trau dich, bist ja sonst auch nicht so schüchtern

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.