I'm having trouble running my console emulator in quake mode

System:
  Kernel: 6.0.3-2-cachyos arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cachyos
    root=UUID=952eaeec-7025-4a75-845b-9396911526a6 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=fdc5ecaf-2802-4a71-9089-200bfcfa40a3 loglevel=3
    mitigations=off sysrq_always_enabled=1 systemd.unified_cgroup_hierarchy=1
  Desktop: KDE Plasma v: 5.26.1 tk: Qt v: 5.15.6 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 20BU000AUS v: ThinkPad T450
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20BU000AUS v: SDK0E50510 WIN
    serial: <superuser required> UEFI-[Legacy]: LENOVO v: JBET73WW (1.37 )
    date: 08/14/2019
Battery:
  ID-1: BAT0 charge: 17.6 Wh (100.0%) condition: 17.6/23.5 Wh (74.8%)
    volts: 12.5 min: 11.4 model: LGC 45N1113 type: Li-ion serial: <filter>
    status: full
  ID-2: BAT1 charge: 8.8 Wh (50.6%) condition: 17.4/23.2 Wh (74.8%)
    volts: 12.0 min: 11.1 model: SANYO 45N1775 type: Li-ion serial: <filter>
    status: charging
CPU:
  Info: model: Intel Core i5-5300U bits: 64 type: MT MCP arch: Broadwell
    gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
    family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 2352 high: 2474 min/max: 500/2900 scaling:
    driver: intel_cpufreq governor: performance cores: 1: 2474 2: 2295 3: 2295
    4: 2344 bogomips: 18379
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: vulnerable
  Type: mds status: Vulnerable; SMT vulnerable
  Type: meltdown status: Vulnerable
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1 status: Vulnerable: __user pointer sanitization and
    usercopy barriers only; no swapgs barriers
  Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled,
    PBRSB-eIBRS: Not affected
  Type: srbds status: Vulnerable
  Type: tsx_async_abort status: Vulnerable
Graphics:
  Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel
    arch: Gen-8 process: Intel 14nm built: 2014-15 ports: active: eDP-1
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:1616
    class-ID: 0300
  Device-2: Lite-On Integrated Camera type: USB driver: uvcvideo
    bus-ID: 2-8:4 chip-ID: 04ca:703c class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.4
    compositor: kwin_x11 driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.65x9.37")
    s-diag: 485mm (19.11")
  Monitor-1: eDP-1 model: AU Optronics 0x303e built: 2012 res: 1600x900
    hz: 60 dpi: 132 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
    ratio: 16:9 modes: 1600x900
  OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa
    22.2.1 direct render: Yes
Audio:
  Device-1: Intel Broadwell-U Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
    class-ID: 0403
  Sound API: ALSA v: k6.0.3-2-cachyos running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Intel Ethernet I218-LM vendor: Lenovo driver: e1000e v: kernel
    port: 3080 bus-ID: 00:19.0 chip-ID: 8086:15a2 class-ID: 0200
  IF: enp0s25 state: down mac: <filter>
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:095b class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  IF-ID-1: anbox0 state: down mac: <filter>
  IF-ID-2: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 2-7:3 chip-ID: 8087:0a2a class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
  Local Storage: total: 238.47 GiB used: 122.21 GiB (51.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Silicon Power model: SPCC Solid State
    Disk size: 238.47 GiB block-size: physical: 512 B logical: 512 B
    speed: 6.0 Gb/s type: SSD serial: <filter> rev: 91.3 scheme: MBR
Partition:
  ID-1: / raw-size: 229.67 GiB size: 229.67 GiB (100.00%) used: 122.21 GiB
    (53.2%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /home raw-size: 229.67 GiB size: 229.67 GiB (100.00%) used: 122.21
    GiB (53.2%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-3: /var/log raw-size: 229.67 GiB size: 229.67 GiB (100.00%) used: 122.21
    GiB (53.2%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-4: /var/tmp raw-size: 229.67 GiB size: 229.67 GiB (100.00%) used: 122.21
    GiB (53.2%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.47 GiB used: 347.2 MiB (4.5%)
    priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda2 maj-min: 8:2
Sensors:
  System Temperatures: cpu: 60.0 C pch: 53.5 C mobo: N/A
  Fan Speeds (RPM): fan-1: 3598
Info:
  Processes: 230 Uptime: 54m wakeups: 1 Memory: 7.47 GiB used: 4.05 GiB
  (54.2%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1987
  libs: 387 tools: aura,octopi,paru Shell: fish v: 3.5.1 running-in: tilix
  inxi: 3.3.22
Garuda (2.6.9-1):
  System install date:     2022-10-04
  Last full system update: 2022-10-23 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Snapper
  Failed units:   

I'm using tilix for the console and when I try to run tilix -q to run in quake mode (opening the dropdown console window), it opens maximized instead of only taking up 40% of the top of the screen.

Is there some setting that forces all windows to open maximized or something?

How do I get tilix --quake

Nothing in

?

nope this documentation doesnt help

also, ive never had this issue with any other desktop environment. thats why im posting the question in this forum

Perhaps you have been lucky; it looks like this has been an issue for years:

A couple things you could try:

  • Switch to Wayland
  • Turn off the compositor
  • If turning off the compositor helps but you would rather leave it on, try disabling animations a few at a time to see if you can identity a problematic one.
1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.