IDrive Internet backup solution

Hi everyone! Is there someone who has experience in trying to implement IDrive backup in Garuda Dragonized? This has to be done with scripts that are provided by IDrive for Linux users. (They have no GUI solution for Linux.)
I had it working on Linux Mint, but when I tried to run the setup script on Garuda, I ran into a problem. This is the copy from the command line screen:

'Your service directory is: /home/johann/Downloads/Idrive/IDriveForLi
nux/idriveIt
Argument "Soaring" isn't numeric in numeric ne (!=) at Idrivelib/lib
/[Common.pm](http://common.pm/) line 7278.
Argument "Soaring" isn't numeric in numeric ne (!=) at Idrivelib/lib
/[Common.pm](http://common.pm/) line 7278.

Prerequisites are not met. Unable to identify your operating system
requirements.'

So I gather they have a problem with the Linux version? The script version is June 2022, afaik.
Now I don't want to (and am not capable of) modifying their script. What can I do?

Try to install the Win app under Wine, Bottles or .... ?

As requested, this is the inxi output

System:
  Kernel: 6.1.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc
    v: 12.2.0 parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=48cd2da8-53a0-4027-928a-20ce3dc707ba rw
    [email protected] quiet quiet splash rd.udev.log_priority=3
    vt.global_cursor_default=0
    resume=UUID=714d68c7-235d-49a0-91c3-0064a8a1074f loglevel=3
    ibt=off
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.7 info: plank
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
    base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: P8H67-M PRO v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 3904
    date: 04/27/2013
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K270
    serial: <filter> charge: 100% (should be ignored)
    rechargeable: yes status: discharging
CPU:
  Info: model: Intel Core i7-3770K bits: 64 type: MT MCP
    arch: Ivy Bridge gen: core 3 level: v2 built: 2012-15
    process: Intel 22nm family: 6 model-id: 0x3A (58) stepping: 9
    microcode: 0x21
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled
    cache: L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB
    desc: 4x256 KiB L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 3900 min/max: 1600/3900 scaling:
    driver: intel_cpufreq governor: performance cores: 1: 3900
    2: 3900 3: 3900 4: 3900 5: 3900 6: 3900 7: 3900 8: 3900
    bogomips: 57683
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: Intel IvyBridge GT2 [HD Graphics 4000] vendor: ASUSTeK
    driver: i915 v: kernel arch: Gen-7 process: Intel 22nm
    built: 2012-13 ports: active: HDMI-A-2 empty: DP-1, DP-2,
    HDMI-A-1, VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0162
    class-ID: 0300
  Device-2: Generalplus 808 Camera type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 2-1.3:7
    chip-ID: 1b3f:2002 class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
    compositor: kwin_x11 driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: crocus gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96
    s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-2 mapped: HDMI-2 model: BenQ GW2780
    serial: <filter> built: 2017 res: 1920x1080 hz: 60 dpi: 82
    gamma: 1.2 size: 598x336mm (23.54x13.23") diag: 686mm (27")
    ratio: 16:9 modes: max: 1920x1080 min: 720x400
  API: OpenGL v: 4.2 Mesa 22.3.2 renderer: Mesa Intel HD
    Graphics 4000 (IVB GT2) direct render: Yes
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition
    Audio vendor: ASUSTeK P8H67 driver: snd_hda_intel
    bus-ID: 2-1.3:7 v: kernel bus-ID: 00:1b.0 chip-ID: 1b3f:2002
    class-ID: 0102 chip-ID: 8086:1c20 class-ID: 0403
    serial: <filter>
  Device-2: Generalplus 808 Camera type: USB
    driver: snd-usb-audio,uvcvideo
  Device-3: Creative USB Sound Blaster HD type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-1.4:5
    chip-ID: 041e:30d7 class-ID: 0300 serial: <filter>
  Sound API: ALSA v: k6.1.3-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK P8P67 and other motherboards driver: r8169
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
    bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full
    mac: <filter>
  Device-2: TP-Link TL-WN823N v2/v3 [Realtek RTL8192EU]
    type: USB driver: rtl8xxxu bus-ID: 3-1.3:4 chip-ID: 2357:0109
    class-ID: 0000 serial: <filter>
  IF: wlp1s0u1u3 state: down mac: <filter>
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode)
    type: USB driver: btusb v: 0.8 bus-ID: 7-1:2 chip-ID: 0a12:0001
    class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: no
    address: <filter>
Drives:
  Local Storage: total: 5.46 TiB used: 1.26 TiB (23.0%)
  SMART Message: Unable to run smartctl. Root privileges
    required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung
    model: SSD 870 QVO 2TB size: 1.82 TiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
    serial: <filter> rev: 2B6Q scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate
    model: ST1000DX002-2DV162 size: 931.51 GiB block-size:
    physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD
    rpm: 7200 serial: <filter> rev: CC41 scheme: MBR
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD20EZBX-00AYRA0 size: 1.82 TiB block-size:
    physical: 4096 B logical: 512 B speed: 3.0 Gb/s type: HDD
    rpm: 7200 serial: <filter> rev: 1A01 scheme: MBR
  ID-4: /dev/sdd maj-min: 8:48 vendor: Seagate
    model: ST31000528AS size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 7200
    serial: <filter> rev: CC49 scheme: MBR
Partition:
  ID-1: / raw-size: 195.31 GiB size: 195.31 GiB (100.00%)
    used: 15.27 GiB (7.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 608 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 1.61 TiB size: 1.58 TiB (98.37%)
    used: 1.24 TiB (78.4%) fs: ext4 dev: /dev/sda3 maj-min: 8:3
  ID-4: /var/log raw-size: 195.31 GiB size: 195.31 GiB (100.00%)
    used: 15.27 GiB (7.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 195.31 GiB size: 195.31 GiB (100.00%)
    used: 15.27 GiB (7.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60)
    cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 10.66 GiB
    used: 0 KiB (0.0%) priority: -2 dev: /dev/sda4 maj-min: 8:4
  ID-2: swap-2 type: zram size: 11.4 GiB used: 0 KiB (0.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 30.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 244 Uptime: 6h 25m wakeups: 55 Memory: 11.4 GiB
  used: 2.68 GiB (23.5%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages:
  pm: pacman pkgs: 1596 libs: 406
  tools: gnome-software,octopi,pamac,paru pm: appimage pkgs: 0
  Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.24
Garuda (2.6.14-1):
  System install date:     2023-01-05
  Last full system update: 2023-01-06
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio
  Windows dual boot:       No/Undetected
  Failed units:

And: Yes, I have contacted IDrive, but they only told me try the script again.

Please edit your post and add input and output from

garuda-inxi

It is best to ask iDrive if you need assistance.

1 Like

Added the inxi.
Their support is not really helpful. Try the scripts again, they said

Which offer do you use?
Without posting the script, no one here will be able to help.

Please understand that the Garuda Forum cannot provide support for any existing software, especially those that are not open source and have commercial goals.

2 Likes

Take a look at this thread, it looks like some hacking around in the script may be necessary:

1 Like

Thanks for that. I'm afraid I'm too stupid to understand that.
But in the post they talk about scripts for Arch being available. Let me try to get those before I start tinkering around myself...

Of course I understand. But if you don't ask you never know. It's not impossible that someone has come up with a solution (like the next response shows).