Identity.sync.tokenserver.uri remains same after change

identity.sync.tokenserver.uri in the about:config can be edited but after a restart of the browser the original uri is sitll intact.

Also I can create an account @ https://ffsync.garudalinux.org/1.0/sync/1.5 and sign in. However after signing in the menu is still asking me to sign in.

I think that the uri should read https://ffsync.garudalinux.org/token/1.0/sync/1.5 according to the documentation.

Are you changing that setting in ~/.firedragon/firedragon.overrides.cfg?
Otherwise, I don't think the change can be persistent.

1 Like

i didn't know that even existed. lol. Thanks I will look into this.

You have to create it with the settings you want to override.
See e.g.

that I used to connect to my firefox account, that I use on my mobile phone and my work PC, to share open tabs, bookmarks, etc.

1 Like

Thanks I added lockPref("identity.sync.tokenserver.uri", "https://token.services.mozilla.com/1.0/sync/1.5"); to firedragon.overrides.cfg, and restarted the firedragon browser. When I got into about:config the uri has not changed.

It happened to me too at first.
Unfortunately I don't remember exactly what I did to solve it.
A few ideas:

  • whitelist/disable Canvas blocker and ublock origin for accounts.firefox.com
  • create an exception for the same in the cookie section in privacy settings

You have to fight a little bit with It, but it's feasible...

1 Like

I managed to sign in I added accounts.firefox.com:

  • no-script
  • canvas blocker
  • ublock-origin

EDIT: Clean-urls is the culprit. When I disable this extension everything worked.

However, I am now using ffsync.garudalinux.org. I am using iceraven on android and cannot change the uri from mozillas.

2 Likes

You just helped finding a really annoying bugs solution! I was searching for why this seemed to happen for some people (it didn't happen to me for some reason?!), just got the confirmation that this was indeed the issue. Guess that means bye bye ClearURLs :confused:

3 Likes

By the way, I see ClearURLs has this issue #699 open since last year.

3 Likes

Seems as though CleanURLS just needs to be disabled for the initial login. After CleanURLS can be reinabled and sync can still work.