ICU breaks things when updating

If I understand correctly, you might have to remove thunderbird-appmenu, upgrade icu, then build thunderbird-appmenu from the AUR instead of the current chaotic build? Not 100% certain though.

What does paru -Si thunderbird-appmenu return?

I didn't do anything with thunderbird yet. Hence a system upgrade should work flawlessly.
I guess dalto recognized the issue pretty fast and there might be a bug. I'm curious about his findings :slight_smile:

paru -Si thunderbird

type or paste code h╭─[email protected] in ~ took 3s
[🧱] × paru -Si thunderbird-appmenu
Repositorium             : chaotic-aur
Name                     : thunderbird-appmenu
Version                  : 91.6.0-2
Beschreibung             : Thunderbird from extra with appmenu patch
Architektur              : x86_64
URL                      :
Lizenzen                 : MPL  GPL  LGPL
Gruppen                  : Nichts
Stellt bereit            : thunderbird=91.6.0
Hängt ab von             : glibc  gtk3  mime-types  dbus
dbus-glib  alsa-lib  nss  hunspell  sqlite  ttf-font  libvpx  zlib  bzip2
botan  libwebp  libevent  libjpeg-turbo  libffi  nspr  gcc-libs  libx11  libxrender  libxfixes  libxext  libxcomposite
libxdamage  pango  cairo  gdk-pixbuf2  icu  freetype2  fontconfig  glib2  pixman  gnupg
Optionale Abhängigkeiten : libcanberra: sound support
In Konflikt mit          : thunderbird
Ersetzt                  : Nichts
Größe des Downloads      : 63,14 MiB
Installationsgröße       : 196,21 MiB
Packer                   : Nico Jensch <[email protected]>
Erstellt am              : Mi 23 Feb 2022 17:21:55
Verifiziert durch        : MD5-Summe  SHA-256-Summe  Signatur

It looks like it is the chaotic-aur version that needs to be rebuilt.

You can either just wait for that to happen or you can uninstall it, update and then build the AUR version.

Waiting is a lot simpler.


It seems that way. :thinking:

What should we do next? Or should we just wait until you've fixed it?

EDIT - timing overlap of posts xD
okay dalto :slight_smile:


1 Like

Yeah, same for me. I am getting a flashback, same error happening from the past.

Calling Dr. Bombay! Emergency! Come right away! @dr460nf1r3


Just woke up, on it! :slight_smile:


I still get the ICU error.
Plus a time out error :scream: :

:: Paketdatenbanken werden synchronisiert …
core                                  157,3 KiB   869 KiB/s 00:00 [------------------------------------] 100%
extra                                1724,4 KiB  3,86 MiB/s 00:00 [------------------------------------] 100%
community                               6,6 MiB  6,79 MiB/s 00:01 [------------------------------------] 100%
multilib                              175,4 KiB   864 KiB/s 00:00 [------------------------------------] 100%
chaotic-aur                          1704,7 KiB   459 KiB/s 00:04 [------------------------------------] 100%

--> Refreshing mirrorlists using rate-mirrors, please be patient..
Error: failed to connect to , consider increasing fetch-mirrors-timeout

Failed to update mirrorlist
spawn pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing icu (71.1-1) breaks dependency '' required by thunderbird-appmenu
:: installing icu (71.1-1) breaks dependency '' required by thunderbird-appmenu

This turned out to be a tricky one, rebuilds did not solve this as the package still demands libicu 70 :thinking:


Hi all,

I am having the same trouble i think :

 ╭─[email protected] in ~
 ╰─λ thunderbird
XPCOMGlueLoad error for file /usr/lib/thunderbird/ cannot open shared object file: No such file or directory
Couldn't load XPCOM.

 ╭─[email protected] in ~ took 60ms
[⚡] × firedragon
XPCOMGlueLoad error for file /usr/lib/firedragon/ cannot open shared object file: No such file or directory
Couldn't load XPCOM

I have upgrade my systems this morning with the command garuda-update -a

I have just to wait a rebuild, or i can do something alone ?

Best regards.

1 Like

Alright, this was caused by our builders using an outdated mirror as package source ( shame on you, Cloudflare! :joy: ). Now the real builds can start.

This is the way. Builders are working :slight_smile:

edit: thunderbird-appmenu is updated


Perfect for thunderbird-appmenu is working again. But i can't run firedragon anymore :

 ╭─[email protected] in ~ took 60ms
[⚡] × firedragon
XPCOMGlueLoad error for file /usr/lib/firedragon/ cannot open shared object file: No such file or directory
Couldn't load XPCOM

Whats is the best to do ?

My garuda-inxi:

  Kernel: 5.17.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=c0f75d9e-6e1f-4e3b-8385-5e4fd8e89f17 rw [email protected]
    rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=ed6f1df7-3f2e-4ca9-b56c-7442968255fa loglevel=3
  Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: Dell product: Latitude 5400 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0PD9KD v: A00 serial: <superuser required> UEFI: Dell
    v: 1.5.1 date: 08/21/2019
  ID-1: BAT0 charge: 61.6 Wh (98.7%) condition: 62.4/68.0 Wh (91.8%)
    volts: 8.6 min: 7.6 model: LGC-LGC8.948 DELL X77XY99 type: Li-ion
    serial: <filter> status: discharging
  Info: model: Intel Core i5-8365U bits: 64 type: MT MCP
    arch: Comet/Whiskey Lake note: check family: 6 model-id: 0x8E (142)
    stepping: 0xC (12) microcode: 0xEC
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 819 high: 889 min/max: 400/4100 scaling:
    driver: intel_pstate governor: powersave cores: 1: 802 2: 803 3: 889 4: 802
    5: 842 6: 808 7: 801 8: 805 bogomips: 30399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds mitigation: TSX disabled
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: Dell
    driver: i915 v: kernel ports: active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2
    bus-ID: 00:02.0 chip-ID: 8086:3ea0 class-ID: 0300
  Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-6:3 chip-ID: 0bda:565c class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
    compositor: kwin_x11 driver: X: loaded: intel unloaded: modesetting
    alternate: fbdev,vesa gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP1 model: AU Optronics 0x463d built: 2018
    res: 1920x1080 hz: 60 dpi: 157 gamma: 1.2 size: 310x170mm (12.2x6.69")
    diag: 355mm (14") ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2)
    v: 4.6 Mesa 22.0.1 direct render: Yes
  Device-1: Intel Cannon Point-LP High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:9dc8 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.3-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.50 running: yes
  Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi
    v: kernel bus-ID: 00:14.3 chip-ID: 8086:9df0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bd class-ID: 0200
  IF: eno2 state: down mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-10:5 chip-ID: 8087:0aaa class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 476.94 GiB used: 243.39 GiB (51.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba
    model: KBG40ZNS512G NVMe 512GB size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 10410104 temp: 30.9 C scheme: GPT
  ID-1: / raw-size: 459.69 GiB size: 459.69 GiB (100.00%)
    used: 243.39 GiB (52.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 562 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 459.69 GiB size: 459.69 GiB (100.00%)
    used: 243.39 GiB (52.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 459.69 GiB size: 459.69 GiB (100.00%)
    used: 243.39 GiB (52.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 459.69 GiB size: 459.69 GiB (100.00%)
    used: 243.39 GiB (52.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 16.99 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: swap-2 type: zram size: 15.44 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 25.0 C pch: 37.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
  Processes: 248 Uptime: 2m wakeups: 109 Memory: 15.44 GiB
  used: 1.68 GiB (10.9%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1314 lib: 330 Shell: fish
  v: 3.4.1 running-in: konsole inxi: 3.3.15
e[1;34mGaruda (2.6.1-3):e[0m
e[1;34m  System install date:e[0m     2021-12-01
e[1;34m  Last full system update:e[0m 2022-04-17
e[1;34m  Is partially upgraded:  e[0m No
e[1;34m  Relevant software:      e[0m NetworkManager
e[1;34m  Windows dual boot:      e[0m Probably (Run as root to verify)
e[1;34m  Snapshots:              e[0m Timeshift (maybe)
e[1;34m  Failed units:           e[0m 

Best regards.

It also got rebuild, you might have catched the one with pkgrel=2 which got built with the outdated mirror earlier today. I suggest simply reinstalling it to fix that: sudo pacman -Syu firedragon. Ignore the warning about the package being broken and press yes to the removal prompt, then run the command again.


firedragon is back ! Thx a lot @dr460nf1r3 :smile:


Thanks guys!

Woah, 2 days without update and I've got a 727MB download size on my garuda-update :rofl:

100Mbits internet FTW :heart:

Bruce :shark:

1 Like

Welcome to the rolling release model.


Not new to me but back in the days there weren't that big packages :rofl:

1 Like

I stopped looking at that worthless information a long time ago. I get amused by people that go woo, hoo, there's updates! :wink:

Thanks for today's amusement. I'mma pretty cheap date.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.