Icons pinned to lower dock don't survive a reboot

I'm a Garuda newbie but not a Linux newbie. I have been using Ubuntu/Kubuntu/Cinnamon Mint Linux for years. On my new PC I decided to try an Arch-based distribution and Garuda looks nice. The issue is with my pinned applications in the dock.

As I use the PC for development, I pin things that I want to use a lot into the dock. Things like PyCharm, Eclipse, Chrome, VS Code, etc... It all works good and looks great. Then I reboot. After a reboot, the dock comes back up in its new, default state with none of my pinned apps in it.

I can't imagine that "reset the dock to default on startup" is a default setting, or even a setting at all so I am not sure whats going on.

I have also made slight tweaks to the top dock, like changing the size of the tray icons and clock area that I am not sure are persisting through a reboot, because it looks bigger again after I restart, but my changes were only slight so I may be imagining that. I do know that desktop and upper dock widgets that I have added are still there after a reboot, so at least the entire desktop isn't resetting itself to default.

If anyone has any idea what I may be doing wrong, I'd sure like to hear from you. Thanks!

Please paste the output of garuda-inxi into the thread for all issues.

I am going to assume you are using Dr460nized KDE; is your method for pinning the item to the dock to right-click, and select "Pin Launcher"?

5 Likes

Please paste the output of garuda-inxi into the thread for all issues.

Pasted below

I am going to assume you are using Dr460nized KDE;

Yes. And awesome use of the semicolon.

is your method for pinning the item to the dock to right-click, and select "Pin Launcher"?

Yes.

Here is the output of usr/bin/garuda-inxi


< --snip-- > Was the wrong thing. See below.

Just type

garuda-inxi

in the terminal and post here in-between
three~~~
before and after

3 Likes

Oh Sorry... "the output of". I shouldn't have pasted the garuda-inxi file. I looked at the contents of the garuda-inxi file and thought, "I don't know how this'll help, but ok". This makes more sense.

Here's the output of

$ garuda-inxi

System:
Kernel: 5.19.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=70506f6d-548b-48a9-be56-3306d110d844 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: ROG STRIX B550-F GAMING v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 2423
date: 08/10/2021
Battery:
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: AMD Ryzen 9 5950X bits: 64 type: MT MCP arch: Zen 3 gen: 4
level: v3 built: 2021-22 process: TSMC n7 (7nm) family: 0x19 (25)
model-id: 0x21 (33) stepping: 2 microcode: 0xA201204
Topology: cpus: 1x cores: 16 tpc: 2 threads: 32 smt: enabled cache:
L1: 1024 KiB desc: d-16x32 KiB; i-16x32 KiB L2: 8 MiB desc: 16x512 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 2299 high: 3400 min/max: 2200/5083 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2200 2: 2200
3: 2200 4: 2200 5: 2200 6: 2200 7: 2200 8: 2200 9: 3400 10: 2200 11: 2200
12: 2879 13: 2200 14: 2200 15: 2200 16: 2200 17: 3400 18: 2293 19: 2200
20: 2200 21: 2200 22: 2200 23: 2200 24: 2200 25: 2200 26: 2200 27: 2200
28: 2200 29: 2200 30: 2200 31: 2200 32: 2200 bogomips: 217591
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ASUSTeK
driver: nvidia v: 515.76 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-08) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 07:00.0 chip-ID: 10de:1c03 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa gpu: nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 5760x2160 s-dpi: 80 s-size: 1829x686mm (72.01x27.01")
s-diag: 1953mm (76.91")
Monitor-1: DP-3 pos: bottom-c res: 1920x1080 dpi: 96
size: 510x287mm (20.08x11.3") diag: 585mm (23.04") modes: N/A
Monitor-2: HDMI-0 pos: primary,top-left res: 3840x2160 hz: 30 dpi: 52
size: 1872x1053mm (73.7x41.46") diag: 2148mm (84.56") modes: N/A
Monitor-3: HDMI-1 pos: top-right res: 1920x1080 dpi: 96
size: 510x287mm (20.08x11.3") diag: 585mm (23.04") modes: N/A
OpenGL: renderer: NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA
515.76 direct render: Yes
Audio:
Device-1: NVIDIA GP106 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 07:00.1 chip-ID: 10de:10f1 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 09:00.4 chip-ID: 1022:1487 class-ID: 0403
Sound Server-1: ALSA v: k5.19.12-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.58 running: yes
Network:
Device-1: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel pcie:
gen: 2 speed: 5 GT/s lanes: 1 port: N/A bus-ID: 06:00.0 chip-ID: 8086:15f3
class-ID: 0200
IF: enp6s0 state: down mac: <filter>
Device-2: Qualcomm Atheros AR9271 802.11n type: USB driver: ath9k_htc
bus-ID: 1-9:5 chip-ID: 0cf3:9271 class-ID: ff00 serial: <filter>
IF: wlp1s0f0u9 state: up mac: <filter>
Bluetooth:
Device-1: Broadcom BCM20702A0 Bluetooth 4.0 type: USB driver: btusb v: 0.8
bus-ID: 3-2:3 chip-ID: 0a5c:21e8 class-ID: fe01 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 4.57 TiB used: 46.66 GiB (1.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO Plus
2TB size: 1.82 TiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 4B2QEXM7
temp: 42.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Leven model: JAJM600M1024C
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 2A0 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Seagate
model: ST2000DM001-1CH164 size: 1.82 TiB block-size: physical: 4096 B
logical: 512 B type: HDD rpm: 7200 serial: <filter> scheme: MBR
Partition:
ID-1: / raw-size: 953.37 GiB size: 953.37 GiB (100.00%) used: 46.66 GiB
(4.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 5.8 MiB
(1.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 953.37 GiB size: 953.37 GiB (100.00%) used: 46.66
GiB (4.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 953.37 GiB size: 953.37 GiB (100.00%) used: 46.66
GiB (4.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 953.37 GiB size: 953.37 GiB (100.00%) used: 46.66
GiB (4.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 62.68 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 38.9 C mobo: N/A gpu: nvidia temp: 75 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
Processes: 483 Uptime: 1d 0m wakeups: 27 Memory: 62.68 GiB used: 7.1 GiB
(11.3%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1510
libs: 375 tools: octopi,paru,yay Shell: fish v: 3.5.1 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.21
Garuda (2.6.8-1):
System install date:     2022-09-29
Last full system update: 2022-10-01 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

First of all i would reboot

as this means you should reboot.

second I would create a user and see if it presists the for a user

3 Likes

I rebooted, but this time I completely shut down my PC (turned off the switch to the power supply) then rebooted. The UI loaded a configuration from two days ago when I was experimenting with a very small bottom dock and very small tray icons, but otherwise my pinned apps are still no longer pinned.

I'ma try pinning some apps and then restarting again and see what's up.

Ok. Now no app icons show up in the lower dock, so I cannot pin them. I've tried running PyCharm, Discord, Slack, Signal...

Ok. I learned something. I have three monitors and the dock is only on one of them. It only shows running apps from the monitor it's on. I looked into the dock settings and see that "Track: Active Windows from All Screens" is the selected setting, but it doesn't seem to be honoring that setting. If I drag an app onto the same monitor that the dock is on, then the app shows up on the dock. If I drag it away to another monitor, then it goes away from the dock again.

Also, after I went to edit the dock, it loaded completely different settings for the dock and now the lower dock app icons and upper dock tray icons are all big again. It seems not to know exactly from where to load its settings and pulls them willy-nilly from different places I presume, changing them on the fly. How can I trust the settings that I make in the dock?

Thanks for your help, but I am not trusting that the Garuda team uses multiple monitors and I'm not trusting the UI any longer so I am bailing on it and going back to something stable like Mint or Ubuntu.

I like to play with different distributions, but where the rubber hits the road I am a developer who needs to be able to trust his machine to just work.

I am at the point now where I am fearful of rebooting in case my settings go awry and I have to spend an hour troubleshooting the OS before I Can get back to work, and that simply cannot stand.

So... thanks for your help. I tried Garuda and liked its eye candy, but I need a stable OS that will enable me to do real work and Garuda isn't it.


Update:

The reply by @SGS is another thing I don't appreciate about Garuda...

Garuda Linux is also responsible for the war in Ukraine, in fact for everything that goes wrong in the world. Especially for what sometimes happens or doesn't happen in KDE.

That's some smarmy shit right there. I came back to say that while attempting to write a new bootable flash drive for Mint, I used pacman to install Balena Etcher, but it wouldn't run. Whenever I'd start it, its icon would bounce next to the mouse cursor then it'd just go away. I finally had to resort to using dd to write the flash drive but I accidentally left open the partition manager after deleting the existing partitions on the flash drive, so I'd get an error that /dev/sdc couldn't be accessed. I closed the partition manager and I still couldn't access /dev/sdc so I had to reboot.

Garuda reminds me of Windows 95, having to reboot whenever something unexpected happens, in order to reset the OS to a functioning state. Additionally, the Garuda team's mockery of people who want to try out the distribution and run into issues, is some world-class douchebaggery.

Garuda may be a fine distribution once one can sort out the problems, but life is too short to deal with this type of classlessness in the community that apparently, comes from the top.

That said, I do appreciate the well-wishes of @BluishHumility.

No hard feelings @pblanton, I hope you find what you are looking for in your new distribution.

3 Likes

Garuda Linux is also responsible for the war in Ukraine, in fact for everything that goes wrong in the world. Especially for what sometimes happens or doesn't happen in KDE.

5 Likes

I don't like it when someone insults Garuda's developers and holds them liable for things they can't control.

2 Likes

You did not have to reboot, you did not know how to properly handle the drive in its state so you rebooted instead.

If you just reboot every time something you don't understand happens, you will resolve many problems without learning anything.

You may have interpreted that comment as hostile, but SGS's point is valid: you are quick to blame Garuda for a whole set of problems that Garuda has nothing to do with. You recklessly changed a bunch of settings, something broke, and you immediately point the finger at the Garuda team saying the distro is at fault. :face_with_raised_eyebrow:

Garuda runs a version of KDE closer to the edge than the systems you are used to. This means fewer bugs have been discovered and resolved than the distros that release later. Add to that the fact that Latte Dock isn't being actively maintained, and voilà--you managed to hack around and break something.

Neither KDE nor Latte Dock are developed or maintained by Garuda, but somehow Garuda takes your blame. :man_shrugging:

I tried to reproduce your issue on my KDE Dr460nized install, but could not--no matter what I tried, my pinned items remained pinned. That is why I am so convinced your many adjustments in the settings yeilded your strange broken interface.

We can agree on one thing: I do not think this is a good distro for you. It sounds like you want something that will obscure the OS away from you a bit more and take care of things without you needing to be bothered. Arch and Arch-based distros like Garuda tend to require a knowledgeable user to provide periodic maintenance.

Not for nothing, but I hope your coding skills are better than your system administration skills. :smirk:

I immediately closed this topic so it wouldn't turn into a drag, and yet here we are. * sigh * I hope you will still take to heart my well wishes, and do enjoy Linux Mint if that is your choice--it truly is a great distro (I'm a LMDE fan myself) and I think it will serve better as a system that gets out of the way for you so you can focus on your work without needing to learn how to fix things as you go.

6 Likes