I3/Volume Pulseaudio

In the I3 edition, everytime I boot, the volume on my onboard sound is set to 46%, is that some weird default in PulseAudio?
I could dig for it..but since this may affect others, I'm posting and asking.

As software salesman, I would say it's a feature not a bug.
It is a security setting to protect your ears :slight_smile:

</kidding>

Have a look in Garuda Welcome / Control / Audio
Maybe you find this 46% there ( my value are +- 5% = 30-35-40-35-30 :wink: )
In i3 config is no entry for volume.

I never check that value in the past but I will do in feature.

2 Likes

Insanity, my volume is now 100% (and I didn't change anything, other than applying an update (which I do well pretty much all the time)). Ok, if it crops up again, I'll poke around and try to find it. Hard to find when it's behaving though :slight_smile:

Today I start KDE and voila :wink:

2020-10-17_14-27

Not sure if the welcome app do this or ...? @librewish

It is pulseaudio itself

1 Like

But is it configuration of pulseaudio or the code itself?
As I've said before SGS, you make me happy when you duplicate my problems (lol).

I check now on i3, I set to 50% reboot, 50 %
Same on KDE, I boot 4 times, always I get the last value again.

1 Like

Yep, that also bears out my chaotic results. Btw, I've only noticed this fluctuation on Garuda and as you may have noticed, I like to keep about 7 distros :slight_smile: This leads me to believe it's configuration of some sort.

1 Like

Well I caught it at 46% yesterday in an I3 session, so I set it via garuda welcome and we'll see if it sticks.

1 Like

And this morning, I am at 46% again....in I3.
A quick peek around pulseaudio, none of the configs seem to refer to specific volumes. Suggestions?

1 Like

It's not i3 or pulse that is causing these issues. It is a problem with latest alsa updates. It ranges from people having no sound to it being reduced to 46% on various hardware / DE's.

Check what version of alsa-ucm-conf you are running. if it is 1.2.4 try downgrading it to 1.2.3, reboot ,and see what happens.

3 Likes

That is good info to have :wink: Hmm, will do so. Thank you. I am assuming that a gatekeeper has prevented that version updating on my other distros.
Hmm, arcolinux has 1.2.4-1 and I spend a lot of time there and don't have any aberrant audio issues. Just FYI, because I don't know what it means and maybe it's just luck.

1 Like

Yes it is the same currently in the arch repositories:


I guess you have 2 options. Try updating the system so you have 1.2.4-1 and see if that works if not downgrade.
There is a AUR package that makes downgrading a package easier:
1 Like

Once downgrade is installed you can downgrade very simply with pamac, that is if you use Pamac of course. Otherwise, do it through the terminal using pacman.

1 Like