I want to install Wine Staging 7.3 Arch Linux

Like i said i want to install Wine Staging 7.3 but i dont know where to find it. I only found Ubuntu and Debian version, and there is one in the AUR named "Wine-Staging-Git" but that somehow is gets stuck in a loop while installing.

System:
Kernel: 5.18.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=38add348-b329-4341-8751-7bbc309d28a1 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=0 loglevel=3
Desktop: KDE Plasma v: 5.25.2 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: B450M PRO-VDH MAX (MS-7A38) v: 8.0
serial: <superuser required> UEFI: American Megatrends v: B.40
date: 11/07/2019
CPU:
Info: model: AMD Ryzen 5 3600X bits: 64 type: MT MCP arch: Zen 2 gen: 3
built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3619 high: 3724 min/max: 2200/4409 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3724 2: 3597
3: 3680 4: 3596 5: 3619 6: 3592 7: 3595 8: 3600 9: 3586 10: 3636 11: 3605
12: 3600 bogomips: 91198
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
vendor: Tul / PowerColor driver: amdgpu v: kernel arch: RDNA 1
process: TSMC n7 (7nm) built: 2019-20 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: DP-1,HDMI-A-1 empty: DP-2,DP-3 bus-ID: 2b:00.0
chip-ID: 1002:731f class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.65x15.00")
s-diag: 1245mm (49.01")
Monitor-1: DP-1 mapped: DisplayPort-0 pos: right model: Asus VP228
serial: <filter> built: 2015 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
size: 476x268mm (18.74x10.55") diag: 546mm (21.5") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: primary,left
model: BenQ GL2706PQ serial: <filter> built: 2016 res: 2560x1440 hz: 60
dpi: 109 gamma: 1.2 size: 597x336mm (23.5x13.23") diag: 685mm (27")
ratio: 16:9 modes: max: 2560x1440 min: 640x480
OpenGL: renderer: AMD Radeon RX 5600 XT (navi10 LLVM 13.0.1 DRM 3.46
5.18.7-zen1-1-zen)
v: 4.6 Mesa 22.1.2 direct render: Yes
Audio:
Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel pcie:
bus-ID: 3-3:4 gen: 4 chip-ID: 0d8c:013c speed: 16 GT/s class-ID: 0300
lanes: 16 bus-ID: 2b:00.1 chip-ID: 1002:ab38 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 2d:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: C-Media CM108 Audio Controller type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound Server-1: ALSA v: k5.18.7-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 25:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp37s0 state: down mac: <filter>
Device-2: Realtek RTL8192CU 802.11n WLAN Adapter type: USB
driver: rtl8192cu bus-ID: 1-1:6 chip-ID: 0bda:8178 class-ID: 0000
serial: <filter>
IF: wlp3s0f0u1 state: up mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
IF-ID-2: virbr0 state: down mac: <filter>
Drives:
Local Storage: total: 3.18 TiB used: 1.2 TiB (37.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: DT01ACA300
size: 2.73 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: ABB0 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 750 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 1B6Q scheme: GPT
Partition:
ID-1: / raw-size: 448.27 GiB size: 448.27 GiB (100.00%)
used: 366.5 GiB (81.8%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 25.8 MiB (8.6%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 448.27 GiB size: 448.27 GiB (100.00%)
used: 366.5 GiB (81.8%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 448.27 GiB size: 448.27 GiB (100.00%)
used: 366.5 GiB (81.8%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 448.27 GiB size: 448.27 GiB (100.00%)
used: 366.5 GiB (81.8%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.57 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 17.2 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sdb3 maj-min: 8:19
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 52.0 C
mem: 58.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 1300
Info:
Processes: 339 Uptime: 3m wakeups: 0 Memory: 15.57 GiB
used: 2.3 GiB (14.8%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: apt: 0
pacman: 2513 lib: 542 Shell: fish v: 3.4.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.19
Garuda (2.6.4-2):
System install date:     2022-01-14
Last full system update: 2022-06-30
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service rustdesk.service systemd-oomd.socket```

Why? Version 7.11 is in the repos:

$ pacman -Ss wine-staging
multilib/wine-staging 7.11-1
    A compatibility layer for running Windows programs - Staging branch
1 Like

cause i need 7.3 for a thing and not 7.11 if i wanted 7.11 (wich i have installed btw) i would have asked for that.
I need that version to install hearthstone deck tracker.

Apparently 7.11 works:

There's absolutely no reason to be rude to someone who is trying to help you. I have no idea what you are trying to do, or why, which is why I have to ask a question to find out.

3 Likes

I have said what im trying to do, installing wine staging 7.3 and then i get your answer to install 7.11

And how was my answer rude? i have phrased that differently at first and that was rude but then i thought i dont want you anger so i rephrased it to be not rude and it is still rude to you.

And i get this error when executing "wineboot --init" thats why i thought thats cause i dont use 7.3

env WINEPREFIX="$HOME/.hs64" wineboot --init
wine: created the configuration directory '/home/z3r0ut/.hs64'
002c:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
002c:fixme:winediag:LdrInitializeThunk wine-staging 7.11 is a testing version containing experimental patches.
002c:fixme:winediag:LdrInitializeThunk Please mention your exact version when filing bug reports on winehq.org.
0048:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
0050:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
0050:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hr 0x80004002
0050:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, hr 0x80004002
0050:err:ole:apartment_get_local_server_stream Failed: 0x80004002
0048:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hr 0x80004002
0048:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, hr 0x80004002
0048:err:ole:apartment_get_local_server_stream Failed: 0x80004002
0048:err:ole:start_rpcss Failed to open RpcSs service
0050:fixme:imm:ImeSetActiveContext (0000000000340340, 0): stub
0050:fixme:imm:ImmReleaseContext (0000000000010020, 0000000000340340): stub
002c:fixme:imm:ImeSetActiveContext (000000000033CC40, 1): stub
002c:fixme:imm:ImmReleaseContext (0000000000020036, 000000000033CC40): stub
0078:err:winedevice:ServiceMain Failed to load L"C:\\windows\\system32\\win32k.sys"
0078:err:winedevice:ServiceMain Failed to load L"C:\\windows\\system32\\drivers\\dxgkrnl.sys"
0078:err:winedevice:ServiceMain Failed to load L"C:\\windows\\system32\\drivers\\dxgmms1.sys"
0088:fixme:file:NtLockFile I/O completion on lock not implemented yet
0088:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
0088:err:mscoree:LoadLibraryShim error reading registry key for installroot
0088:err:mscoree:LoadLibraryShim error reading registry key for installroot
0088:err:mscoree:LoadLibraryShim error reading registry key for installroot
0088:err:mscoree:LoadLibraryShim error reading registry key for installroot
0088:err:mscoree:LoadLibraryShim error reading registry key for installroot
0088:err:mscoree:LoadLibraryShim error reading registry key for installroot
0088:err:mscoree:LoadLibraryShim error reading registry key for installroot
0088:err:mscoree:LoadLibraryShim error reading registry key for installroot
0098:fixme:imm:ImeSetActiveContext (000000000033C810, 1): stub
0098:fixme:imm:ImmReleaseContext (000000000002007A, 000000000033C810): stub
00a8:fixme:imm:ImeSetActiveContext (000000000033C7F0, 1): stub
00a8:fixme:imm:ImmReleaseContext (000000000003008A, 000000000033C7F0): stub
0088:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
0088:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
00b8:fixme:imm:ImeSetActiveContext (000000000033C7F0, 1): stub
00b8:fixme:imm:ImmReleaseContext (000000000004008C, 000000000033C7F0): stub
00fc:fixme:msg:pack_message msg 14 (WM_ERASEBKGND) not supported yet
wine: configuration in L"/home/z3r0ut/.hs64" has been updated.

╭─[email protected] in ~ via  v18.4.0 took 6s
╰─λ Could not parse file "/home/z3r0ut/.local/share/applications/libinput-gestures-qt.desktop": Invalid key name: Path[$e]
Could not parse file "/home/z3r0ut/.local/share/applications/lstopo.desktop": Invalid key name: Path[$e]
Could not parse file "/home/z3r0ut/.local/share/applications/micro.desktop": Invalid key name: Path[$e]
Could not parse file "/home/z3r0ut/.local/share/applications/org.kde.konsole.desktop": Invalid key name: Path[$e]
Could not parse file "/home/z3r0ut/.local/share/applications/qwikaccess.desktop": Invalid key name: Path[$e]
Could not parse file "/home/z3r0ut/.local/share/applications/xgps.desktop": Invalid key name: Path[$e]
Could not parse file "/home/z3r0ut/.local/share/applications/xgpsspeed.desktop": Invalid key name: Path[$e]
Could not parse file "/home/z3r0ut/.local/share/applications/yad-icon-browser.desktop": Invalid key name: Path[$e]
Could not parse file "/home/z3r0ut/.local/share/applications/yad-settings.desktop": Invalid key name: Path[$e]
Could not parse file "/home/z3r0ut/.local/share/applications/discord-551187306317611043.desktop": Key file contains line ?? %u? which is not a key-value pair, group, or comment
0050:err:ole:start_rpcss Failed to start RpcSs service
0174:err:rpc:I_RpcReceive we got fault packet with status 0x1c010003
0168:fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 1053
0168:fixme:service:scmdatabase_autostart_services Auto-start service L"wineusb" failed to start: 1115
0168:fixme:service:scmdatabase_autostart_services Auto-start service L"winebus" failed to start: 1115
0168:fixme:service:scmdatabase_autostart_services Auto-start service L"PlugPlay" failed to start: 1115
0168:fixme:service:scmdatabase_autostart_services Auto-start service L"Eventlog" failed to start: 1115
0168:fixme:service:scmdatabase_autostart_services Auto-start service L"nsiproxy" failed to start: 1115
0168:fixme:service:scmdatabase_autostart_services Auto-start service L"NDIS" failed to start: 1115```

Those are WINE debug messages. If you note, the output also contains the line:

Did you try the installation steps mentioned in the GitHub issue that are supposed to work, or did you just abort at this point?

4 Likes

That is the Very first step that is failing. And the others are workaround if something happens after the first one worked. At least as far as i can see.

How do you know that it is failing?

Did you read what I wrote in my reply?

1 Like

Oh you meant if i tried to execute the rest of the steps after the first one "failed"... No i did not cause i didnt even realize that it was just debug and not failing.. I try the rest now... Im sorry that i took your time if it works..

1 Like

Yeah it works as Intendet. It was just me being dumb to not notice that it was just debug instead of actual failing. Thank you. xD

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.