I think NVIDIA is fully broken

@dr460nf1r3

Greetings

Right from the live usb I cannot boot normally when selecting the propietary drivers. All of the services at the begining completely start until the end which prompts

Starting Deactivate Plymouth Boot Screen...
Starting Hold until boot process finishes up...
Starting Terminate Plymouth Boot Screen...

Then it just stops and doesn't do anything. I was able tho to make a TTY session in wich I did enter normally and tried some commands, but due to the behaviour of the basic Terminal I cannot read completely what the outputs say.

When I tried to call for garuda-assistant then the Terminal prompts:

qt.qpa.xcb: could not connect to display
qt.qpa.plugin: could not load the Qt platform plugin "xcb" in ""
even though it was found
This application failed to start because no Qt platform plugin
could be initialized. Reinstalling the application may fix this
problem

Available platform plugins are: eglfs, linuxfb, minimal, 
minimalegl, offscreen, vnc, wayland, wayland-xcomposite-egl, 
wayland-xcomposite-glx, xcb.

Abortado ('core' generado)

I am writing manually what the terminal echoes so no fancy outputs here. Commands:

pacman -Qs nvidia:

local/lib32-libvdpau 1.4-1
local/libvdpau 1.4-1
local/mhwd-nvidia 460.67-1
local/mhwd-nvidia-390xx 290.141-1
local/xf86-video-nouveau 1.0.17-1 (xorg-drivers)

mhwd -l:

video-linux 2021.02.19 true pci
video-modesetting 2020.07.13 """
video-vesa 2017.03.12 """

-lspci -k | grep -A 2 -E "(VGA)":

subsystem: Dell Device 0402
kernel driver in use: i801_smbus
kernel modules: i2c_i801
VGA controller: NVIDIA GT218 GeFroce 8400 GS rev .3 (rev a2)

subsystem: Point of View BV Device 8522 [""which is tatooed
on the sticker of the GPU board""]
kernel modules: nouveau [this is very strange]
audio device: NVIDIA high definition rev a1

subsystem: Point of View BV device 8522
kernel driver in use: snd_hda_intel
kernel modules: snd_hda_intel

glxinfo -B:

Unable to open display

xrandr --prop:

Can't open display

dmesg | grep -i VGA:

console colour VGA+ 80x25
vgaarb: seeting as boot VGA device
vgaarb: VGA device added: decodes=io+mem, owns=io+mem,
locks=none
vgaarb: bridge control possible
vgaarb: loaded
snd_hda_intel 0000:01:00.1: handle VGA_switcheroo audio
client

cat /proc/cmdline:

BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=es_ES keytable=es tz=UTC misobasedir=garuda misolabel=GARUDA_DR460NIZEDGAMING_SOARING_ quiet systemd.show_status=1 systemd.unified_cgroup_hierarchy=1 driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1

nvidia-settings -q all:

command not found

Three days ago I instaled normally with nouveau but then I did couple of modifications to actually install nvidia on zen and after all it broke absolutely, not even timeshift was able to recover anything, Restore function was complete useless. I have had issues with timeshift before, not recovering when I needed. Even tho I made a secondary Rsync on another partition and tried to restore it from another live USB. The grub menu had a hell lot of bugs after that.

NVIDIA propietary driver is not compatible with any kernel, with ubuntu linux-liquorix it wasn't able to actually being enabled. And so on. How to fix this from the beggining? I am not a pro but I am used to investigate and solve issues, but how about a complete amateur who is switching from windows?, it is going to be obliterated by this issues. The actual installer also has some issues, that I have to remake several times the boot partition due to it failing at the last step of install.

PLEASE make sure that the installer looks and probes for the BIOS compatible booting before going half or an hour to the complete installation just to fail at the end of it. Which by the way forces you to go through the whole installation process AGAIN if it fails for some reason, that is nonsense.

The rest of the distro is absolutely gourgeous. The best distro I've ever tested, and I've tested many. Be nice ^^

If you were trying the ISO for fun, thank you for the feedback. We "ll look into it.
If you want to install and use the system, install with open source drivers and later on, use Garuda Hardware Manager to install proprietary nvidia. I am sure you already know that, but it may help future readers. :wink:

3 Likes

Hmm please lend me a hand to be sure I don't break it again. From the settings GUI it doesn't show any propietary NVIDIA, I would have to download it. What should I download? Another thing that I asked for in the topic was the Kernel Issue, what kernel should I use to use propietary NVIDIA without issues? I often have several kernels to make tests and benchmarks, Will they all work at once?

And also, I have a good strong curiosity to know what is hapening to the graphical process with propietary live usb. Is it an Xconfig issue? Wayland issue? Driver Issue?

Nothing.

Use

garuda-settings-manager

image

Right click on video-nvidia-dkms

2 Likes

Do I click both checkboxes? what are the other options for? explain me please :smiley:

Read,

there is no click on checkbox it mark only what is installed.

And use only the yellow box I marked.

1 Like

Hope you are having a nice day. I have just installed again and there is only video-linux and video-modesetting. There is no nvidia-dkms available to select.

Seems there is no nvidea card in your system.
We forget that you do not post your

inxi -Fxxxza
1 Like

Additionally, what model is the actual, physical graphics card in your system?

Maybe very new card? IDK.

I am installing dkms manually from Pamac, hope it doesn't break

No - very old - NVIDIA GeForce 8400 GS Rev. 3 Specs | TechPowerUp GPU Database

2010!

3 Likes

yes, it is not new. but it works for some stuff

So, maybe your PC has not the minimal requirements for Garuda.
That why we always ask for the inxi above.

1 Like

it broke again for just installing nvidia-dkms

It is broken so I booted from a fallback snapshot
I don't get what minimal requirements would that be, explain, if it works on ubuntu, it should work here

> ╭─filiberto@ophiucus in ~ 
╰─λ inxi -Fxxxza
System:    Kernel: 5.11.11-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0 
parameters: BOOT_IMAGE=/timeshift-btrfs/snapshots/2021-04-09_12-58-40/@/boot/vmlinuz-linux-zen 
root=UUID=0db4fdd6-ac8e-4a95-a0eb-bb4c6f97132b quiet splash rd.udev.log_priority=3 
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 
rootflags=defaults,noatime,space_cache,autodefrag,compress=zstd,subvol=timeshift-btrfs/snapshots/2021-04-09_12-58-40/@ 
Desktop: KDE Plasma 5.21.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Desktop System: Dell product: OptiPlex 780 v: N/A serial: <filter> Chassis: type: 3 
serial: <filter> 
Mobo: Dell model: 0200DY v: A03 serial: <filter> BIOS: Dell v: A08 date: 01/21/2011 
CPU:       Info: Dual Core model: Pentium E5800 bits: 64 type: MCP arch: Penryn family: 6 
model-id: 17 (23) stepping: A (10) microcode: A0B cache: L2: 2 MiB 
flags: lm nx pae sse sse2 sse3 ssse3 vmx bogomips: 12768 
Speed: 2658 MHz min/max: 1200/3200 MHz Core speeds (MHz): 1: 2658 2: 2135 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf mitigation: PTE Inversion; VMX: EPT disabled 
Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass status: Vulnerable 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
Type: srbds status: Not affected 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GT218 [GeForce 8400 GS Rev. 3] vendor: Point of View BV driver: nouveau 
v: kernel bus-ID: 01:00.0 chip-ID: 10de:10c3 class-ID: 0300 
Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: nouveau 
unloaded: modesetting alternate: fbdev,nv,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1360x768 s-dpi: 96 s-size: 359x203mm (14.1x8.0") s-diag: 412mm (16.2") 
Monitor-1: HDMI-1 res: 1360x768 hz: 60 dpi: 216 size: 160x90mm (6.3x3.5") diag: 184mm (7.2") 
OpenGL: renderer: NVA8 v: 3.3 Mesa 21.0.1 direct render: Yes 
Audio:     Device-1: Intel 82801JD/DO HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
bus-ID: 00:1b.0 chip-ID: 8086:3a6e class-ID: 0403 
Device-2: NVIDIA High Definition Audio vendor: Point of View BV driver: snd_hda_intel v: kernel 
bus-ID: 01:00.1 chip-ID: 10de:0be3 class-ID: 0403 
Sound Server-1: ALSA v: k5.11.11-zen1-1-zen running: yes 
Sound Server-2: JACK v: 0.125.0 running: no 
Sound Server-3: PulseAudio v: 14.2 running: yes 
Sound Server-4: PipeWire v: 0.3.24 running: no 
Network:   Device-1: Intel 82567LM-3 Gigabit Network vendor: Dell driver: e1000e v: kernel port: ece0 
bus-ID: 00:19.0 chip-ID: 8086:10de class-ID: 0200 
IF: enp0s25 state: up speed: 100 Mbps duplex: full mac: <filter> 
RAID:      Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: fec0 bus-ID: 00:1f.2 
chip-ID: 8086.2822 rev: 02 class-ID: 0104 
Drives:    Local Storage: total: 465.76 GiB used: 20.23 GiB (4.3%) 
SMART Message: Unable to run smartctl. Root privileges required. 
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: DT01ACA050 size: 465.76 GiB block-size: 
physical: 4096 B logical: 512 B speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: A750 
scheme: GPT 
Partition: ID-1: / raw-size: 73.03 GiB size: 73.03 GiB (100.00%) used: 20.23 GiB (27.7%) fs: btrfs 
dev: /dev/sda2 maj-min: 8:2
ID-2: /home raw-size: 73.03 GiB size: 73.03 GiB (100.00%) used: 20.23 GiB (27.7%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-3: /var/log raw-size: 73.03 GiB size: 73.03 GiB (100.00%) used: 20.23 GiB (27.7%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-4: /var/tmp raw-size: 73.03 GiB size: 73.03 GiB (100.00%) used: 20.23 GiB (27.7%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: zram size: 1.88 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-2: swap-2 type: zram size: 1.88 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
Sensors:   System Temperatures: cpu: 46.0 C mobo: N/A gpu: nouveau temp: 46.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 182 Uptime: 4m wakeups: 0 Memory: 3.77 GiB used: 1.6 GiB (42.5%) Init: systemd
v: 248 tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1626 lib: 504
Shell: fish v: 3.2.1 default: Zsh v: 5.8 running-in: konsole inxi: 3.3.03

No.
And KDE use a lot of hardware power.

You can read at the Download page

Minimum requirements

  • 30 GB storage space
  • 4 GB RAM
  • 64-bit System

Recommended requirements

  • 40 GB storage space
  • 8 GB RAM
  • video card with OpenGL 3.3 or better

*** Our distro is optimized for performance on real hardware. Installing in virtual machines is not recommended as it might result in a bad experience!*** We sacrifice extra RAM to improve the responsiveness of the system.

2 Likes

So I can close this thread.

So, what you post is

```
Memory: 3.77 GiB used: 1.6 GiB (42.5%)
```
So you post wrong data here?
1 Like

Here it is:

NVIDIA GT218 [GeForce 8400 GS Rev. 3]

Freedesktop/Nouveau:

NVA8 (GT218) GeForce 8400 GS, ION 2, GeForce 205, 210, G 210M, 305M, 310(M), 405...

Archwiki:

Unsupported drivers
If you have a GeForce 300 series card or older (released in 2010 or earlier), Nvidia no longer supports drivers for your card. This means that these drivers do not support the current Xorg version. It thus might be easier if you use the Nouveau driver, which supports the old cards with the current Xorg.

However, Nvidia's legacy drivers are still available and might provide better 3D performance/stability.

Nvidia support:

The Linux 340.* legacy driver series is the last to support the G8x, G9x, and GT2xx GPUs, and motherboard chipsets based on them. Support for X.Org xserver version 1.20 was added to the 340.* legacy driver series with version 340.107, and support for Linux kernels up to Linux 5.4 was added with version 340.108. No further releases from the 340.* series are planned.



Official answer from Nvidia, Archlinux and Garuda is:

You may only use nouveau, or go on your own, since it's your system.
Or choose another distro.

4 Likes