I think I corrupted my GPT?

So, I've been trying out garuda for a few days on an installation on an usb stick, and was pretty satisfied with it, so I decided to get a real hard drive and move my installation onto it. I thought I'd use clonezilla for that, booted up the livecd, etc. When stqrting to clone, it gave me an error message: apparently, the USB had both MBR and GPT. After a bit of googling, I saw that this could easily be fixed by opening the drive in gdisk, picking between GPT and MBT, and saving the thing.

So, I did that. I recalled selecting GPT at some point while installing garuda, so I picked that one. I, of course, had made a backup with fdisk beforehand, on the disk where I wanted to move my installation. Seeing both my partitions present qnd of the right size, I assumed all was good, and carried on with the copy, which deleted the GPT backup. Upon rebooting though, all I was met with is the word GRUB (different of the usual Welcome to GRUB!), and nothing happening.

I booted the Live CD, and couldn't mount my partitions. I opened gparted, and I saw this:

My partitions were there with the flags and names, but the filesystem is not recognized anymore. Same with my original USB. I guess some kind of information must have been corrupted when using gdisk, but I couldn't find any resources that looked helpful.

I hope someone with more experience will be able to tell me what is going on and maybe how to fix it. I really hope that data is not gone even though it hasn't been terribly long since I've started to use this system :grimacing:

In the meantime, I've been running gparted's "Partition rescue tool" for 2 hours now with no signs of progression :confused: Thanks in advance for any help :pray:

garuda-inxl (from Live CD)
System:
Kernel: 5.18.16-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
misobasedir=garuda misolabel=GARUDA_DR460NIZEDGAMING_TALON quiet
systemd.show_status=1 driver=free nouveau.modeset=1 i915.modeset=1
radeon.modeset=1
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: P5KPL-AM v: x.xx
serial: <superuser required> BIOS: American Megatrends v: 0603
date: 08/20/2010
CPU:
Info: model: Intel Core2 Quad Q8200 bits: 64 type: MCP arch: Penryn
built: 2008 process: Intel 45nm family: 6 model-id: 0x17 (23)
stepping: 0xA (10) microcode: 0xA0B
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 4 MiB desc: 2x2 MiB
Speed (MHz): avg: 2326 high: 2331 min/max: 1998/2331 scaling:
driver: acpi-cpufreq governor: performance cores: 1: 2328 2: 2314 3: 2331
4: 2331 bogomips: 18648
Flags: ht lm nx pae sse sse2 sse3 sse4_1 ssse3
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
SMT disabled
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass status: Vulnerable
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GK208B [GeForce GT 710] vendor: ASUSTeK driver: nouveau
v: kernel non-free: series: 470.xx+ status: legacy-active (EOL~2023/24)
arch: Fermi 2 code: GF119/GK208 process: TSMC 28nm built: 2010-16 pcie:
gen: 1 speed: 2.5 GT/s lanes: 8 ports: active: VGA-1
empty: DVI-D-1,HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:128b class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nouveau display-ID: :0 screens: 1
Screen-1: 0 s-res: 1440x900 s-dpi: 97 s-size: 379x237mm (14.92x9.33")
s-diag: 447mm (17.6")
Monitor-1: VGA-1 model: Acer AL1916W serial: <filter> built: 2006
res: 1440x900 dpi: 89 gamma: 1.2 size: 410x257mm (16.14x10.12")
diag: 484mm (19.1") ratio: 16:10 modes: max: 1400x1050 min: 720x400
OpenGL: renderer: NV106 v: 4.3 Mesa 22.1.4 direct render: Yes
Audio:
Device-1: Intel NM10/ICH7 Family High Definition Audio
vendor: ASUSTeK P5KPL-CM driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:27d8 class-ID: 0403
Device-2: NVIDIA GK208 HDMI/DP Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 8
bus-ID: 01:00.1 chip-ID: 10de:0e0f class-ID: 0403
Sound Server-1: ALSA v: k5.18.16-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: ASUSTeK
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e800
bus-ID: 02:00.0 chip-ID: 10ec:8136 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Ralink RT2770 Wireless Adapter type: USB driver: rt2800usb
bus-ID: 1-2:3 chip-ID: 148f:2770 class-ID: 0000 serial: <filter>
IF: wlp0s29f7u2 state: up mac: <filter>
Drives:
Local Storage: total: 989.18 GiB used: 0 KiB (0.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM048-2E7172
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: <unknown> type: HDD rpm: 5400 serial: <filter> rev: SDM1
scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Corsair model: Slider 3.0
size: 57.67 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: 000D scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
Message: No partition data found.
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.83 GiB used: 40.8 MiB (1.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 36.0 C mobo: 40.0 C gpu: nouveau temp: 50.0 C
Fan Speeds (RPM): cpu: 2070 psu: 0 case-1: 0
Power: 12v: 12.14 5v: N/A 3.3v: 3.38 vbat: N/A gpu: nouveau mV: 925.00
Info:
Processes: 186 Uptime: 2h 31m wakeups: 0 Memory: 3.83 GiB used: 1.91 GiB
(49.9%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.1.1 Packages: pacman: 1785 lib: 503 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20
Garuda (2.6.5-1):
System install date:     2022-08-20
Last full system update: 2022-08-08
Is partially upgraded:   Yes
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service snapper-cleanup.service

Hi @arthuro555 and welcome to Garuda!

I want to congratulate you for your choice of Operating System for your desktop PC. Garuda is the best choice for adventurous people.

Don't worry at all with the problem you are facing. If there is a solution, we will find it. Garuda support has the best experts for Arch Linux.

How old are you?

3 Likes

If you have only been using it for a few days like you say, you can probably spare yourself some grief by just doing a completely fresh installation on the metal and just start over.

Unless you created and saved some special or irreplaceable files on that flash drive, I would just move on; any custom setup you have achieved so far can likely be recreated with less time and anguish than the effort you are putting in to trying to restore the system after deleting or overwriting the partition table.

2 Likes

Thanks! Garuda looked like a very cool distribution, and so far I am fully satisfied with it. I only had a minor issue so far that I resolved pretty easily, whereas when I tried some more mainstream linux distributions in the past, I always had a lot of small obscure problems that I couldn't seem to find solutions or documentation for.

17 :sweat_smile: I hope my young age and my deleting of my GPT won't give too bad a first impression :grimacing:

That's fair, and a bit what I expected :weary: I've let my little sister play a few games on it and I hoped I wouldn't have to tell her her save file is lost. I'll still have few other things to try before giving up, I've managed to get a folder with a lot of @ starting subfolders to mount, and I recall @s being everywhere in btrfs snapshots, and it seems to contain files from my installation. I'll try to install Garuda on the HDD and copy the files from that folder I managed to mount to the garuda installation drive.

1 Like

Alright, I've made some progress.

I managed to restore my partition table with sudo gpart -W /dev/sdb /dev/sdb from the Live CD on the original USB, and to clone it (properly this time) to my HDD with clonezilla. GRUB was still not working, so I followed the instructions from this topic to reinstall GRUB. While chrooted into my HDD I confirmed that the system contained my files, and that they were not corrupted.

Now, GRUB works and the system seems to start up, but while booting up, it just shows [FAILED] Failed to start Samba NMB Demon, which is weird because I recall I had uninstalled that.

Would you guys have an idea of what I did wrong?

I suppose it was the method you used to install Garuda.
Cloning the installer ISO partitions has no practical sense, since the ISO partition layout is specific to an ISO installer and different (incompatible) than an installation.

I would suggest you start reading Installation Instructions at Garuda Wiki. :wink:

I admit you are a brave young man! :muscle:

3 Likes

Sorry for not responding earlier, I was busy with schoolwork :sweat:

I think you have misunderstood me - I have not reinstalled Garuda, I have managed to restore the partition table of the USB containing my installation of Garuda (not an installer Live USB, a real Garuda installation performed previously from a separate Live CD installer). Since I still want to transfer that installation to my HDD, I used clonezilla, as advised here, and without messing up my partition table this time. But after the transfer from my USB to the HDD, the system seems to boot up normally until it displays this error message. Booting up from my USB still lets the system startup normally.

Is the error preventing the DE from starting?

If you are able to get to a TTY, can you disable it?

sudo systemctl disable --now smb nmb

This is a different Linux distribution, but perhaps still relevant (I'm honestly not sure): Samba nmb daemon won't start. Can't boot into DE - Support - Manjaro Linux Forum or Boot stuck on [FAILED] SMB/NMB after 20220123 upgrade - Support - Manjaro Linux Forum

1 Like

I took a look at the topics, they seem to say that there are other deeper causes to this error message, and disabling smb/nmb would not help. I've started up my last Garuda snapshot, and it booted up! Even after restauring that snapshot though, the system won't start unless I start it as a snapshot :confused: Is there anything different with booted up snapshots that could allow to identify the problem?

I tried disabling KMS and the nvidia kernel module on the kernel command line, since a few topics seemed to say nvidia was the cause of their trouble, but to no avail.

Check the values in the /etc/fstab. Each partition usually has a unique UUID. Make sure the ID's in fstab are pointing to the right device. It is not unusual to have to edit partition UUID's in fstab when moving things around.

3 Likes

Obviously... Sorry...
I have used Gparted to transfer a system (each partition, with copy partition) to a new disk.
You should know that the new clones keep the same UUIDs as the source partitions.
If you are not going to use the old/source system, you might only need to install grub properly with arch-chroot.

If you try to boot up the new system, without unplugging the source system USB, then something like what you report, is very likely to happen.
If you are sure that you have installed grub properly to the new system, unplug any USB drives and boot.

If you plan to keep using the USB installed system, you need to change UUIDs for one of the systems' partitions (preferably the new one). It is easy to do this with Gparted.

In any case, when reporting feedback with your issues, please, provide the exact error messages, instead of what you remember. It is very important, as many messages look alike, but say different things in many cases.

3 Likes