I need myvideo.ge for learning (and retaining!) Georgian, but it refuses to work

I have attempted to use the flash version, html, use the link in the source code, nothing works. I know that they SHOULD be accessable, because downloaders for the site DO work. Even the ads work. As does the mobile app. But the videos on the website don’t work. How in the world would I fix THAT? Video error report ON YOUTUBE:
the actual site (myvideo.ge)
Either this is a issue on their end, or it’s on mine. I don’t know, and since the message is so vague, I can’t really comprehend much of what’s going on. What is going on, and how do I fix it?

(there, did i clear it up enough?)

jsyk, i placed this here instead of asking them directly because i couldnt find any contact info, and the only email I found never got back to me. soooo
*note three: I didnt want to waste precious website real estate with this question. sorry.

As minimum, you can post the garuda-inxi, please.


Link, please.


1 Like

“Before it was discontinued at the end of September 2017, MyVideo provided background information and trailers for current films and computer games and promoted content from maxdome’s commercial offering.”

2017 is very old in a rolling release distribution. So many things have changed since then, I’d be surprised if you get it working.

But please; surprise me. :smiley:

1 Like


Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm Desktop: KDE Plasma v: 5.27.9
tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda Linux
base: Arch Linux
Type: Laptop System: HP product: HP ZBook 17 G3 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: HP model: 80D6 v: KBC Version 10.75 serial: <superuser required>
UEFI: HP v: N81 Ver. 01.45 date: 01/06/2020
ID-1: BAT0 charge: 29.4 Wh (39.0%) condition: 75.4/75.4 Wh (100.0%)
volts: 12.3 min: 11.4 model: Hewlett-Packard Primary type: Li-ion
serial: <filter> status: charging
Info: model: Intel Core i5-6440HQ bits: 64 type: MCP arch: Skylake-S
gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
model-id: 0x5E (94) stepping: 3 microcode: 0xF0
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 3183 high: 3256 min/max: 800/3500 scaling:
driver: intel_pstate governor: powersave cores: 1: 3256 2: 3181 3: 3195
4: 3102 bogomips: 20799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel HD Graphics 530 vendor: Hewlett-Packard driver: i915
v: kernel arch: Gen-9 process: Intel 14n built: 2015-16 ports: active: eDP-1
empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3 bus-ID: 00:02.0
chip-ID: 8086:191b class-ID: 0300
Device-2: NVIDIA GM204GLM [Quadro M3000M] vendor: Hewlett-Packard
driver: nvidia v: 545.29.02 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2023-10; EOL~2026-12-xx) arch: Maxwell code: GMxxx
process: TSMC 28nm built: 2014-2019 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:13fa
class-ID: 0300
Device-3: Cheng Uei Precision Industry (Foxlink) HP HD Camera
driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
bus-ID: 1-7:2 chip-ID: 05c8:0383 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: ChiMei InnoLux 0x1738 built: 2015 res: 1920x1080
hz: 60 dpi: 128 gamma: 1.2 size: 381x214mm (15x8.43") diag: 437mm (17.2")
ratio: 16:9 modes: 1920x1080
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 1 drv: iris device: 3 drv: swrast gbm: drv: kms_swrast
surfaceless: drv: nvidia x11: drv: iris inactive: wayland,device-2
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 530 (SKL GT2)
device-ID: 8086:191b memory: 15.14 GiB unified: yes
API: Vulkan v: 1.3.269 layers: 15 device: 0 type: integrated-gpu
name: Intel HD Graphics 530 (SKL GT2) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:191b surfaces: xcb,xlib device: 1 type: discrete-gpu
name: Quadro M3000M driver: nvidia v: 545.29.02 device-ID: 10de:13fa
surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe (LLVM 16.0.6 256
bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM 16.0.6)
device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel 100 Series/C230 Series Family HD Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
alternate: snd_soc_avs bus-ID: 00:1f.3 chip-ID: 8086:a170 class-ID: 0403
Device-2: NVIDIA GM204 High Definition Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:0fbb class-ID: 0403
API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.84 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Ethernet I219-LM vendor: Hewlett-Packard driver: e1000e
v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b7 class-ID: 0200
IF: enp0s31f6 state: down mac: <filter>
Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:24f3 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
IF-ID-1: vethkUXzWz state: up speed: 10000 Mbps duplex: full mac: <filter>
IF-ID-2: waydroid0 state: up speed: 10000 Mbps duplex: unknown
mac: <filter>
Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-12:4 chip-ID: 8087:0a2b
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 19 state: up address: <filter> bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c010c
Local Storage: total: 1.14 TiB used: 110.64 GiB (9.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SanDisk model: THNSN5256GPUK
NVMe TOSHIBA 256GB size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 5KDA4103 temp: 48.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: A3T0 scheme: GPT
ID-1: / raw-size: 237.97 GiB size: 237.97 GiB (100.00%)
used: 44.14 GiB (18.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 513 MiB size: 512 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 66.5 GiB (7.1%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/log raw-size: 237.97 GiB size: 237.97 GiB (100.00%)
used: 44.14 GiB (18.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 237.97 GiB size: 237.97 GiB (100.00%)
used: 44.14 GiB (18.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.5 GiB used: 5.65 GiB (36.5%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4
dev: /dev/zram0
System Temperatures: cpu: 62.0 C pch: 57.0 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 424 Uptime: 4d 19h 15m wakeups: 18 Memory: total: 16 GiB
available: 15.5 GiB used: 6.89 GiB (44.4%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages: 2102
pm: dpkg pkgs: 2 pm: pacman pkgs: 2077 libs: 559 tools: octopi,paru
pm: flatpak pkgs: 23 Shell: fish v: 3.6.1 default: Bash v: 5.2.15
running-in: konsole inxi: 3.3.31
Garuda (2.6.17-1):
System install date:     2023-07-21
Last full system update: 2023-11-06 ↻
Is partially upgraded:   Yes
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

downloader link (wrong link. forgot to check history, sorry, correct link here)

Also, there are a lot of MyVideos out there. I’m talking about the Georgian one. Sorry for the confusion.

So I followed your link, tried both way, the example and the “how to” which was redundant, entered the example, clicked on the link and another example .mp4, which took me to a video page where I can pay for stuff with BTC. I also entered the Georgian link from your first post, which took me here: https://www.youtube.com/watch?v=D3rH11Sau-U which played in Georgian language (as far as an English-only person can tell). So what is your point?

Everything seemed to work!

Last full system update: 2023-11-06 ↻

That ‘swoosh’ means you need to reboot since your last update. Do not count on anything working correctly until you do!


Sorry for the miscommunication. I didn’t mean on youtube, but on myvideo.ge. It’s not working there, specifically. I just updated my system and the result didn’t change. What I’m trying to do here is get videos THERE to work.

For me none of the video clips did load on that site

1 Like

same for me, all i got was a spinning buffer icon.

i think this is a website issue and not related to Garuda.

1 Like

Hm. Seems like the problem’s different for different people. But if this is consistent with everyone, everywhere, it may be region locked on the website only (which doesnt make sense). If it is, I’m doomed.

they may be blocking VPN’s, i use one and so do many others.

i really don’t know, i’ve never even heard of that website till you posted here.

1 Like

Well, this is what I get from that exact link. Make sure you have DRM enabled plus maybe an MP4 or FFmpeg extension(s) installed.

I sourced these running FireDragon from the latest dr4gonized Live ISO.


mine is disabled and may very well be the cause of the buffer loop.

I think I added an MP4 extension from the FF store. Can’t remember, it was in the LiveISO…it’s not old age or the weed, I swear.

1 Like

did you get any farther than the ads, or did it just stop you right after they were done?

I don’t recall, and I’m not going to proceed any further with the footwork for you. Linux is not a somebody-else-do-it-for-you operating system. You must do your own research, your own testing, and find your own solution. We can help you, but only so much. The rest is incumbent on you to do the work.

Then tell us extensively the results. And not a little, a lot of research & experimentation. Give us logs/journals! Don’t hold anything back. Do enough of narrowing down your problem, then we might be able to provide help, at that point.That’s how Linux works. :smiley:


ok, ill try.

lmao five minutes later and now that the error message has become less vague, and i went into the network tab, i see it’s multiple errors. to be specific, the jwplayer.js code, and in other parts of the website’s javascript. there’s also a few failed phps and something else? one even got blocked by my browser. these were probably important.

either i need to find a way to fix the code myself (which i cant, because i dont know how to code…) or i could find a way to prevent the PHPs from failing. which seems impossible.
(oh goodness this php is hard to read. it was never meant to be seen so they didnt make it aesthetically pleasing but jeez. and this is just async.)

Ah, so the website hosting init.js is down? Maybe that’s it?
If it were forbidden for me I would have seen 403, like with nue10.
so it’s either down, or…

disabling my adblocker fixed the failed ones except for init.js. that still doesn’t work. As it turns out, the media aborted playing because it was 403 Forbidden. Thus, either it really is down, or it really is regionlocked. If init.js ever comes back up, I’ll try it again, and see what happens.
Also, DOM Mutation Events are deprecated. I wonder when they’ll replace that.

So, it’s probably region locked or something. I’m gonna have to use the Android app, ig.

Just wanna ask is there a reason you are trying so hard for this website? If it’s for learning a new language there are so many resources an eg, duolingo (just citing it from recent ads, haven’t tried it myself). Have you paid for this website already if not why not try something else?