I need help configuring Japanese hiragana and katakana on Garuda

I've already tried going into input settings and tried adding Japanese, but the only Japanese I can install types strictly in Katakana. I would like something like IME on Windows where I can type in romanized characters and have it convert to hiragana automatically, with the option to use kanji instead for words like 日本語 vs にほんご.

I vaguely remember being able to do this on Ubuntu using my old laptop, but I bought a different one recently and decided to swap distros. So far I've liked everything except my struggles to get Japanese typing working correctly, which is really frustrating! It would be greatly appreciated if someone could give me some assistance on adding this functionality as I can't really seem to find much online for something other than Ubuntu.

garuda-inxi output (new user, so not sure if this is needed or not as it was mentioned in the directions, but better to include it than not, right?)

System:
Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=480ac2ff-22ed-4200-9653-c8b2f28f2c1a rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.26.1 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 20BHS06U00 v: ThinkPad W540
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: LENOVO model: 20BHS06U00 serial: <superuser required> UEFI: LENOVO
v: GNET94WW (2.42 ) date: 06/02/2021
Battery:
ID-1: BAT0 charge: 77.9 Wh (95.1%) condition: 81.9/99.5 Wh (82.4%)
volts: 12.6 min: 11.1 model: LGC 45N1153 type: Li-ion serial: <filter>
status: not charging
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M510
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: Intel Core i7-4900MQ bits: 64 type: MT MCP arch: Haswell
gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 1248 high: 3800 min/max: 800/3800 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 798 2: 3800 3: 800
4: 799 5: 800 6: 798 7: 798 8: 1391 bogomips: 44697
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Unknown: No mitigations
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Lenovo
driver: i915 v: kernel arch: Gen-5.75 process: Intel 45nm built: 2010
ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2, VGA-1
bus-ID: 00:02.0 chip-ID: 8086:0416 class-ID: 0300
Device-2: NVIDIA GK106GLM [Quadro K2100M] vendor: Lenovo driver: N/A
alternate: nouveau non-free: series: 470.xx+
status: legacy-active (EOL~2023/24) arch: Kepler code: GKxxx
process: TSMC 28nm built: 2012-18 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:11fc class-ID: 0300
Device-3: Acer Integrated Camera type: USB driver: uvcvideo
bus-ID: 3-12:6 chip-ID: 5986:026a class-ID: 0e02
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.4
compositor: kwin_x11 driver: X: loaded: modesetting dri: crocus gpu: i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: BOE Display 0x0630 built: 2016 res: 1920x1080
dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel HD Graphics 4600 (HSW GT2) v: 4.6 Mesa
22.2.1 direct render: Yes
Audio:
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:03.0
chip-ID: 8086:0c0c class-ID: 0403
Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20
class-ID: 0403
Device-3: NVIDIA GK106 HDMI Audio vendor: Lenovo driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:0e0b class-ID: 0403
Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Intel Ethernet I217-LM vendor: Lenovo driver: e1000e v: kernel
port: 5080 bus-ID: 00:19.0 chip-ID: 8086:153a class-ID: 0200
IF: enp0s25 state: down mac: <filter>
Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:08b2 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 3-11:5 chip-ID: 8087:07dc class-ID: e001
Report: bt-adapter ID: hci1 rfk-id: 5 state: up address: <filter>
Device-2: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
driver: btusb v: 0.8 bus-ID: 3-6:4 chip-ID: 0a12:0001 class-ID: e001
Report: ID: hci0 rfk-id: 2 state: up address: N/A
Drives:
Local Storage: total: 253.31 GiB used: 17.04 GiB (6.7%)
ID-1: /dev/mmcblk0 maj-min: 179:0 model: SL16G size: 14.84 GiB
block-size: physical: 512 B logical: 512 B type: SSD serial: <filter>
scheme: GPT
SMART Message: Unknown smartctl error. Unable to generate data.
SMART Message: Unable to run smartctl. Root privileges required.
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 PRO 256GB
size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 4B6Q scheme: GPT
Partition:
ID-1: / raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 17.04 GiB
(7.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
(0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 17.04
GiB (7.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 17.04
GiB (7.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 17.04
GiB (7.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.5 GiB used: 12 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 52.0 C mobo: N/A
Fan Speeds (RPM): fan-1: 1617
Info:
Processes: 257 Uptime: 10h 6m wakeups: 24 Memory: 15.5 GiB used: 3.58 GiB
(23.1%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1422 libs: 355
tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.22
Garuda (2.6.9-1):
System install date:     2022-10-22
Last full system update: 2022-10-22 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Welcome :slight_smile:

Check if this help, just a 10 second whoogle search.

https://wiki.archlinux.org/title/Localization/Japanese

BTW, just reboot after update.

4 Likes

I appreciate the help, but this didn't really get me much further than I initially was. I'm looking to do something very specific and, well, I kind of already thought to Google it before going to the trouble to make a forum account just to make this post. I've spend a good 2-3 hours just plowing through Arch documentation to find what specifically I need to type in Hiragana, Kanji, and Katakana, and for such a simple thing it really does seem hard to believe that it's never been written out before. It doesn't seem right to me that I'd have to search through 20 different pages to find one little nugget of information that gets me marginally closer to what I am trying to accomplish.

What I've got now is an iBus Preferences menu that now has languages available to select in it, but under Japanese I only have:

"Japanese" (English keyboard with Japanese layout)
"Japanese (Dvorak)" (English keyboard with Japanese DVORAK layout)
"Japanese (Kana)" (Katakana only)
"Japanese (Kana 86)" (??? English)
"Japanese (Macintosh)" (self-explanatory)
"Japanese (OADG 109A)" (??? also English for some reason)

All I have managed to do at this point is install the "ibus" package, that is all. I know it's mostly my fault, but I really do have trouble navigating these vast archives of information relating to Arch just to find what I need. I always seem to get myself into an endless cycle of Googling for hours on end searching for one single thing that would be easy on Debian or Windows, only to eventually run out of links and end up where I started.

An alternative to windows IME is mozc.

And while Ubuntu uses ibus, Arch uses fcitx.

Since Garuda can use fcitx5
Install fcitx5-gtk from octopi.

At that time, when related files containing mozc are displayed
Install that too.

After restarting, Japanese input will be enabled.

I'm sorry in poor English.

Thank you to everyone at Garuda.

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.