I Just updated my system and the application launcher is giving me an error (Someone please help i am a newbie)

The error looks something like this and i searched everywhere but cant seem to solve the problem…

file:///usr/share/plasma/plasmoids/org.kde.plasma.kickoff/contents/ui/main.qml:20:1: Cannot load library /usr/lib/qt6/qml/org/kde/plasma/private/kicker/libkickerplugin.so: (libKF6Runner.so.6: cannot open shared object file: No such file or directory)

Since i am a new user i cant really upload images

So please someone help me i want to access my other apps for my work…

What’s the problem with not posting garuda-inxi?
It contains additional, useful information about the status of your system.

No pictures from terminal, please!

:warning: Missing information requested in the template may result in not receiving assistance

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.
  • Describe your issue in detail. The more we know, the better we can help
  • Show us the results of your searches, and what you’ve tried
  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)
  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Without garuda-inxi this request will be moved to 412 Precondition Failed


like SGS said without the garuda-inxi its hard to help you but im guessing you upgraded from plasma 5 to 6. 99% of all widgets have to be rewritten by the volunteer developer who made it so you can do two things. Remove the widget an add a stock one back. you can also check the get new section of widgets an see if a KDE 6 compatible one has been made an add it that way.

To do any of this R-Click on empty desktop an click edit mode. From there you can remove your old one, swap it with a built in kde one or find a new one with the “Get New” button in the Add Widgets panel. more are being added over time so it might not be there just yet.

╭─kuzibay@kuzibay in ~
╰─λ garuda-inxi
Kernel: 6.8.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=25376516-84e0-46d7-86bc-264dac89496b rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 6.0.2 tk: Qt v: N/A info: frameworks v: 6.0.0
wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Type: Laptop System: Dell product: Vostro 3501 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Dell model: 0790WT v: A00 serial: <superuser required> part-nu: 0A2A
uuid: <superuser required> UEFI: Dell v: 1.11.0 date: 12/15/2021
ID-1: BAT0 charge: 26.7 Wh (85.6%) condition: 31.2/42.0 Wh (74.3%)
volts: 12.7 min: 11.4 model: SMP DELL VM73283 type: Li-poly serial: <filter>
status: charging
Info: model: Intel Core i3-1005G1 bits: 64 type: MT MCP arch: Ice Lake
gen: core 10 level: v4 note: check built: 2019-21 process: Intel 10nm
family: 6 model-id: 0x7E (126) stepping: 5 microcode: 0xC4
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 160 KiB desc: d-2x48 KiB; i-2x32 KiB L2: 1024 KiB desc: 2x512 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 1096 high: 1170 min/max: 400/3400 scaling:
driver: intel_pstate governor: powersave cores: 1: 1071 2: 1032 3: 1170
4: 1112 bogomips: 9523
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Iris Plus Graphics G1 vendor: Dell driver: i915 v: kernel
arch: Gen-11 process: Intel 10nm built: 2019-21 ports: active: eDP-1
empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:8a56 class-ID: 0300
Device-2: Sunplus Innovation Integrated_Webcam_HD driver: uvcvideo
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:3
chip-ID: 1bcf:2b98 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1280x720 s-dpi: 96 s-size: 338x190mm (13.31x7.48")
s-diag: 388mm (15.27")
Monitor-1: eDP-1 model: BOE Display 0x08cd built: 2019 res: 1280x720
hz: 60 dpi: 95 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
ratio: 16:9 modes: 1366x768
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.3-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics (ICL GT1)
device-ID: 8086:8a56 memory: 11.19 GiB unified: yes
API: Vulkan v: 1.3.279 layers: 7 device: 0 type: integrated-gpu name: Intel
UHD Graphics (ICL GT1) driver: mesa intel v: 24.0.3-arch1.2
device-ID: 8086:8a56 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.3-arch1.2 (LLVM
17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Dell
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_icl
bus-ID: 00:1f.3 chip-ID: 8086:34c8 class-ID: 0403
API: ALSA v: k6.8.2-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: Dell RTL8111/8168/8411 driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp1s0 state: down mac: <filter>
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
vendor: Dell driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Device-1: Qualcomm Atheros driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:4 chip-ID: 0cf3:e009
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 6c010c
Local Storage: total: 931.51 GiB used: 48.41 GiB (5.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 5400 serial: <filter> fw-rev: 01 scheme: GPT
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 48.41 GiB (5.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 600 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 48.41 GiB (5.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 48.41 GiB (5.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 48.41 GiB (5.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 11.46 GiB used: 572.4 MiB (4.9%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4
dev: /dev/zram0
System Temperatures: cpu: 54.0 C mobo: 39.0 C
Fan Speeds (rpm): cpu: 0
Memory: total: 12 GiB note: est. available: 11.46 GiB used: 3.73 GiB (32.6%)
Processes: 222 Power: uptime: 9h 19m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 3 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 4.54 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1478 libs: 421 tools: octopi,paru,yay
Compilers: gcc: 13.2.1 Shell: garuda-inxi default: Bash v: 5.2.26
running-in: konsole inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2022-12-26
Last full system update: 2024-03-28
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       No/Undetected
Failed units:

Maybe you could restore the latest working snapshot and repeat the garuda-update.
Just in case anything went wrong last time.
Did you update with garuda-update or what?


So what happend is i didnt use my lap for quite sometime but as soon as i started the computer i updated the whole system after that when i restarted the application launcher isnt working… And that to i cant access the snapshot thing becasue my application launcher isnt working… Plus before updating the application laucher was working but after updating (Using the garuda assistant ) The application laucher wasn’t working

So this was the big KDE 6 update, which might cause this kind of troubles.
Try as suggested to remove the widget, especially if you used a non-standard widget, and add back the standard one.
Even if the application launcher is not working, maybe krunner will (alt+space if I remember correctly).
Anyway, in case you want to restore a snapshot, you do it from the GRUB.

If you restore and update again, make sure to read


So here is the thing i tried going to the grub an chose a snapshot that is the latest so once i clicked on it everything was going well but then it just gets stuck in the booting screen error was something like this : (Failed to start sna daemon) and something like that… pls help

Snapshots are taken before and after each update, so the last one should be anyway with the same system you have now.
Try the one before, probably generated a few minutes earlier.

1 Like

Yep i tried everything but i end up with the same result the error Is Samba nma daemon failed to start and Samba mna daemon failed to start i think. Please help some with with screenshots so i can follow

Please don’t beg for help, we all do what we can.
I’m not a snapshot expert sorry.
Before anyone else jumps in, have you tried the widget change? Have you read the migration wiki and maybe tried the manual migration (I don’t know if it was triggered before by the Garuda system maintenance)?

1 Like

Just shooting blanks here, try to reset to the default theme (find “System Settings”), the steps are numbered:

I followed all the steps but still i am getting the error…

Try, open garuda-assistent

This doesnt seem to solve the problem aswell, i went to garuda assistent and did the same things and logged out aswell but no changes…

Perhaps loading up the new LiveISO an dragging kickoff over to your system in the correct folders of course. Just guessing here. Since im not sure what version of kde you upgraded from maybe something got lost over the years.

kickoffis the standard application launcher from KDE and requires krunner (libKF6Runner.so.6). Try reinstall krunner with:

sudo pacman -S krunner

If that doesn’t help, reinstall Plasma (kickoffis a part of plasma) with:

sudo pacman -S plasma-desktop

and reboot.


Thank you very much! My applicaton launcher is now working properly without giving any error thank you so much!

2 posts were split to a new topic: Error regarding the loading networks

  • ONE issue per topic.