I have problem with writing data in / directory and the mounted device at run/media/"deviceName"

Oh you actually haven’t mentioned a mount point for the drive thus it’s looking in the fstab file for a place to mount.

do a,

sudo mount -t ntfs-3g /dev/sdc1 /mnt

and see if you can browse your ntfs partition by visiting the mnt directory,

ls /mnt

you can change /mnt with any other existing directory.

1 Like

problem was solved thanks, one last question :clap:
in the /mnt directory as my mount point will the system be dependent on it ?
because it is external hard drive so I am afraid that the system wont boot until I plug the hard drive in !

unless you mention it in your fstab to mount no. Or if you write a nofail in fstab (sorry I don’t remember the exact entry, look in man fstab or search online) then system won’t bother you even if it can’t find the drive.

yeah it’s the nofail entry. from man fstab. scroll down to look at the last option in this field.

 The fourth field (fs_mntops).
       This field describes the mount options associated with the

       It is formatted as a comma-separated list of options and is optional
       for mount(8) or swapon(8). The usual convention is to use at least
       "defaults" keyword there.

       It usually contains the type of mount (ro or rw, the default is rw),
       plus any additional options appropriate to the filesystem type
       (including performance-tuning options). For details, see mount(8) or

       Basic filesystem-independent options are:

           use default options. The default depends on the kernel and the
           filesystem. mount(8) does not have any hardcoded set of default
           options. The kernel default is usually rw, suid, dev, exec, auto,
           nouser, and async.

           do not mount when mount -a is given (e.g., at boot time)

           allow a user to mount

           allow device owner to mount

           or x-<name> for use by fstab-maintaining programs

           do not report errors for this device if it does not exist.
1 Like

much appreciated thanks NaN :pray:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.