I have been using Gruda for a while and have had many problems, but dont know how to address them

Hi everyone
I have fallen in love with GARUDA, very easy to use for a person like me who dont know any coding what so ever. I have faced many issues in the past but didnt know how to ask for the help so would just re-install the whole garuda. This takes alot of time and then again i have to re-install all the apps that i use from the ADD-REMOVE and log in to the emails thru thunderbird. Long story short, I recently upgraded the system using the welcome menu on the start and when i rebooted the system it would stuck on the first screen after we select the GRUDA (3 sec later) i dont exactly remember but it is stuck on LOADING something. so i had to use the snapper to go back and reset the system and then again i updated the system, still the same problem. So i freshly installed the system again and as it updated after the install the same thing happened. I dont even know where to look for the logs and how to paste them here. Please help me solve the issue.

Ignoring the template is not going to get you very far.

5 Likes

I am sorry if i have missed something, Just created the account, i did read the forum to look for the problems i have faced today but those were year back issues (2021) and also as i mentioned i am pretty new to this, how do i go about this ?

There was a post template that you read and deleted, this would be a good starting point, absolutely no knowledge required since it's all written in there :wink:

6 Likes

Oh, yes i did delete the post. do you think i should read the post again and try the solutions given in the post ? or do you want me to run something into my system ?

The template asked you to post the output of

garuda-inxi

here as it helps solving problems. So, open the terminal (ctrl+alt+t) and run this command copy the output and paste it here. If you want the output to appear in a file instead of terminal use the command.

garuda-inxi >> FileNameOfYourChoice

this will save the output of the command garuda-inxi into the file FileNameOfYourChoice the path of this file will be the path were your terminal is currently running which if you have just fired and not changed would be home or ~ (both are the same things)

It would also be helpful if you could take some screenshots/photos of the problem and post it here.

1 Like
garuda
System:
Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/.snapshots/3/snapshot/boot/vmlinuz-linux-zen
root=UUID=b8a84b75-8d03-4467-a213-07bba23eb57c quiet quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
rootflags=defaults,noatime,compress=zstd,discard=async,ssd,[email protected]/.snapshots/3/snapshot
Desktop: KDE Plasma v: 5.26.0 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: HP product: HP EliteDesk 800 G2 SFF v: N/A
serial: <superuser required> Chassis: type: 4 serial: <superuser required>
Mobo: HP model: 8054 v: KBC Version 05.39 serial: <superuser required>
UEFI: HP v: N01 Ver. 02.47 date: 04/28/2020
Battery:
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter>
charge: 55% (should be ignored) rechargeable: yes status: discharging
Device-2: hidpp_battery_1 model: Logitech Wireless Keyboard
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: Intel Core i5-6500 bits: 64 type: MCP arch: Skylake-S
gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
model-id: 0x5E (94) stepping: 3 microcode: 0xF0
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 2000 high: 3200 min/max: 800/3600 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 3200 3: 800
4: 3200 bogomips: 25599
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT disabled
Type: retbleed mitigation: IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Graphics:
Device-1: Intel HD Graphics 530 vendor: Hewlett-Packard driver: i915
v: kernel arch: Gen-9 process: Intel 14n built: 2015-16 ports: active: none
empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:1912 class-ID: 0300
Device-2: NVIDIA GK208B [GeForce GT 710] vendor: Gigabyte driver: nouveau
v: kernel non-free: series: 470.xx+ status: legacy-active (EOL~2023/24)
arch: Fermi 2 code: GF119/GK208 process: TSMC 28nm built: 2010-16 pcie:
gen: 2 speed: 5 GT/s lanes: 8 ports: active: HDMI-A-3
empty: DVI-D-1,VGA-1 bus-ID: 01:00.0 chip-ID: 10de:128b class-ID: 0300
temp: 48.0 C
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting,nouveau
alternate: fbdev,intel,nv,vesa dri: nouveau,iris gpu: nouveau
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-3 mapped: HDMI-3 model: BenQ GW2480 serial: <filter>
built: 2020 res: 1920x1080 hz: 60 dpi: 93 gamma: 1.2
size: 527x296mm (20.75x11.65") diag: 604mm (23.8") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL: renderer: NV106 v: 4.3 Mesa 22.2.1 direct render: Yes
Audio:
Device-1: Intel 100 Series/C230 Series Family HD Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
chip-ID: 8086:a170 class-ID: 0403
Device-2: NVIDIA GK208 HDMI/DP Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 8
bus-ID: 01:00.1 chip-ID: 10de:0e0f class-ID: 0403
Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Intel Ethernet I219-LM vendor: Hewlett-Packard driver: e1000e
v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b7 class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB
driver: r8188eu bus-ID: 1-2:2 chip-ID: 0bda:8179 class-ID: 0000
serial: <filter>
IF: wlp0s20f0u2 state: up mac: <filter>
Drives:
Local Storage: total: 577.05 GiB used: 15.38 GiB (2.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Hikvision model: HS-SSD-C100 120G
size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 373 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD5000AUDX-56WNHY0 size: 465.26 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: N/A serial: <filter> rev: 1A01
scheme: MBR
Partition:
ID-1: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
(0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 111.49 GiB size: 111.49 GiB (100.00%) used: 15.38
GiB (13.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-3: /var/log raw-size: 111.49 GiB size: 111.49 GiB (100.00%) used: 15.38
GiB (13.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/tmp raw-size: 111.49 GiB size: 111.49 GiB (100.00%) used: 15.38
GiB (13.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 23.24 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 34.0 C pch: 44.5 C mobo: N/A gpu: nouveau
temp: 48.0 C
Fan Speeds (RPM): N/A gpu: nouveau fan: 2130
Info:
Processes: 254 Uptime: 4h 47m wakeups: 37 Memory: 23.24 GiB used: 4.25 GiB
(18.3%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1145 libs: 304
tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.22
Garuda (2.6.8-1):
System install date:     2022-10-17
Last full system update: 2022-10-17
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            snapper-cleanup.service
McFly: Importing shell history for the first time. This may take a minute or two...done.
2 Likes

Thank you,
i have posted the out put of the INXI, i do not have any screenshot but if i upgrade the system and reboot the error will appear and then i can take a photo and upload it here if you need me to.
please let me know if you need me to upload the photo where the system stops.

Hi @FlyingMetal, welcome to the community.

Try switching to a different kernel and see if the problem goes away. There are many different kernels you can try; the LTS kernel is a good place to start.

First bring the system fully up to date:

garuda-update

Install the kernel and headers:

sudo pacman -S linux-lts linux-lts-headers

Then reboot, and on the Grub menu (the menu before you get to the login screen) choose advanced boot options and find the entry for your new kernel.

2 Likes

I got the 2 advanced options, before it was just one, which one should i go into ?
1 garuda linux
2 garuda linux (on/dev/sda2)
I am trying to upload an image but it says "sorry new users cant upload images"
Let me know which one to choose.
Thank you :+1:

One of the menu options should say something like "advanced boot options". Look inside and find the LTS kernel (it will say LTS on it).

1 Like

Thank you,
It worked with the LTS, that means there is some problem with the zen kernel. Now the problem is i need to manually change it every time i shut down the PC. Is there a way to remove the zen kernel and make LTS kernel the default one that way the grub would pick it up by itself ?

You can remove a kernel just like any other package.

sudo pacman -Rsu linux-zen linux-zen-headers

My advice would be to keep it though. Likely an update will come down sooner or later with a fix for whatever broke it on your system. As you have experienced, having a backup kernel to boot to can be handy.

2 Likes

You can also auto-select the LTS-kernel. Run
sudo garuda-boot-options
in terminal and select the LTS-Kernel.

3 Likes

Thank you,
When i installed garuda yesterday, i did select 2 kernels to install from garuda setup assistant
1 LTS
2 Hardened.
From where the zen kernal was installed? ( For my knowledge).
I can keep the kernels.
I will try leonavis suggestions for grub to auto-select the kernel. Can we revert the settings again ? As you say the update would fix it in near future. So just want to make the grub as it is now.
Cheers

Yes. Just use boot-options once more in that case.

Linux-Zen is Garuda's standard-kernel, I think it's installed by default.

2 Likes

Thank you leonavis.
Got the boot options.
Cheers

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.