I have a toughbook (mk4 cf-31) and no sound after garuda install

Mk4 CF-31 toughbook.

OS: Garuda Linux
Host: CF-31WDLBXLM 004
Kernel: 5.13.13-zen1-1-zen
Uptime: 19 mins
Packages: 1787 (pacman)
Shell: bash
DE: Plasma 5.22.5
WM: KWin
WM Theme: Sweet-Dark-transparent
Terminal: konsole
CPU: Intel i5-3340M (4) @ 3.4GHz
GPU: Intel 3rd Gen Core processor Graphics Controller
Memory: 2.97GiB / 7.63GiB

Multiboot Win10, android x86, Ubuntu, and Garuda.
sound works on everything but Gruda.

^This is how i got sound on Ubuntu, but obv. doesnt work on garuda.
any help you can give would be appreciated.

Try reinstalling pipewire-support

sudo pacman -Syu pipewire-support
2 Likes

ok, I put that in my konsole and it only took 9 seconds! then i rebooted. still nothing.

It would really help if you post complete inxi -Faz.
Otherwise I can't really suggest anything else other than trying pulseaudio or trying different kernels.

2 Likes

Spending a little time searching on how to post for help correctly is a plus. Demonstrating that you understand it will get you a lot of help.

2 Likes

ike this?

λ inxi -Faz
System:    Kernel: 5.13.13-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=56d39371-e79f-43d8-bbd4-2b9eed31291f  
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: Panasonic product: CF-31WDLBXLM v: 004 serial: <filter> Chassis: type: 10  
v: 001 serial: <filter>  
Mobo: Panasonic model: CF31-4 v: 1 serial: <filter> BIOS: American Megatrends v: 4.00L12  
date: 07/22/2013  
Battery:   ID-1: BAT1 charge: 54.2 Wh (59.6%) condition: 91.0/91.0 Wh (100.0%) volts: 10.8 min: 10.7  
model: Panasonic CF-VZSU46 type: Li-ion serial: <filter> status: Discharging  
CPU:       Info: Dual Core model: Intel Core i5-3340M bits: 64 type: MT MCP arch: Ivy Bridge family: 6  
model-id: 3A (58) stepping: 9 microcode: 21 cache: L2: 3 MiB  
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21550  
Speed: 3304 MHz min/max: 1200/3400 MHz Core speeds (MHz): 1: 3304 2: 3090 3: 3194 4: 1896  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable  
Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
Type: meltdown mitigation: PTI  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling  
Type: srbds status: Vulnerable: No microcode  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Matsushita driver: i915 v: kernel  
bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel  
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1024x768 s-dpi: 96 s-size: 270x203mm (10.6x8.0") s-diag: 338mm (13.3")  
Monitor-1: LVDS1 res: 1024x768 hz: 60 dpi: 96 size: 270x200mm (10.6x7.9") diag: 336mm (13.2")  
OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 21.2.1 compat-v: 3.0  
direct render: Yes  
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Matsushita  
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20 class-ID: 0403  
Sound Server-1: ALSA v: k5.13.13-zen1-1-zen running: yes  
Sound Server-2: JACK v: 1.9.19 running: no  
Sound Server-3: PulseAudio v: 15.0 running: no  
Sound Server-4: PipeWire v: 0.3.34 running: yes

this is of no help to me, or anyone. if you want me to do something simply say it or post a link. i'm aware that when i put stuff in forums it never comes out right. so my solution is simply avoid forums. however i've looked for a solution to this problem, i've found that i'm not the only one with it, but not a proper solution.

i honestly don't know what you want me to do. search how to post to forums? how to format posts? which part specifically to copy/paste?

im not sure i'm doing anything right! i found an issue that wasn't addressed. so, i brought it up. you guys can do what ever you like with that. help is appreciated, but ambiguous directions about searching the internet to no avail for additional problems and failures on my part is exactly what brought me here to begin with!

Alsa & Pipewire are both up & running. I'd suggest you use whatever utility your imagination desires to raise the volume. Just that; raise the volume.

1 Like

Volume is max on every facet of control I have, Still have no audio. If I reboot and go in to windows or Ubuntu audio works.

So, it's not hardware.

It's something do with a "driver conflict"
But I can't locate the pulseaudio file I had to edit in Ubuntu and Mint (same file in that video) which I had assumed would have an equivalent .conf in Garuda... I just can't "locate " it.

Install pulseaudio then

sudo pacman -S pulseaudio-support pulseaudio-bluetooth

And reboot

3 Likes

Yes! that did it! I have sound!
I used that konsole command and installed pulseaudio, I then had to follow the path and .conf edit from the video above for the ubuntu fix.
then reboot.
from start-up and log in sound worked!
Thanks much!

1 Like

Glad that it is solved!

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.