I can't update or upgrade Garuda

Hello
I am new in Linux arch world i more used with Debian but lately i came across with Garuda and found very interested then i decide to install in my laptop and desktop so far everything is ok with laptop, can run update and upgrade with no problem.
Unfortunately can't do none of them i keep doing all kind troubleshooting, following all posting suggestion still with no luck, i am getting frustrated.

error: failed retrieving file 'linux-5.13.6.arch1-1-x86_64.pkg.tar.zst' from mirrors.lug.mtu.edu : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
america.mirror.pkgbuild.com : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'linux-5.13.6.arch1-1-x86_64.pkg.tar.zst' from mirror.rackspace.com : Resolving timed out after 10000 milliseconds
warning: failed to retrieve some files
error: failed to commit transaction (download library error)
Errors occurred, no packages were upgraded.

This implies there is an issue with your networking setup, specifically DNS resolution.

Make sure the connection works on other devices, check your router, etc.

2 Likes

Run reflector-simple, then report back.

2 Likes

Thanks but i still get this

:: garuda-common-settings and systemd-swap are in conflict. Remove systemd-swap? [y/N] y
warning: dependency cycle detected:
warning: deepin-session-ui will be installed before its deepin-control-center dependency
warning: dependency cycle detected:
warning: deepin-session-ui will be installed before its deepin-daemon dependency
warning: dependency cycle detected:
warning: deepin-launcher will be installed before its startdde dependency
warning: dependency cycle detected:
warning: deepin-file-manager will be installed before its startdde dependency
warning: dependency cycle detected:
warning: deepin-session-shell will be installed before its startdde dependency
warning: dependency cycle detected:
warning: rubygems will be installed before its ruby dependency
warning: dependency cycle detected:
warning: ruby-irb will be installed before its ruby dependency
warning: dependency cycle detected:
warning: ruby-irb will be installed before its ruby dependency

and ends withs reply
total Download Size: 12.90 MiB
Total Installed Size: 9927.15 MiB
Net Upgrade Size: 384.67 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
libretro-play-6632-1-x86_64 1413.7 KiB 138 KiB/s 00:10 [------------------------------------] 100%
libretro-ppsspp-30123-1-x86_64 11.1 MiB 132 KiB/s 01:26 [------------------------------------] 100%
libretro-yabause-3314-1-x86_64 438.1 KiB 148 KiB/s 00:03 [------------------------------------] 100%
Total (3/3) 12.9 MiB 132 KiB/s 01:40 [------------------------------------] 100%
(580/580) checking keys in keyring [------------------------------------] 100%
downloading required keys...
:: Import PGP key 0706B90D37D9B881, "Chaotic-AUR Wild Bear Node [email protected]"? [Y/n] y
error: key "0706B90D37D9B881" could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

Deepin is not a supported Garuda desktop.

3 Likes

This is a common/known issue, described in Tutorials.

Post this please.

pacman -Qi garuda-system-maintenance
2 Likes

once again i got this error after following your instructions.

(579/579) checking package integrity [------------------------------------] 100%
error: candy-icons-git: signature from "Nico Jensch (Chaotic-AUR) [email protected]" is invalid
:: File /var/cache/pacman/pkg/candy-icons-git-r673.98c1771-1-any.pkg.tar.zst is corrupted (invalid or corrupte
d package (PGP signature)).
Do you want to delete it? [Y/n] y
error: protontricks-git: signature from "Nico Jensch (Chaotic-AUR) [email protected]" is invalid
:: File /var/cache/pacman/pkg/protontricks-git-1.5.2.r10.g425e3e5-1-any.pkg.tar.zst is corrupted (invalid or c
orrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: retroarch-autoconfig-udev-git: signature from "Pedro Henrique Lara Campos [email protected]" is inval
id
:: File /var/cache/pacman/pkg/retroarch-autoconfig-udev-git-r1937.6fd380f-1-any.pkg.tar.zst is corrupted (inva
lid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: samba-mounter-git: signature from "Nico Jensch (Chaotic-AUR) [email protected]" is invalid
:: File /var/cache/pacman/pkg/samba-mounter-git-175.7ac03da-1-x86_64.pkg.tar.zst is corrupted (invalid or corr
upted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: whoogle-git: signature from "Nico Jensch (Chaotic-AUR) [email protected]" is invalid
:: File /var/cache/pacman/pkg/whoogle-git-0.5.4_r350.g8e91564-1-x86_64.pkg.tar.zst is corrupted (invalid or co
rrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

Run sudo pacman -Scc && update remote fix

and report back :slight_smile:

2 Likes

If you had updated the keyring packages then you won't be getting this error message...

3 Likes

Thank you all for support being provided.

I having hard time with internet the download simply doesn't finish to upgrade the package.
So i just decided to go around it by using packages already downloaded and install them manually.

But apart from that i would like to have back the default install back which seems can't.
Every time i pick sweetfield plasma and i apply i get no menu bar it changes only the background.

You have to solve your packaging problem. If you update all your system packages, you may solve your issue (or not).
But we can't help on a partially updated system.

1 Like

As @petsam says, that practice leads to a partial update situation. In Archlinux, that is an untenable setting that may end up causing more problems than solve, and--also--bork your system.

But, as we used to say as a kid, when you're up to your ass in alligators, it is difficult to remember your initial objective was to drain the swamp.

Best not to make a bad situation worse.

Hang in there, Baby!

:slight_smile:

2 Likes

Yeah i know that, i had no other option but doing this.
Managed to have the system fully upgraded and operational, thank you all.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.