I can't start any of my desktop environments/window managers even after reinstalling them

Yes, I know I don't have my garuda-inxi but I can't get it right now. Just please help if you've had a similar thing happen to you. The only package I thought might be the culprit was arandr but I uninstalled it and the problem persists. No DE or WM works anymore. And yes, my drivers are still all installed.
Whether I login from the login screen or use startx, all it gives me is a frozen screen with my mouse cursor still able to move.

When running startx I do get an irregular output before it ouputs it's regular stuff:
"Timeout in locking authority file /home/USER/.Xauthority
But this goes away if I'm in root when I execute the command

I swear, linux makes me want to commit seppuku sometimes when I need to get things done and everything breaks

Use last working snapshot.
Did you update before?
What means no DE/WM?

1 Like

I might have updated before, yes. I don't have any snapshots, they never show up in grub. By no DE/WM I mean i3, awesome, kde, and xmonad all no longer work

???

Update your system minimum one time per week.
If Timeshift or Snapper not work, your system is broken or not Garuda Linux.
Use live ISO to post your inxi.
I am sure you have a backup from your data. If not, use live ISO.

I

I know, I updated my system today but it wasn't immediately before stuff stopped working.

I am on KDE now, work.
i3wm work too. Last test one hour ago.

Did you change something else?

Last update include many qt5- files?

Do you use garuda-update?

And, please, post the inxi.

Maybe xmonad make the trouble???

2 Likes

Installing multiple DEs can cause stuff to break. I'm not saying that is why this happened, I have no idea, but it seems likely.

Unless you modified when snapshots are generated, you should have a new snapshot every time you update or install/remove packages with pacman. When you go to restore a snapshot in grub, the menu is empty?

If you have locked .Xauthority files, try to delete them (note the hypen):

rm .Xauthority-*
2 Likes
System:
  Kernel: 5.18.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=5411b7ff-d53c-4780-9b50-82a7b4183826
    rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3 ibt=off
  Console: tty 4 DM: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Acer product: Nitro AN515-57 v: V1.10 serial: <superuser required>
  Mobo: TGL model: Scala_TLS v: V1.10 serial: <superuser required> UEFI: Insyde v: 1.10
    date: 09/19/2021
Battery:
  ID-1: BAT1 charge: 20.9 Wh (37.6%) condition: 55.6/57.5 Wh (96.7%) volts: 14.9 min: 15.4
    model: LGC AP18E8M type: Li-ion serial: <filter> status: discharging cycles: 195
CPU:
  Info: model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP arch: Tiger Lake gen: core 11
    built: 2020 process: Intel 10nm family: 6 model-id: 0x8D (141) stepping: 1 microcode: 0x3E
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache: L1: 640 KiB
    desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 843 high: 1186 min/max: 800/4600 scaling: driver: intel_pstate
    governor: powersave cores: 1: 975 2: 792 3: 801 4: 788 5: 900 6: 865 7: 775 8: 787 9: 800
    10: 785 11: 818 12: 801 13: 1186 14: 811 15: 801 16: 809 bogomips: 73728
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Acer Incorporated ALI driver: i915
    v: kernel arch: Gen12.1 process: Intel 10nm built: 2020-21 ports: active: eDP-1
    empty: DP-1,DP-2 bus-ID: 0000:00:02.0 chip-ID: 8086:9a60 class-ID: 0300
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: Acer Incorporated ALI
    driver: nvidia v: 515.48.07 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-06) arch: Ampere process: TSMC n7 (7nm) built: 2020-22
    bus-ID: 0000:01:00.0 chip-ID: 10de:25a2 class-ID: 0300
  Device-3: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 3-9:4 chip-ID: 0408:a061
    class-ID: 0e02
  Display: server: X.org v: 1.21.1.3 with: Xwayland v: 22.1.2 driver: X: loaded: intel,nvidia
    unloaded: modesetting,nouveau,vesa alternate: fbdev,nv gpu: i915 tty: 192x54
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x1521 built: 2020 res: 1920x1080 dpi: 142 gamma: 1.2
    size: 344x193mm (13.54x7.6") diag: 394mm (15.5") ratio: 16:9 modes: 1920x1080
  Message: GL data unavailable in console. Try -G --display
Audio:
  Device-1: Intel Tiger Lake-H HD Audio driver: snd_hda_intel v: kernel
    alternate: snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:43c8 class-ID: 0403
  Device-2: NVIDIA vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
    bus-ID: 0000:01:00.1 chip-ID: 10de:2291 class-ID: 0403
  Sound Server-1: ALSA v: k5.18.5-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 16.0 running: no
  Sound Server-4: PipeWire v: 0.3.52 running: no
Network:
  Device-1: Intel Tiger Lake PCH CNVi WiFi vendor: Rivet Networks driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:43f0 class-ID: 0280
  IF: wlp0s20f3 state: down mac: <filter>
  Device-2: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000
    bus-ID: 0000:2c:00.0 chip-ID: 10ec:2600 class-ID: 0200
  IF: enp44s0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-14:5
    chip-ID: 8087:0026 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 3 state: down bt-service: enabled,running rfk-block:
    hardware: no software: no address: <filter>
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd v: 0.6 port: N/A
    bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev: class-ID: 0104
Drives:
  Local Storage: total: 2.29 TiB used: 247.85 GiB (10.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: HFM512GD3JX016N size: 476.94 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 41020C20 temp: 37.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 QVO 2TB size: 1.82 TiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 2B6Q scheme: MBR
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Kingston model: DataTraveler 2.0
    size: 7.21 GiB block-size: physical: 512 B logical: 512 B type: N/A serial: <filter> rev: 1.00
    scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: 297.4 GiB size: 297.4 GiB (100.00%) used: 247.8 GiB (83.3%) fs: btrfs
    dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 50.5 MiB (52.6%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 297.4 GiB size: 297.4 GiB (100.00%) used: 247.8 GiB (83.3%) fs: btrfs
    dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-4: /var/log raw-size: 297.4 GiB size: 297.4 GiB (100.00%) used: 247.8 GiB (83.3%)
    fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-5: /var/tmp raw-size: 297.4 GiB size: 297.4 GiB (100.00%) used: 247.8 GiB (83.3%)
    fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.41 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 27.8 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 311 Uptime: 2m wakeups: 2 Memory: 15.41 GiB used: 958.6 MiB (6.1%) Init: systemd
  v: 251 default: graphical tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages:
  pacman: 2052 lib: 529 Shell: Bash v: 5.1.16 running-in: tty 4 inxi: 3.3.18
e[1;34mGaruda (2.6.3-2):e[0m
e[1;34m  System install date:e[0m     2022-02-16
e[1;34m  Last full system update:e[0m 2022-06-19
e[1;34m  Is partially upgraded:  e[0m No
e[1;34m  Relevant software:      e[0m NetworkManager
e[1;34m  Windows dual boot:      e[0m Probably (Run as root to verify)
e[1;34m  Snapshots:              e[0m Snapper
e[1;34m  Failed units:           e[0m nmb.service 

1 Like

Still says it's 'not writable' after I delete the file.
"xauth: /home/USER/.Xauthority not writable, changes will be ignored"

Only shows snapshots I've done manually.
I don't touch btrfs assistant at all except for making snapshots. If it's supposed to make new snapshots after every update, it's definitely failed at that

Use chroot on live ISO and garuda-update.
Check snapper/timeshift settings in your DE's.
Check if fast boot and secure boot is off in M$.

All in all reinstall :slight_smile: seems you have fun to test a lot of things :wink:

1 Like

What? How?

Fastboot is disabled but every time I try to chroot with the ISO, it gives an error about a problem with /bin/bash

I don't know what DE means

dasktop environments

2 Likes

Each DE has different snapper/timeshift settings?

You must know it, I have many PC/Laptops with different DE's and snapshot apps.

Now on sway, BTRFS Assistant use Snapper.

Okay, that's great and all but I still don't see how it helps fix my system

Now we still don't know what you did to your system, nor which snapshot app is installed. We are not clairvoyants, all my systems, including dual boot with M$, work without glitch. As has been mentioned before, you are using M$ alongside several Garuda Linux DE's, but are having problems, so save your data if necessary and focus on one DE.
Apart from that, Garuda Linux does not give support for dual boot.
We also don't know how you boot the different DE's, custom.cfg?

1 Like

I would edit .xinitrc