I can't screencast in Wayfire

Hello, I'm not new to Archlinux but I am new to most things Wayland. I installed Garuda Wayfire, but I am having trouble figuring out a solution to this problem of not being able to record my screen. I've consulted various wiki's, and I am not finding a solution. Any help would be appreciated.

Hello.

Post your terminal/konsole in- and output as text (no pictures) from:

inxi -Faz
System:    Kernel: 5.15.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
           root=UUID=21c46ada-6c46-4b03-a306-dd3c5c7d708d rw [email protected] quiet splash
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
           loglevel=3
           Desktop: N/A wm: wlroots wm vt: 1 dm: N/A Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: LENOVO product: 2349BZ8 v: ThinkPad T430
           serial: <superuser required> Chassis: type: 10 serial: <superuser required>
           Mobo: LENOVO model: 2349BZ8 serial: <superuser required> UEFI: LENOVO
           v: G1ETB7WW (2.77 ) date: 06/05/2018
Battery:   ID-1: BAT0 charge: 44.3 Wh (96.5%) condition: 45.9/47.5 Wh (96.5%) volts: 11.8
           min: 10.8 model: LGC 45N1005 type: Li-ion serial: <filter> status: Unknown
CPU:       Info: Dual Core model: Intel Core i7-3520M bits: 64 type: MT MCP arch: Ivy Bridge
           family: 6 model-id: 3A (58) stepping: 9 microcode: 21 cache: L1: 128 KiB L2: 512 KiB
           L3: 4 MiB
           flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23146
           Speed: 1634 MHz min/max: 1200/3600 MHz Core speeds (MHz): 1: 1634 2: 2948 3: 3324
           4: 2853
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW,
           STIBP: conditional, RSB filling
           Type: srbds status: Vulnerable: No microcode
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 v: kernel
           bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300
           Device-2: Acer Integrated Camera type: USB driver: uvcvideo bus-ID: 1-1.6:5
           chip-ID: 5986:02d5 class-ID: 0e02
           Display: wayland server: X.Org 1.21.1.3 compositor: wayfire driver: loaded: i915
           note: n/a (using device driver) display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.7x9.4")
           s-diag: 485mm (19.1")
           Monitor-1: XWAYLAND0 res: 1600x900 hz: 60 dpi: 131 size: 310x170mm (12.2x6.7")
           diag: 354mm (13.9")
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 21.2.5
           compat-v: 3.0 direct render: Yes
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo
           driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20 class-ID: 0403
           Sound Server-1: ALSA v: k5.15.5-zen1-1-zen running: yes
           Sound Server-2: sndio v: N/A running: no
           Sound Server-3: JACK v: 1.9.19 running: no
           Sound Server-4: PulseAudio v: 15.0 running: no
           Sound Server-5: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel 82579LM Gigabit Network vendor: Lenovo driver: e1000e v: kernel
           port: 6080 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200
           IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi v: kernel
           bus-ID: 03:00.0 chip-ID: 8086:0085 class-ID: 0280
           IF: wlp3s0 state: down mac: <filter>
           IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth: Device-1: Broadcom BCM20702 Bluetooth 4.0 [ThinkPad] type: USB driver: btusb v: 0.8
           bus-ID: 1-1.4:4 chip-ID: 0a5c:21e6 class-ID: fe01 serial: <filter>
           Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:    Local Storage: total: 232.89 GiB used: 17.24 GiB (7.4%)
           SMART Message: Required tool smartctl not installed. Check --recommends
           ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO M.2 250GB
           size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
           serial: <filter> rev: 1B6Q scheme: GPT
Partition: ID-1: / raw-size: 73.24 GiB size: 73.24 GiB (100.00%) used: 17.24 GiB (23.5%)
           fs: btrfs dev: /dev/sda2 maj-min: 8:2
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%)
           fs: vfat dev: /dev/sda1 maj-min: 8:1
           ID-3: /home raw-size: 73.24 GiB size: 73.24 GiB (100.00%) used: 17.24 GiB (23.5%)
           fs: btrfs dev: /dev/sda2 maj-min: 8:2
           ID-4: /var/log raw-size: 73.24 GiB size: 73.24 GiB (100.00%) used: 17.24 GiB (23.5%)
           fs: btrfs dev: /dev/sda2 maj-min: 8:2
           ID-5: /var/tmp raw-size: 73.24 GiB size: 73.24 GiB (100.00%) used: 17.24 GiB (23.5%)
           fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 7.58 GiB used: 77 MiB (1.0%) priority: 100
           dev: /dev/zram0
Sensors:   System Temperatures: cpu: 44.0 C mobo: N/A
           Fan Speeds (RPM): fan-1: 2588
Info:      Processes: 261 Uptime: 1h 33m wakeups: 53 Memory: 7.59 GiB used: 3.09 GiB (40.7%)
           Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0
           Packages: 1669 pacman: 1664 lib: 376 flatpak: 5 Shell: fish v: 3.3.1 default: Bash
           v: 5.1.12 running-in: alacritty inxi: 3.3.09

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.
installed flatpak OBS with wayland support
installed xdg-desktop-portal-gnome, kde
Tried to install a couple of github workarounds that basically was
installing xdg-desktop-portal
that turned out to be junk.
Tried different versions of OBS, vokoscreen, or simplescreenrecorder
Verified that pipewire was installed.
I probably did a few other things that I can't remember.
Any help would be appreciated.

Install

sudo paru -Syu obs-studio wlrobs xdg-desktop-portal-wlr

Wlrobs is a obs-studio plugin for wlr based compositer.

4 Likes

I guess I was missing wlrobs. Thanks. That worked. [SOLVED]

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.