I cant login after update

Hey there
I've updated my garuda and cant login.
Its second time ive updated my garuda and cant login. Last time i restored it to before the update.

Login screen changed also

  Kernel: 6.4.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=e159b6b8-0660-46f4-91d0-11782cc97f85
    rw rootflags=subvol=@ quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: ROG Strix G733ZM_G733ZM v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: G733ZM v: 1.0 serial: <superuser required> UEFI: American Megatrends LLC.
    v: G733ZM.311 date: 03/18/2022
  ID-1: BAT0 charge: 80.2 Wh (100.0%) condition: 80.2/90.0 Wh (89.1%) volts: 17.2 min: 15.9
    model: AS3GWAF3KC GA50358 type: Unknown serial: <filter> status: full
  Info: model: 12th Gen Intel Core i9-12900H bits: 64 type: MST AMCP arch: Alder Lake gen: core 12
    level: v3 note: check built: 2021+ process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154)
    stepping: 3 microcode: 0x42A
  Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled cache: L1: 1.2 MiB
    desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB
    desc: 1x24 MiB
  Speed (MHz): avg: 2652 high: 4900 min/max: 400/4900:5000:3800 scaling: driver: intel_pstate
    governor: powersave cores: 1: 453 2: 2900 3: 3602 4: 4900 5: 4732 6: 2900 7: 400 8: 2900 9: 2900
    10: 2900 11: 400 12: 2900 13: 2900 14: 2900 15: 2900 16: 860 17: 2900 18: 2900 19: 2900
    20: 2900 bogomips: 116736
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: ASUSTeK driver: i915 v: kernel
    arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports: active: eDP-1 empty: DP-1,DP-2
    bus-ID: 0000:00:02.0 chip-ID: 8086:46a6 class-ID: 0300
  Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: ASUSTeK driver: nvidia
    v: 535.54.03 alternate: nouveau,nvidia_drm non-free: 530.xx+ status: current (as of 2023-05)
    arch: Ampere code: GAxxx process: TSMC n7 (7nm) built: 2020-22 bus-ID: 0000:01:00.0
    chip-ID: 10de:2520 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia unloaded: nouveau alternate: fbdev,intel,nv,vesa dri: iris gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: BOE Display 0x0a00 built: 2021 res: 1920x1080 hz: 360 dpi: 128
    gamma: 1.2 size: 382x215mm (15.04x8.46") diag: 438mm (17.3") ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 23.1.3 renderer: Mesa Intel Graphics (ADL GT2) direct-render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:51c8 class-ID: 0403
  Device-2: NVIDIA GA106 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 0000:01:00.1 chip-ID: 10de:228e class-ID: 0403
  API: ALSA v: k6.4.1-zen1-1-zen status: kernel-api with: aoss type: oss-emulator tools: N/A
  Server-1: PipeWire v: 0.3.72 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 0000:00:14.3
    chip-ID: 8086:51f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel port: 3000
    bus-ID: 0000:2c:00.0 chip-ID: 10ec:8125 class-ID: 0200
  IF: enp44s0 state: down mac: <filter>
  Device-1: Intel driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1
    bus-ID: 3-10:4 chip-ID: 8087:0033 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-se
rvice: enabled,running rfk-block:
    hardware: no software: yes address: <filter>
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd v: 0.6 port: N/A
    bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
  Local Storage: total: 953.87 GiB used: 72.72 GiB (7.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVL21T0HCLR-00BTW size: 953.87 GiB
    block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: GXA7401Q temp: 45.9 C scheme: GPT
  ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%) used: 72.72 GiB (7.6%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%) used: 72.72 GiB (7.6%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%) used: 72.72 GiB (7.6%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 953.57 GiB size: 953.57 GiB (100.00%) used: 72.72 GiB (7.6%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.28 GiB used: 12.5 MiB (0.1%) priority: 100 dev: /dev/zram0
  System Temperatures: cpu: 62.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
  Processes: 378 Uptime: 35m wakeups: 2 Memory: available: 15.28 GiB used: 8.91 GiB (58.3%)
  Init: systemd v: 253 default: graphical tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7
  Packages: pm: dpkg pkgs: 0 pm: pacman pkgs: 1565 libs: 450
  tools: gnome-software,octopi,pamac,paru Client: shell wrapper v: 5.1.16-release inxi: 3.3.27
Garuda (2.6.16-1):
  System install date:     2022-11-08
  Last full system update: 2023-07-04
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio nvidia-dkms
  Windows dual boot:       No/Undetected
  Failed units:            snap.v2ray-core.v2ray.service 

Try switching to a TTY from the login screen to troubleshoot. You can press Ctrl+Atl+F2 (or F3, F4, F5, and so on) to switch to a TTY, then try logging in from there to see if it succeeds.

If the login fails from the TTY also, try typing your password in the username field where you can see the characters that are being typed. That way you can confirm the password is being typed as you expect--Shift is working, the symbols on the output match your keyboard, etc.


Tried Ctrl+Alt+F2 and cant login and im sure i type correctly my password
something came to my mind is it possible it related to Grub? i modified grub because i stuck in initial ramdisk after switch to my nvidia driver. this time after updated i get this:

The "splash" (Plymouth) kernel parameter was removed from your GRUB configuration automatically to ensure system stability. Plymouth may be enabled manually again, but it is strongly recommended to keep plymouth disabled.
The GRUB bootloader at /EFI/Garuda has been updated/reinstalled using 'grub-install'. If this looks correct, no further action has to be taken.

You may be typing your password correctly, but if the keyboard layout has changed for example then the login will fail. That is why you should type it in a visible field, so you can inspect it:


Yes i did it visibly and it was correct and its not a complicated pass anyway. But i can change it to a simple numeric pass and try it again if you think it might be the case

And also thank you guys for your awesome support and all the beautiful designs :pray::white_check_mark::beers:

Hmm, if you can't log in from the TTY and you can see that the password is correct, it seems unlikely to help but I suppose just changing the password period may be worth a shot.

Can you explain more specifically how the login screen changed?


From this to the screen shot that i post first


I don't think that changing the background image and login interface will change the password.
Click, show password, and try garuda. :slight_smile:
Does the user garuda exist on the system?

chroot via live ISO and update again, maybe change the password and/or create another user.


I created another user and i can login with new user account but i cant login with my first administrator account. I've changed its pass to a simple one but still cant login. I tried garuda as pass but it didnt work either. Is it possible its because my username?

It could be, if your username is not entered correctly. Check in /etc/passwd to see how it is spelled and make sure it has not been mistyped.

cat /etc/passwd

Maybe you could use the new user to collect and provide some journal logs at the time the "main" user failed to login.


I dont know why this is happening but i guess its because when you want to type your username it makes first letter capital by default and when your username have capital in first letter it makes conflict.

Finally i figure out where the problem is. When i use Capital in my begining of user name make conflict for example
Username: Fff (cant login)
Username: fff (can login without problem)
Pass is not the problem.

Fff and fff are not the same user, like Uir and uir are not the same password.

On my KDE not.

Yes when my user name have capital in first letter cant login so i changed my user name and it worked

Then my kde behave strange

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.