I can't install Wayfire

Hi there.

The apologies of the case I am new in this, I hope your understanding.

It should be noted that I just edited the publication with the results.

Hello there

I just edited the post with the response of the indicated command.

and what are you trying to do

I am trying to install Wayfire on my computer, but it is throwing me the error mentioned in the image.

OK lets try it a little more blunt, I am blind, I can't see the image.
Either you provide text or I am unable to help.

Note

I am not blind.

3 Likes

I will try to read what it says on the screen when wanting to install, since it disappears very quickly.

This will take time but I will return in a moment.

1 Like

I write what I see in the image:

[ wayfire-0.7.2/src/main.cpp:249] Starting wayfire version 0.7.2
[ libseat][ libseat/backend/seatd.c:78] Could not connect to socket /run/seatd.stock: No such file or dictory
[libseat ][libseat/libseat.c:70 ] Backend 'seatd' failed to open sea. Skipping

2 Likes

Any solution to the mentioned problem?

Let me start honestly saying that I'm not a technical expert nor a Wayfire user.
The first thing which comes to my mind is to try with the free drivers, since you mentioned only the proprietary ones (of course you can switch to them after installation).
If not working, I'd verify the ISO checksum and, if OK, I'd anyway burn again the same USB key, or another one, with a different method (not mentioned in your post, preferred are Balena Etcher, Ventoy or simply Linux dd command).
If still occurring, I haven't found anything really "trustworthy" on the Internet.
Maybe give a look at this one.

2 Likes

I use Ventoy I will make the corresponding discards.

I may be completly off here, but i remember reading about wlroots changing to libseat:

Session management is now completely offloaded to libseat.

does the solution posted on the link that @filo gave work ?

3 Likes

I had the exact same problem, booting with nvidia drivers showed this error in an endless loop. My fix was to edit the nvidia boot option:

linux /boot/vmlinuz-$2 driver=nonfree nvidia-drm.modeset=1

HTH

2 Likes

I think wayfire is trying to use seatd but it should try to use polkit instead.

I found this arch forum discussion (but was for sway instead of wayland) with same problematics : seatd problem

You need to pass the following environment variable to wayfire on startup :
LIBSEAT_BACKEND=logind

You have to find how to initialize this variable when starting wayfire.
I havent't found any other way that specify it just before calling the start script for wayfire. There must be other ways but I haven't found yet.

Anyway I hope it gets you on the solution path!

Regards,
BT

I'm a bit of linux noob. I actually get this exact error when trying to install garuda. Would anyone mind explaining how to set this environment variable before installing?

In the unixstackexchange article it is said " Problem solved by adding LIBSEAT_BACKEND=logind to my /etc/environment"

So as root just edit the file "/etc/environment" and add a line at the end with the text ...

Regards,
BT

1 Like

I am seeing this issue just trying to boot the live Garuda Wayfire environment from USB on bare-metal - not virtualized. How would I go about fixing this apparent LIBSEAT_BACKEND issue in this case? After I see the "seatd" message, all I get is a blinking cursor in the upper-left corner of my screen. I can press ALT-F2 to get to a terminal with a login prompt, and I can login as the Garuda live user from there. Beyond that, I'm stuck.

Also, just for a bit of clarification, I get this issue when booting the live USB for either Wayfire or Sway editions of Garuda. Again, bare-metal, not virtual.

Can you clarify your Graphics card.

What were the results from trying to fixes mentioned in this thread?

1 Like

Graphics card is a GTX 3060.

What would you suggest I modify to change/fix the LIBSEAT_BACKEND on the live boot environment? Is it something I can pass through GRUB at boot time?

Just in case the reason for no-answer is the stated model of my graphics card, I made a typo (out of habit). It's an RTX 3060.

I'd still like to know how to boot the live USB for Wayfire, because it's just flashing me the seatd message once, then stopping with a blinking cursor in the upper left corner of my display.

1 Like

Have you tried passing the boot parameter suggested above at GRUB?
linux /boot/vmlinuz-$2 driver=nonfree nvidia-drm.modeset=1
If not working, if you can switch to a TTY and login, maybe you could try adding that
LIBSEAT_BACKEND=logind to /etc/environment and launching wayfire from TTY.