I can't get steam to open

Hello, maybe i am doing something wrong. yesterday i downloaded steam and was using it no issue.
Today i log back in and cannot get steam to open. Steam native for some reason uninstalled itself and the runtime was useless. if i type in the Konsole steam this is the only output i get.

steam.sh[38202]: Running Steam on garuda Soaring 64-bit
steam.sh[38202]: STEAM_RUNTIME is enabled automatically
setup.sh[38276]: Steam runtime environment up-to-date!
steam.sh[38202]: Steam client's requirements are satisfied

Any advice would be greatly appreciated. I am very new to arch and know barley now how to do advanced things in linux. So please forgive me if i ask you to maybe explain a thing or two.

thank you


Kernel: 5.19.10-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=0a3aa89c-7e3a-4b46-ac95-2bb484b7379c rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=5853c994-3e63-464a-9c37-1a41db2761a4 loglevel=3
Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: MSI model: Z97A GAMING 7 (MS-7916) v: 1.0
serial: <superuser required> UEFI: American Megatrends v: 1.12
date: 02/16/2016
Info: model: Intel Core i7-4790K bits: 64 type: MT MCP arch: Haswell
gen: core 4 level: v3 built: 2013-15 process: Intel 22nm family: 6
model-id: 0x3C (60) stepping: 3 microcode: 0x28
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 3975 high: 4400 min/max: 800/4400 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 1535 2: 4400 3: 4391
4: 4400 5: 4400 6: 3875 7: 4400 8: 4400 bogomips: 63994
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Unknown: No mitigations
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected

edited for terminal output formating

i am now unable to open system settings as well, maybe they are unrelated but im very confused

After a reboot everything started working again but im just confused on what happend in the first place. if anybody has an idea let me know but everything seems all good now

I heard zen kernel would not please steam enough to run due to some missing libs -
change kernel I would propose

1 Like

thank you for the recommendation, but how hard is that to do?

is that a option at boot in the bootloader???

yes I suppose you have other kernels installed besides zen, so you select at boot which of the installed kernels you start at the grub boot loader start menu

if that does end up helping will it automatically defer to the other ones on boot or is that just something i have to get into the habit of???

you can e.g. use grubcustomizer to assign a default grub entry to start with

many thanks to you

garuda settings manager it is, if it happened you have only zen kernel you can install with pamac
linux and/or linux-lts additionally, then go to garuda settings manager

1 Like

so i already booted into lts and titanfall 2 seems a bit smoother

1 Like

hope it now runs well, just do not install grub-customizer, that was a wrong suggestion by me,
and you can still compare it with linux standard kernel

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.