I can't connect to the Internet using Ethernet

inxi -Faz
System:    Kernel: 5.15.4-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=1409d596-84e3-4768-b0e5-996dc20bb2a5 rw
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 loglevel=3
           Desktop: LXQt 1.0.0 tk: Qt 5.15.2 info: cairo-dock, lxqt-panel wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
           base: Arch Linux
Machine:   Type: Desktop Mobo: INTEL model: HM65DESK serial: <superuser required> UEFI: American Megatrends v: 4.6.5
           date: 02/23/2019
CPU:       Info: Dual Core model: Intel Core i7-2620M bits: 64 type: MT MCP arch: Sandy Bridge family: 6 model-id: 2A (42)
           stepping: 7 microcode: 2F cache: L1: 128 KiB L2: 512 KiB L3: 4 MiB
           flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 21550
           Speed: 1091 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 2559 2: 3046 3: 3225 4: 3081
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported
           Type: l1tf mitigation: PTE Inversion
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GM107 [GeForce GTX 750] driver: nvidia v: 495.44 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
           chip-ID: 10de:1381 class-ID: 0300
           Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: nvidia display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1360x768 s-dpi: 90 s-size: 384x300mm (15.1x11.8") s-diag: 487mm (19.2")
           Monitor-1: HDMI-0 res: 1360x768 hz: 60 dpi: 49 size: 708x398mm (27.9x15.7") diag: 812mm (32")
           OpenGL: renderer: NVIDIA GeForce GTX 750/PCIe/SSE2 v: 4.6.0 NVIDIA 495.44 direct render: Yes
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
           chip-ID: 8086:1c20 class-ID: 0403
           Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX] driver: snd_hda_intel v: kernel bus-ID: 01:00.1
           chip-ID: 10de:0fbc class-ID: 0403
           Sound Server-1: ALSA v: k5.15.4-zen1-1-zen running: yes
           Sound Server-2: sndio v: N/A running: no
           Sound Server-3: JACK v: 1.9.19 running: no
           Sound Server-4: PulseAudio v: 15.0 running: yes
           Sound Server-5: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 v: kernel port: d000 bus-ID: 03:00.0
           chip-ID: 10ec:8168 class-ID: 0200
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 2.78 TiB used: 712.95 GiB (25.0%)
           SMART Message: Required tool smartctl not installed. Check --recommends
           ID-1: /dev/sda maj-min: 8:0 model: SATA SSD size: 55.9 GiB block-size: physical: 512 B logical: 512 B
           speed: 3.0 Gb/s type: SSD serial: <filter> rev: Sb10 scheme: GPT
           ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3000NM0053 size: 2.73 TiB block-size: physical: 512 B
           logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: G00A scheme: GPT
Partition: ID-1: / raw-size: 389.6 GiB size: 389.6 GiB (100.00%) used: 318.92 GiB (81.9%) fs: btrfs dev: /dev/sdb4
           maj-min: 8:20
           ID-2: /boot/efi raw-size: 5.59 GiB size: 5.58 GiB (99.80%) used: 237.7 MiB (4.2%) fs: vfat dev: /dev/sda2
           maj-min: 8:2
           ID-3: /home raw-size: 389.6 GiB size: 389.6 GiB (100.00%) used: 318.92 GiB (81.9%) fs: btrfs dev: /dev/sdb4
           maj-min: 8:20
           ID-4: /var/log raw-size: 389.6 GiB size: 389.6 GiB (100.00%) used: 318.92 GiB (81.9%) fs: btrfs dev: /dev/sdb4
           maj-min: 8:20
           ID-5: /var/tmp raw-size: 389.6 GiB size: 389.6 GiB (100.00%) used: 318.92 GiB (81.9%) fs: btrfs dev: /dev/sdb4
           maj-min: 8:20
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 3.79 GiB used: 314.5 MiB (8.1%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 35 C
           Fan Speeds (RPM): N/A gpu: nvidia fan: 33%
Info:      Processes: 255 Uptime: 56m wakeups: 0 Memory: 3.79 GiB used: 2.52 GiB (66.6%) Init: systemd v: 249 tool: systemctl
           Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1877 lib: 530 flatpak: 0 Shell: fish v: 3.3.1
           running-in: qterminal inxi: 3.3.09

Hi everyone, me again. I'm just having the weirdest bug I've ever had. I was watching youtube videos like any other sunday and then: no more internet. Just like that.
Almost.
None of my 4 browsers can connect to any site, my terminal can't update the system because it can't reach the repos, and so on but... Connman still shows that I'm correctly connected, systemctl shows absolutely no errors and... KDE-Connect still could easily and quickly as ever send a 2.3Gb file back and forth between Garuda and my phone? Notification sync is also working perfectly.

-> I tried disconnecting and reconnecting several times, I tried login in and out, I tried rebooting, shuting down, I tried mannually removing the ethernet cable and putting it back in... nothing seems to get my system back online and honestly I ran out of knowledge to solve this problem. Apart from the fact that... the system seems to be online '_'

The last weird thing is that this monday morning, I booted up and there it was: the internet again! Worked perfectly for about one hour and then, back to the same mysterious issue once again. It's just weird, I have no idea what's going on.

Just as aditional info, yes, my phone still can connect to the internet, so can my TV through cable, so can my secondary system in the same exact machine, in which I am right now (and therefore I had to retrieve an inxi-faz from a previous post of mine), so I really think this is a Garuda only issue.
I literally didn't mess up with anything, last time I updated was wednesday (and that was the wildest thing I did with my system all week long) and everything was working fine untill literally from a second to another it just wasn't.

All and any ideas are more than welcome '_'

Nope :slight_smile:

Try in terminal

ping -c 3 8.8.8.8
2 Likes

Have you tried with a different Ethernet cable?

2 Likes

No I didn't try another cable, but if it were the cable, shouldn't my secondary OS be unable to connect as well?

As for the ping, here is my result, even tho this time when I booted the internet seems to be okay again? If (and hopefully not when) the error occurs again, I'll repeat the operation and post the result of then.

ping 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=117 time=5.39 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=117 time=4.82 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=117 time=3.03 ms

--- 8.8.8.8 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 3.034/4.414/5.391/1.003 ms

His(?) intent (I assume) with that test to determine if "the internet" is working and it's a DNS issue (an internet service that converts web addresses into IP addresses).

It COULD be that the connection to and/or the DNS you're using is having issues. This can be changed in Garuda-Assistant. If you have the issue again and that ping works, try changing the DNS server (in settings tab).

4 Likes

Sorry, I skept that part of your checks.
Anyway, does the other OS connects always, and especially when Garuda doesn't?
If not, maybe you could try another cable.
And if the other OS is windows, that's a different story, I think, and it's worth testing a different cable.

Yeah sounds like your DNS or route is botched that's all.

Alright, the internet seems stable for now, and I'm hoping it stays like so, but now I won't be able to stay at my desktop to be sure of it
.
But good thinking, maybe it's a DNS problem? If the problem happens again, I'll try changing it. From the Garuda assistant, any recommendations? I've seen there's a handful of options there and I have no idea what should be best

And, yes, filo, as I was working when the internet stopped today, I immediatly changed OSs and Pop! could connect with no problems at all. Also yesterday, as I assumed Garuda wouldn't be able to connect, I did all my late afternoon and night youtube watching and internet scrolling through Pop! and it didn't flinch xD

if it happens again check your route (yes just route in term) or just ping something external like fark.com. If you can ping things on your network but fark fails you can do a tracepath to see where things are dying. In theory you could just sudo dhclient -r ; sudo dhclient and see if that smartens it up when it happens again so long as a ping to the router succeeds.

3 Likes

Alright, so I just sat down and started working again, and again the same problem popped up my face.
Second thing I did was try and change the DNS at the Garuda Assistant and, simple like that, everything was back online!
Before changing the DNS I tried the ping 3 8.8.8.8 again and the result was the same, I tried pinging wikipedia and it returned as unknown. After changing it, not only wikipedia returned to me and endless list of 64bit packages xD but it also got my browser back to normal function!
Thanks everyone for all the help, specially @anon26187667 for being the first one to spot that it could be a dns kinda of thing.

I just have one last thing to ask, I never really picked a DNS in my life before, and even knowing that the Garuda team wouldn't put anything as a preset on the settings if it wasn't near perfection, I still have no idea what kind of DNS should I choose
Can anyone give me a hint?

Try switching to cloudflare for your DNS (IP address 1.1.1.1).

I was going to suggest this a bit back when I caught your thread, but you said things were working again.

3 Likes

try 1.1.1.1 which is cloudflare :smiley:

3 Likes

I just picked up on and clarified what SGS was getting at :woman_shrugging:

I've used OpenDNS for years and years. Reliable enough and easily memorable IP addresses :+1:

E2A: Okay, so their IP isn't as easily memorable as Cloudflare apparently :smiley:

1 Like

I've always used opendns (before running my own) but my vote is switch between so it skews data collection externally :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.