I can't connect Garuda Linux to my university WiFi

I have a dual boot ThinkPad running Garuda Linux, it connects to my home WiFi, my phone and pretty much any other WiFi just fine. Except for my university WiFi, 'eduroam'. When I go to connect Latte Dock pops up and I'm not sure what I'm supposed to do from there. On Windows and Android, I sign into the network with my university credentials (username & password) and I'm connected. Does anybody have experience signing into enterprise networks with private machines running Arch based systems?

Ask your university Admin or other students :slight_smile:

Welcome :slight_smile:

2 Likes

A quick bit of Ducky brought me to [SOLVED] WPA2-Enterprise connection problems / Networking, Server, and Protection / Arch Linux Forums, seems they used netctl then transferred to Network Manager.

2 Likes

But, please, give them your inxi -Faz :slight_smile:

3 Likes

Have you read the entries in the Arch Wiki pertaining to Eduroam?

4 Likes

I didn't know they existed, I thought that was just the name of my school's WiFi.

I followed the page from the Arch Wiki and I found eduroam's tool for configuring devices for their wireless networks, called eduroam CAT. It ships as python code for Linux, so I downloaded it and run it in terminal

python eduroam-linux-UoW.py

Worked like a charm, thanks.

2 Likes

Yes - your University's IT support staff. It's what they're paid to do. :wink:

5 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.