I can not get full screen in Virtualbox

I can not get fulf screen in Virutualbox. Here's what I've done

sudo pacman -S --noconfirm --needed virtualbox
sudo pacman -S --noconfirm --needed linux-tkg-pds-headers
sudo pacman -S --needed virtualbox-host-dkms
sudo pacman -S --noconfirm --needed xf86-video-vmware
sudo grub-mkconfig -o /boot/grub/grub.cfg

My kernel
uname -a
Linux 5.10.14-119-tkg-bmq #1 TKG SMP PREEMPT Mon, 08 Feb 2021 12:16:22 +0000 x86_64 GNU/Linux

Did you install the Virtualbox guest additions within the guest OS?

Did you install the Virtualbox guest additions within the guest OS?

No.
I would like full screen during installation of an OS

I don't understand why this is a problem that needs to be solved.

This also doesn't sound like a Garuda issue?

3 Likes

Seems to be more of a luxury problem.
I have some of them too. :grin:

I make videos for others and then it should preferably be in full screen

Please address this request to VB. :slight_smile:

1 Like

Before booting press E to edit and add:

GRUB_GFXMODE=1920x1080
GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"
GRUB_GFXPAYLOAD_LINUX=keep
2 Likes

This might work for a Linux distro, but not for Windows etc. :wink:

2 Likes

Does virtualbox not have a display scaling option? I don't know I don't use it. Most hypervisors have a scaling option.

EDIT:

I lied I do have it installed for some reason...

Non-Scaled mode:

Scaled mode:

2 Likes

I had to have my Graphics Controller set to VBoxSVGA on the Guest.

3 Likes

Yes, now it works

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.