I am confused by what the issue is [Nvidia driver]

System:
Kernel: 6.9.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=5ed3d6f6-6439-42b0-a1ac-658417c30fdd rw rootflags=subvol=@
quiet loglevel=3 nvidia-drm.modeset=1 ibt=off
Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.2.0
wm: kwin_x11 with: krunner vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Desktop Mobo: Gigabyte model: B550I AORUS PRO AX
serial: <superuser required> uuid: <superuser required> UEFI: American
Megatrends LLC. v: F16e date: 07/20/2022
CPU:
Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
model-id: 0x21 (33) stepping: 0 microcode: 0xA201016
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 3693 min/max: N/A cores: 1: 3693 2: 3693 3: 3693 4: 3693
5: 3693 6: 3693 7: 3693 8: 3693 9: 3693 10: 3693 11: 3693 12: 3693
bogomips: 88637
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA GA104 [GeForce RTX 3060 Ti Lite Hash Rate] vendor: ZOTAC
driver: nvidia v: 550.78 alternate: nouveau,nvidia_drm non-free: 550.xx+
status: current (as of 2024-04; EOL~2026-12-xx) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: none off: DP-2 empty: DP-1,DP-3,HDMI-A-1
bus-ID: 07:00.0 chip-ID: 10de:2489 class-ID: 0300
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia,nvidia-nvswitch
display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 92 s-size: 707x393mm (27.83x15.47")
s-diag: 809mm (31.85")
Monitor-1: DP-2 note: disabled model: MSI MAG321CQR serial: <filter>
built: 2019 res: 2560x1440 hz: 144 dpi: 93 gamma: 1.2
size: 698x393mm (27.48x15.47") diag: 801mm (31.5") ratio: 16:9 modes:
max: 2560x1440 min: 640x480
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.78
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3060 Ti/PCIe/SSE2
memory: 7.81 GiB
API: Vulkan v: 1.3.279 layers: 7 device: 0 type: discrete-gpu name: NVIDIA
GeForce RTX 3060 Ti driver: nvidia v: 550.78 device-ID: 10de:2489
surfaces: xcb,xlib
Audio:
Device-1: NVIDIA GA104 High Definition Audio vendor: ZOTAC
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 07:00.1 chip-ID: 10de:228b class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 09:00.4 chip-ID: 1022:1487 class-ID: 0403
API: ALSA v: k6.9.3-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: f000 bus-ID: 05:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 06:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp6s0 state: up mac: <filter>
Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Bluetooth:
Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-8:5 chip-ID: 8087:0029
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.2
lmp-v: 11 status: discoverable: no pairing: no class-ID: 6c0104
Drives:
Local Storage: total: 1.39 TiB used: 112.02 GiB (7.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 5B2QGXA7 temp: 47.9 C
scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:3 vendor: Western Digital
model: WD Green SN350 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 33006000 temp: 44.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Generic model: Flash Disk
size: 29.3 GiB block-size: physical: 512 B logical: 512 B type: USB rev: 2.0
spd: 480 Mb/s lanes: 1 mode: 2.0 tech: SSD serial: <filter> fw-rev: 8.07
scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 112.02 GiB (24.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 112.02 GiB (24.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 112.02 GiB (24.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 112.02 GiB (24.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.52 GiB used: 512 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 49.5 C mobo: 40.0 C gpu: nvidia temp: 44 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 0%
Info:
Memory: total: 16 GiB available: 15.52 GiB used: 4.86 GiB (31.3%)
Processes: 371 Power: uptime: 18m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 6.17 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: 2205 pm: pacman pkgs: 2199 libs: 593 tools: octopi,paru
pm: flatpak pkgs: 6 Compilers: clang: 17.0.6 gcc: 14.1.1 Shell: garuda-inxi
default: fish v: 3.7.1 running-in: yakuake inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-04-23
Last full system update: 2024-06-02
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

Thank you for reading and if somehow my ADHD mind didn’t do what was needed above, please let me know and I will do my best to correct the problem.

I have been having issues at start up. I will restart my computer and it will try to load and it will say it is having issues loading kernel modules. It will sometimes be able to load into Garuda and sometimes it will just hang.

I have tried instead to load into other kernels I have as backup and the LTS seems to be the one that will work. Since I work so much recently I have not had the time to do anything other than sit and watch a youtube video or 2, so I have not been able to spend the appropriate amound of time to figure out why this was happening.

Yesterday it finally just wouldn’t make it into the OS. No matter what kernel or even trying to load into a snapshot. I used a FlashDrive I have with Garuda flashed to it to boot into the live envorment in hopes to figure out the issue and I couldn’t because it could see my hdd but said it had 0bytes. It’s a Samsung 500gb 980pro and I have had it for about 3 years. I thought maybe it’s dying on me or it was having a connection issue from the computer getting bumped or something. It’s never had an issue prior and I try to limit what I keep on it since I use it for my boot drive. I still pulled it out cleaned the contacts with ipa and put it back and nothing. Today I got home and probably used Garuda on the flashdrive 3 or 4 hrs and then I downloaded a new ISO and added it to my ventoy and was going to just try and see if formating and reinstalling was possible. Well I missed the F12 and it went ahead and just booted into Garuda like normal.

This is my last ditch effort for help. I am a tinkerer kinda guy. I am capable of following instructions when given. I having been using Garuda for about 4 years and I have always been able to figure out any issue without asking for help by searching the forums or just doing research and trial and error.

I would however appreciate the help if you have the time and I will be ever so grateful.

Thank you

I have also been having random hangs where it will freeze up, reminding me of life using Windows Vista. I was thinking it may have been Nvidia related but hadn’t had time to look into it, now I am unsure and just generally unsure.
Oh, I am also using X11 because wayland has still been causing stuttering and wierd random issues with Brave.

It is important to know exactly what the error message says in a case like this, because it could be a number of rather different things happening.

There have been a lot of issues reported for this driver. It is possible your problem is GPU-related. Next time you get a hang like that, see if you can switch to a TTY and troubleshoot from there. Computer doesn’t boot, boots to a black screen, or stops at a message

Some users are reporting a number of resolved issues with the 555 drivers. They are still in beta at the moment, so be warned: here be dragons and so on. If you’d like to give them a shot you can install them like this: New nvidia drivers (beta 555), suggestions on how to install? - #4 by BluishHumility

4 Likes

To rule out any eventualities, please read this → tomshardware - Samsung Issues Fix for Dying 980 Pro SSDs

2 Likes

New nvidia drivers (beta 555), suggestions on how to install? - #4 by BluishHumility

This seems to have done the trick. I am very much appreciative of your time! If it relapses and I have issues again. I will make sure to take better notes of errors. I did try to switch to TTY prior and it wouldn’t. At least when it was hanging at the “unable to load kernel modules” message, it wouldn’t. It just had that 3 times in a row with no number error or anything. I wish I could remember it exactly.

In order to help anyone who may come across this. My steps after your reply were as follows:

I followed each link you sent and after reading both, I took your wisdom in regards to the 550.78 drivers. I have had so many issues following this update that I concluded the best place to start would be with the 555 beta drivers.

I had previously attempted to switch into a console at hangs and it wouldn’t. When I used a flash drive and live iso to attempt chroot I had issues with my drive showing 0bytes and being unable to mount and after reading the post I tried “sudo dkms autoinstall” and found that it would fail.

Since I have a backup of all my files I felt I could take the chance and I installed the beta drivers after following the instructions in the second link given. I rebooted and everything seems to work perfectly so far.

as for

Thank you for this. I had looked into this awhile back when I read somewhere or maybe someone on YouTube mentioned it. My drive fortunately wasn’t one of the affected.

Thank you. The Garuda Community is the best. This forum is run so well and I am grateful to have this resource as I use it all the time to do research.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.