I accidentally renamed /etc/pam.d, now unbootable!

First, I would like to apologize for not posting the expected inxi. I don’t know how to do that with an unbootable OS. I am not sure it will be needed for this.

Two days ago, I decided to deal with that /etc/pam.d/kde.pacnew file. So I planned to rename /etc/pam.d/kde to /etc/pam.d/kde.old then rename /etc/pam.d/kde.pacnew to /etc/pam.d/kde then delete /etc/pam.d/kde.old. I had a Doctor’s appointment soon and I was in a bit of a rush. Some how, I accidentally renamed the folder /etc/pam.d to /etc/pam.d.old. No big deal, right? I’ll just rename it back to /etc/pam.d/…except It would not let me do that! I may be wrong, but I suspect that the function of renaming a file is contained somewhere in /etc/pam.d. It said that /etc/pam.d/.old did not exist on my PC! UH-OH!..I think I just hosed myself!
I have tried to restore several different snapshots with no success. I also tried to use Garuda recovery mode. I did manage to figure out the search (find) function finally but I couldn’t see how to rename that folder. I don’t know much cli fu. So, with no more ideas, I decided it was time to give up and ask for help.
Thank you!

Live ISO, chroot …


I understand how such a thing can suck!! Everyone makes those mistakes once in a while.

Have you tried booting with Live ISO from USB, mount or chroot to the partition and rename it?

EDIT: Darn it! SGS just beat it to it :rofl:


You say every once in a while but it seems like virtually every day I see someone post this exact kind of thing (oops I made my system unbootable by deleting really important things) on r/archlinux.

1 Like

That is why informed users do not inform themselves or each other from that giggleweed reddit-type platform. I mean, seriously, those threads are funny to read with morning coffee, but to be believed? Nah. Getcher news here. :smiley: :wink:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.