Hyprland on KDE

can i install this be installed on any garuda linux dystro or does it have to be on sway. currently im on Garuda KDE Dr460nized and wanted to know if i can install hyprland on here with no issues. also if you have a guide specific to my dystro please feel free to share it with me.

I tried it. The themes just mashed each other up even though I had carefully changed all the config files and managed my gtk 2.0 and 3.0 files. It ended up looking very very weird. Tried to manually go back and somehow ended up borking my kvantum-dark theme. I dunno how that even happened. Tried rolling back a snapshot and somehow all my snapshots were stuck at “loading initramfs”. Again a big dunno. I never installed anything that should have affected snapper yet it did (or a previous update did and I just have been oblivious can’t say for sure).

Ended up backing my data and installing hyprland from scratch. Currently ricing it up. Found this repo,

Once done I might multiboot with i3-wm but not right now.


do you have a guide on how to install this? or how to make my linux desktop look like the ones in this github page?

Why would you need a guide for that? The guy has shared all his config files in one place go through it and extract what you need.

For example, wofi is just not working for me in my scaled in screen so I replaced it with rofi-lbonn-wayland-git and put this guy’s config files (for rofi) in my .config dir. Went through his config and saw dependency on some wallpapers outside the rofi config dir. downloaded them adjusted config according to my needs and bam.

In hyprland everything is handled like this the entire DE is contained in the .config dir. If you find yourself confused at what’s all this then set up a multiboot and mess around with it. Watch YT on how to configure hyprland or just read its wiki and go through the ~/.config/hypr/hyprland.conf that the devs have in place for you.


Or check the Garuda Hyprland and change it according to your ideas.
That’s what Linux is all about. :slight_smile:


well i would need a guide since im extremely new so im bound to mess something up.

tried that had some errors and i just went to dragonized garuda linux but im thinking about switching to the other garuda dystros for example sway is one i want to try out.

That’s why you set up multiboot. Since hyprland and sway don’t work in VMs you multiboot with them and play around with it. Even if your system goes bork all you have to do is wipe out that partition (or remove the subvol if you follow in bluishHumility’s footsteps) and reinstall if it comes down to it. Just remember to always have backups.

Just a head up If you wanna try sway do it with the open source nvidia drivers. Sway won’t work with proprietary one’s at all.


i had some errors with it. i couldnt login to my account on my computer after my first reboot. and it turns out it had driver errors. im using a nividia gpu idk if its to do with that. ultimately just deleted garuda hyprland. but like i said before thinking of installing hyprland wm manually on this install and hoping nothing bad happens.

I must insist, this is not correct. I know for certain folks have been running Sway with proprietary Nvidia drivers for many years now. It does take additional configuration, as noted in the ArchWiki article:

After NVIDIA driver version 495, sway works if you enable kernel mode setting and run sway with --unsupported-gpu.

Earlier today I changed the way Sway is launched from the display manager (feat(iso-profiles): update greetd config (a6ff4cdd) · Commits · Garuda Linux 🦅 / Tools / iso-profiles · GitLab) so it uses a wrapper script instead of launching Sway directly (feat(garuda-sway-settings): add swaystart (013e29c2) · Commits · Garuda Linux 🦅 / Themes and Settings / Settings / Garuda Sway settings · GitLab). The main benefit to this method is it helps source needed environment variables before Sway is launched, but it may actually make it easier to use the --unsupported-gpu flag as well because now the user can just edit /usr/local/bin/swaystart and add it in.

Completing the installation with open source drivers is probably the way to go here, and then install proprietary after it is already up (along with enabling kernel mode setting and adding the flag to the wrapper script).

1 Like

I see, I was just mentioning my own experience. In my case using proprietary drivers caused greetd to fail. I changed TTY and saw the logs, went to the greetd config file and removed the 2>/dev/null after the sway launch option and gave greetd a restart which told me about the --unsupported-gpu flag. I again edited the greetd config file and added this flag to sway start option which allowed me to reach the lock screen. Entering my password there I saw a bunch of red errors flash by my screen before going back to the login window.

All this when nvidia isn’t even my primary card. So I just booted in with open source drivers and sway didn’t say anything about it.

1 Like