Hyprland Live Disk works, Installer script doesn't

I’ve been trying to install the GORGEOUS Hyprland from a disk, in fact have tried all of my brand spanking new disks but the Install Garuda Linux script doesn’t work at all, nothing comes up. Is there a way to just get the same beautiful setup through a normal install and then just installing hyprland stuff?

you can follow this old guide :

BTW, please provide your garuda-inxi from live ISO

95c8e75418a82c8389bdb6a8795898065618f4f1 :wink:

Did you pressed Mod+i to launch installer script ?


Yes I tried that as well. nothing worked

What ISO are you using? I think this one was recently confirmed good in another thread: https://iso.builds.garudalinux.org/iso/community/hyprland/231127/

If you can’t get the installer running, log in to the forum from the live environment and paste the terminal output into the thread so we can take a look:

sudo -E calamares

garuda-hyprland-linux-zen-231127.iso Ok good idea brb in a moment

Ohhokayy hayyy somehow that started the installer yayyy!

installed but now mod key isnt working… grr

Ok needed an update . then modkey works. now is there an easy touchpad script to toggle on/off?

I never needed this thing soo…
but you can follow this thing :

although it is for X11 thing, but xwayland is installed and would might or might not work :

 ╭─ankur@ankur in ~ 
 ╰─λ xinput --list
WARNING: running xinput against an Xwayland server. See the xinput man page for details.
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ xwayland-pointer:14                     	id=6	[slave  pointer  (2)]
⎜   ↳ xwayland-relative-pointer:14            	id=7	[slave  pointer  (2)]
⎜   ↳ xwayland-pointer-gestures:14            	id=8	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ xwayland-keyboard:14                    	id=9	[slave  keyboard (3)]

 ╭─ankur@ankur in ~ took 12ms
1 Like

Thanks much bud!

not working but I will continue looking into this and updating as necessary

Fixed it by doing
hyprctl keyword “device:asuf1204:00-2808:0202-touchpad:enabled” false

1 Like

Please, next time, follow the template.
Only one problem per thread. :smiley: