Hyprland help with kde connect, night light

Those are just some questions in my mind as I am a nub in Hyprland…

I wanna know if that happens in my case or others…

  1. can someone please tell me how to do night-light in hyprland ?
  2. And is kde-connect not working in hyprland?

another thing to notify:

  1. that james DSP not work crashes, and not launching
  Kernel: 6.7.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc
    avail: hpet,acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=cef7463d-ac6e-4d76-a945-b8002b8e34ff rw rootflags=subvol=@ quiet
    resume=UUID=d194e71c-09c2-4434-8f35-8dfb9c05c716 loglevel=3 ibt=off
  Desktop: Hyprland v: 0.35.0-83-g8c361363 with: waybar tools: avail: swayidle,swaylock vt: 1
    dm: SDDM Distro: Garuda base: Arch Linux
  Type: Laptop System: Hewlett-Packard product: HP Pavilion 15 Notebook PC
    v: 098C110000404100000610180 serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: Hewlett-Packard model: 2186 v: 35.12 serial: <superuser required> part-nu: F6C93PA#ACJ
    uuid: <superuser required> UEFI: Insyde v: F.30 date: 10/03/2013
  ID-1: BAT0 charge: 12.3 Wh (37.0%) condition: 33.2/33.2 Wh (100.0%) volts: 13.9 min: 14.8
    model: Hewlett-Packard Primary type: Li-ion serial: N/A status: discharging
  Info: model: Intel Core i3-3217U bits: 64 type: MT MCP arch: Ivy Bridge gen: core 3 level: v2
    built: 2012-15 process: Intel 22nm family: 6 model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache: L1: 128 KiB
    desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1796 min/max: 800/1800 scaling: driver: intel_cpufreq governor: schedutil
    cores: 1: 1796 2: 1796 3: 1796 4: 1796 bogomips: 14366
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Hewlett-Packard driver: i915 v: kernel
    arch: Gen-7 process: Intel 22nm built: 2012-13 ports: active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300
  Device-2: Cheng Uei Precision Industry (Foxlink) Webcam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3:2 chip-ID: 05c8:036e class-ID: 0e02
  Display: wayland server: X.org v: with: Xwayland v: 23.2.4 compositor: Hyprland
    v: 0.35.0-83-g8c361363 driver: X: loaded: modesetting alternate: fbdev,intel,vesa dri: crocus
    gpu: i915 display-ID: 1
  Monitor-1: LVDS-1 model: Samsung 0x4651 built: 2012 res: 1366x768 hz: 60 dpi: 101 gamma: 1.2
    scale: 1 size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9 modes: 1366x768
  API: Vulkan v: 1.3.276 layers: 3 device: 0 type: integrated-gpu name: Intel HD Graphics 4000
    (IVB GT2) driver: mesa intel v: 24.0.1-arch1.1 device-ID: 8086:0166 surfaces: xcb,xlib,wayland
    device: 1 type: cpu name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
    v: 24.0.1-arch1.1 (LLVM 16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib,wayland
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Hewlett-Packard 7
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20 class-ID: 0403
  API: ALSA v: k6.7.5-zen1-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Ralink RT3290 Wireless 802.11n 1T/1R PCIe vendor: Hewlett-Packard driver: rt2800pci
    v: 2.3.0 pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 1814:3290 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8136
    class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  Device-1: Ralink RT3290 Bluetooth vendor: Hewlett-Packard driver: N/A pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 01:00.1 chip-ID: 1814:3298 class-ID: 0d11
  Local Storage: total: 465.76 GiB used: 17.58 GiB (3.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABF050 size: 465.76 GiB block-size:
    physical: 4096 B logical: 512 B speed: 3.0 Gb/s tech: HDD rpm: 5400 serial: <filter> fw-rev: 2C
    scheme: GPT
  ID-1: / raw-size: 62.5 GiB size: 62.5 GiB (100.00%) used: 14.45 GiB (23.1%) fs: btrfs
    dev: /dev/sda14 maj-min: 8:14
  ID-2: /boot/efi raw-size: 800 MiB size: 798.4 MiB (99.80%) used: 584 KiB (0.1%) fs: vfat
    dev: /dev/sda15 maj-min: 8:15
  ID-3: /home raw-size: 99.48 GiB size: 99.48 GiB (100.00%) used: 3.13 GiB (3.1%) fs: btrfs
    dev: /dev/sda16 maj-min: 259:0
  ID-4: /var/log raw-size: 62.5 GiB size: 62.5 GiB (100.00%) used: 14.45 GiB (23.1%) fs: btrfs
    dev: /dev/sda14 maj-min: 8:14
  ID-5: /var/tmp raw-size: 62.5 GiB size: 62.5 GiB (100.00%) used: 14.45 GiB (23.1%) fs: btrfs
    dev: /dev/sda14 maj-min: 8:14
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 3.72 GiB used: 0 KiB (0.0%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 4.06 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda13
    maj-min: 8:13
  System Temperatures: cpu: 47.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Memory: total: 4 GiB available: 3.72 GiB used: 2.11 GiB (56.8%)
  Processes: 227 Power: uptime: 3m states: freeze,mem,disk suspend: deep avail: s2idle wakeups: 0
    hibernate: platform avail: shutdown, reboot, suspend, test_resume image: 1.47 GiB
    services: upowerd Init: systemd v: 255 default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1308 libs: 373 tools: octopi,pacseek,paru Compilers: gcc: 13.2.1
    Client: shell wrapper v: 5.2.26-release inxi: 3.3.33
Garuda (2.6.23-1):
  System install date:     2024-01-27
  Last full system update: 2024-02-23
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:            

i create this topic for this… if i need to provide more details … i will add them…

What’s the problem with not posting garuda-inxi?
It contains additional, useful information about the status of your system.

:warning: Missing information requested in the template may result in not receiving assistance

Make sure you have done the following before you post:

Issue still unresolved? Then:

> - ONE issue per topic.

  • Describe your issue in detail. The more we know, the better we can help
  • Show us the results of your searches, and what you’ve tried
  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)
  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Without garuda-inxi this request will be moved to 412 Precondition Failed

1 Like

sorry … I am just going to paste it :slightly_smiling_face:

I’m not using hyprland so cannot confirm, but you can try this:

you can use wlsunset
It is also included in G-Hyprland implementation

Can’t say about others because I don’t use them :slightly_smiling_face:


By the way, it’s amazing how resource-efficient Hyprland is.


ok , how can I add it to the tray??

BTW, how to fix the kde-connect :slightly_smiling_face: I need that very much

1 Like

:slightly_smiling_face: it’s owner gave me this laptop for Rs. 4000 as he was unable to do anything with it … you all know why :rofl: :rofl:

but one thing I have to sacrifice … . Bluetooth
Device-1: Ralink RT3290 Bluetooth vendor: Hewlett-Packard driver: N/A


It’s a CLI tool :eyes:

I have never used it so I can’t say anything about it :slightly_frowning_face:

1 Like

I paid the equivalent of Rs. 500 more for my MacBook (2012), incl. a stylish laptop bag and a new charging cable. :sweat_smile:

Maybe this will help you: Bluetooth problem Ralink RT3290 - Support - Manjaro Linux Forum


On the one hand, I’m interested in why heads explode here, but on the other hand, I don’t need to know everything. :grinning:


I use it this way.

install the packages:

sudo pacman -S kdeconnect 

then add this to hyprland.conf

# KDEconnect:
exec-once = /usr/lib/kdeconnectd&!
exec-once = /usr/bin/kdeconnect-indicator&!

the indicator will show up in the waybar when your phone connected to the computer.

Unfortunately the kde connect apps does’t respect the theme settings for me in hyperland. I don’t have time yet find the solution for this…


Thank you for guide to indicator

… The default sweet theme works for me.

Now i am able to connect …But…
Does file-sharing work for you???
Remote input isn’t working as hyprland issue with kde connect Kdeconnect remote input doesn't work · Issue #1775 · hyprwm/Hyprland · GitHub

But in my case when i try to send files … it stucked or failed (everytime when sending from linux to phone)

and fails sometime when sending from phone

also clipboard sending has issues

I don’t use the default theme, looks good, but i did not like the pink color…

I use mainly share web browser tabs, this option works well for me.
I tried file share now, from phone to computer works fine, but from computer to phone not. I got an error same. I don’t know the reason yet. I will have a look it later.

this i don’t use anyway.

both works for me with no issue.

1 Like

I just tried it with a new phone. Now working fine. But my old phone still not. So probably there is something permissions or settings problem on the phone. I did not find what is it.

which android version ??? i’m on 14

I am same on android 14.
On the first time when i set up kde connect i just go trough the permissions and it works. But my old phone still doesn`t (Miui).

I guess maybe has somewhere something different permission in miui.