Huge lag spikes and force to restart pc

i have not touched or added any drivers from pacman, so i would assume its just what ever garuda has.
i like performance, but stability and predictability is my first wish.

Go to the Arch Wiki page on systemd. Learn how to mask a service, it's very simple to do. Mask the service and then restart. As I already stated, this has been detailed many times recently on the forum how to do this.

I think you need to spend more time searching as this has all been covered in great detail before on our forum before.

I hate to start sounding like a broken record, but these things certainly aren't common on my system. I hate to point fingers, because bugs definitely do occur, but when the same user is constantly having strange issues after a while you start to suspect user interventions may be the cause.

Case in point, without mentioning any user names. A user a little while back had a long string of help requests for odd issues in a short period of time. Turns out the user a few days ago found out the cause. In this case Bleachbit was responsible for cleaning important files from the users system resulting in numerous problems. Don't use Bleachbit unless you are an extremely experienced user IMO. Just one example of how problems can be introduced.

3 Likes

also, since its all fresh, i installed manjaro kde edition for a friend last week and just the other day they had a bad experice with its bugs and glitchyness. they showed me all of them in great detail and there was a good 50% match with my experience. That was when i saw what was kde and what wasn't, and just dont see how you can have a stable experience with it.. what do you not do to have it working lol

I have run KDE more years than I can remember. Perhaps experience in knowing how to configure my system enters into things, but I find KDE very stable personally.

3 Likes

Me too.

Me too.

3 Likes

Anyways as far as helping you out goes.
To mask auto-cpufreq like SGS says:
sudo systemctl disable auto-cpufreq.service
sudo systemctl mask auto-cpufreq.service
and reboot.

My final recomendation would be to check pamac(Add/Remove Software) and search for "chaotic-nvidia" if there is nothing installed, proceed with the next step. I think the default is now straight of the Arch Repository.
Upgrade your system with sudo pacman -Syu or in Pamac.
After doing so reboot and run inxi -G to verify you are on 460.56.
460.56 fixed a lot of stability issues for me.

Also on the Manjaro front, I am pretty sure Manjaro repos are stuck on Nvidia 460.39 at the current moment

1 Like

i was focused on it not going smoothly rather than getting to my goal- i did indeed disable it properly as i was typing that- sorry. It now is no longer ticked on the assistant and i hope it helped.

Im not sure what bleachbit is, but i cant think of doing anything similar of late that could be a result to my own string of "correlation does not equal causation" point and counter points on this here garuda fourm.
I am learning linux a hard way, but i really dont try to make my problems other peoples if i dont have to. I have taken up some linux books that really help. I am always on the wiki's and my system has been all but destroyed multiple times in the last few months. Though i have been laying low since college started back up a few weeks ago

thank you, ill sort these out now

These are all old software versions, which indicates your system is out-of-date. If you're not regularly updating your system then is a rolling-release distribution the right choice for your use case?

Sounds like you want a frozen-pool release, like Mint, Ubuntu, MX, etc.

5 Likes

I like things being up-to-date. I felt it when running LTS distros. I am actaully a fan of bleeding edge versions of programs, for I almost always notice it, and can input on said programs fourms if its buggy or what ever. I like new things, and bugs getting fixed nice and fast also feels good.

in total contradiction to what i just said: have been fighting with a bunch of other things i dont understand and trying to learn them. Updating my system is almost a scary process if it will reset or change a bunch of settings i only just managed to set so that its all working...

that said

im doing this after I sort out my drivers. Just incase there be an issue like the aforementioned

as for these, even if they were rolling release, i like arch and its systems and its apps. Im used to it. I also just have no idea how to set up backups and zram and better ram optimisations and all that jazz. yet to figure out overclocking though...
aside from the actual user experience/theme/terminal, garuda is giving me fab performance in my games and more intensive work programs. When they launch :sweat_smile:
now, just need to do some more reverse engineering

2 Likes

You marked my post as the solution!
Did updating your system and the Nvidia Driver fix the instability?

Just want to verify, because I hadn't heard of anyone else having an issue on 460.39, I kind of realized it myself because the Chaotic-Nvidia Drivers were behind

1 Like