HTOP displaying CPU temperature in Fahrenheit instead of Celsius

Hello!

First of all, I am in love with Garuda, I've installed it some hours and have to say it's the best looking desktop I've ever seen, everything ready after installation. Thank you, I really appreciate it.

The one thing that I found I didn't like was that HTOP is reporting the temperature in Fahrenheit, and I would like it in Celsius. I have been searching for a while and have found nothing relevant to my problem, so I come here in hopes that someone will know the answer.

Thank you

System:
Kernel: 5.15.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=1c0966bd-a51c-4456-82ac-748eaaa86e91 rw [email protected]
quiet
cryptdevice=UUID=89f671d1-1a68-4e93-8fb1-c4429b039bce:luks-89f671d1-1a68-4e93-8fb1-c4429b039bce
root=/dev/mapper/luks-89f671d1-1a68-4e93-8fb1-c4429b039bce splash
rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1
resume=/dev/mapper/luks-1dbce9c8-2c8a-4cea-9245-c04812506ce0 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: MAG X570 TOMAHAWK WIFI (MS-7C84)
v: 1.0 serial: <superuser required> UEFI: American Megatrends v: 1.00
date: 04/11/2020
CPU:
Info: model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+
family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 768 KiB desc: d-8x32 KiB; i-8x64 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 2954 high: 4340 min/max: 2200/3700 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 2633 2: 2900
3: 2421 4: 2571 5: 2457 6: 2466 7: 2499 8: 4305 9: 2560 10: 2798 11: 2897
12: 3934 13: 2634 14: 2462 15: 3394 16: 4340 bogomips: 118384
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GP102 [GeForce GTX 1080 Ti] vendor: Gigabyte
driver: nvidia v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 24:00.0
chip-ID: 10de:1b06 class-ID: 0300
Display: x11 server: X.Org 1.21.1.2 compositor: kwin_x11 driver:
loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 3440x1440 s-dpi: 106 s-size: 824x352mm (32.4x13.9")
s-diag: 896mm (35.3")
Monitor-1: DP-2 res: 3440x1440 dpi: 107 size: 819x346mm (32.2x13.6")
diag: 889mm (35")
OpenGL: renderer: NVIDIA GeForce GTX 1080 Ti/PCIe/SSE2
v: 4.6.0 NVIDIA 495.46 direct render: Yes
Audio:
Device-1: NVIDIA GP102 HDMI Audio vendor: Gigabyte driver: snd_hda_intel
v: kernel bus-ID: 24:00.1 chip-ID: 10de:10ef class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus-ID: 2e:00.3 chip-ID: 1022:1457
class-ID: 0403
Device-3: Generalplus USB Audio Device type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 5-1:2 chip-ID: 1b3f:2008
class-ID: 0300
Sound Server-1: ALSA v: k5.15.8-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
v: kernel port: e000 bus-ID: 26:00.0 chip-ID: 10ec:8125 class-ID: 0200
IF: enp38s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 28:00.0
chip-ID: 8086:2723 class-ID: 0280
IF: wlo1 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-4:3 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 5.01 TiB used: 2 TiB (39.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: PNY model: CS3030 1TB SSD
size: 931.51 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: CS303225
temp: 25.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Samsung
model: SSD 960 PRO 512GB size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 4B6QCXP7 temp: 18.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD20EZRZ-00Z5HB0 size: 1.82 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 0A80 scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD20EARS-00MVWB0 size: 1.82 TiB block-size: physical: 512 B
logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: AB51
scheme: MBR
Partition:
ID-1: / raw-size: 896.72 GiB size: 896.72 GiB (100.00%)
used: 26.92 GiB (3.0%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-89f671d1-1a68-4e93-8fb1-c4429b039bce
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 720 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 896.72 GiB size: 896.72 GiB (100.00%)
used: 26.92 GiB (3.0%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-89f671d1-1a68-4e93-8fb1-c4429b039bce
ID-4: /var/log raw-size: 896.72 GiB size: 896.72 GiB (100.00%)
used: 26.92 GiB (3.0%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-89f671d1-1a68-4e93-8fb1-c4429b039bce
ID-5: /var/tmp raw-size: 896.72 GiB size: 896.72 GiB (100.00%)
used: 26.92 GiB (3.0%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-89f671d1-1a68-4e93-8fb1-c4429b039bce
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.36 GiB used: 2.8 MiB (0.0%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 34.49 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/dm-1 maj-min: 254:1
mapped: luks-1dbce9c8-2c8a-4cea-9245-c04812506ce0
Sensors:
System Temperatures: cpu: 32.9 C mobo: N/A gpu: nvidia temp: 59 C
Fan Speeds (RPM): fan-2: 1514 fan-3: 1486 fan-4: 1511 gpu: nvidia
fan: 21%
Info:
Processes: 395 Uptime: 42m wakeups: 0 Memory: 31.36 GiB
used: 5.3 GiB (16.9%) Init: systemd v: 249 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1894 lib: 541 Shell: fish
v: 3.3.1 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.10

Hi there, welcome.
Have you checked that in F2 (Setup) "Show temperature in degree Farenheit instead of Celsius" in unchecked?

5 Likes

Thank you so much, I don't know how I missed it. I've gone over these settings 20 times trying to fix it.

Thank you again.

1 Like

I went through those settings for the first time, so maybe I was less "biased" :wink:

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.