Hp printer 2630

I have been Trying to set up my HP Printer 2630, as it does not seem to be automaticly recognised.
I have tried suggestions that I have seen on the Forum but nothing has worked. I have installed HP Device Manager but this does not seem to work. The strangfe thisng is , I have a Direct B3 HP Deskjet showing in my Network and its connected but when I try to print something the printer is missing from print dialogue.
I have downloaded software that pertains to HP from the add software app but still does not work. I did have my Firewall active but turned this off as I thought that this may be blocking the service but still nothing.
Any advice would be most welcome.
Stephen

Disable/Mask the ipp-usb.service.

systemctl mask ipp-usb

Reboot.

2 Likes

Thanks TBG for your quick reply. I tried your suggestion but no go.
This is what the Terminal wrote;
╰─λ systemctl mask ipp-usb[sudo] password for stephen:
systemctl mask ipp-usb
Unit ipp-usbsystemctl.service does not exist, proceeding anyway.
Unit mask.service does not exist, proceeding anyway.
Unit ipp-usb.service does not exist, proceeding anyway.
Created symlink /etc/systemd/system/ipp-usbsystemctl.service → /dev/null.
Created symlink /etc/systemd/system/mask.service → /dev/null.
Created symlink /etc/systemd/system/ipp-usb.service → /dev/null

Does not mean anything to me but I hope that either you or someone else can point me in the right direction. My Installation of Garuda went well apart from the printer; which normally
in most recent Linux Distros goes without a hitch, particularly with HP.
I went back to Print settings and am unable to add printer from here, or start services, or connect.

Thanks Steve

My HP printer required a different driver despite there being a so called linux native one. If you haven't googled "linux HP 2630" yet, do that, the first result will probably tell you to install "fooHP" driver or something else like that.

Literally, the driver I needed is named "foo2hp" which is in the package foo2zjs-nightly in the chaotic AUR. That package has a bunch of HP specific drivers that actually work.

2 Likes

Thanks zepherusbane, I had already installed this but I decided to reinstall but this did not work. I decided to try HP Device Manager again. Went through the procedure for configuring USB and the process seemed good it said it had been successful but still unable to print. So I tried the wireless configuration and it found the printer said it was configured correctly but still I can not print. Tried the CUPS config. but just get a message saying could not connect to local host. Connection refused. Any one have any other ideas??? Thanks Steve

Just thought I would add this, if it helps;
HP Linux Imaging and Printing System (ver. 3.21.2)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Icon theme "adwaita" not found.
Icon theme "ubuntu-mono" not found.
Icon theme "yaru" not found.
Icon theme "Mint-X" not found.
Icon theme "elementary" not found.
qt.qpa.xcb: QXcbConnection: XCB error: 5 (BadAtom), sequence: 494, resource id: 0, major code: 20 (GetProperty), minor code: 0
Searching... (bus=usb, search=(None), desc=0)
error: No PPD found for model deskjet_2600 using old algorithm.
dict[m] {'align-type': 15, 'clean-type': 0, 'color-cal-type': 0, 'copy-type': 0, 'embedded-server-type': 1, 'fax-type': 0, 'fw-download': False, 'icon': 'hp_deskjet_f4200.png', 'io-mfp-mode': 1, 'io-mode': 1, 'io-support': 10, 'job-storage': 0, 'linefeed-cal-type': 0, 'model1': 'HP DeskJet 2620 All-in-One', 'model2': 'HP DeskJet2621 All-in-One', 'model3': 'HP DeskJet 2622 All-in-One', 'model4': 'HP DeskJet 2623 All-in-One', 'model5': 'HP DeskJet Ink Advantage 2635 All-in-One', 'model6': 'HP DeskJet Ink Advantage 2636 All-in-One', 'model7': 'HPDeskJet Ink Advantage 2675 All-in-One', 'model8': 'HP DeskJet Ink Advantage 2676 All-in-One', 'model9': 'HP DeskJet Ink Advantage 2677 All-in-One', 'model10': 'HP DeskJet Ink Advantage 2678 All-in-One', 'monitor-type': 0, 'panel-check-type': 0, 'pcard-type': 0, 'plugin': 0, 'plugin-reason': 0, 'power-settings': 0, 'pq-diag-type': 0, 'r-type': 0, 'scan-src': 1, 'scan-type': 7, 'status-battery-check': 0, 'status-dynamic-counters': 0, 'status-type': 10, 'support-released': True, 'support-subtype': 2202411, 'support-type': 2, 'support-ver': '3.17.7', 'tech-class': ['PyramidRefresh17'], 'family-class': ['PyramidRefresh17'], 'tech-subclass': ['Normal'], 'tech-type': 2, 'usb-pid': 83, 'usb-vid': 1008, 'wifi-config': 3}
lpr: Error - The printer or class does not exist.
error: Print command failed with exit code 256!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.