HP Pavilion gaming 16 audio driver issues

Aloha! So I’m not sure how to identify this issue other than audio driver failure, however it’s like when I play a game (minecraft dungeons, forza, gtav) the drivers sound like they keep “changing gears” or modes??. It’ll work fine for a spell then get all crackly, then change to another higher pitched crackle, then another the back to normal if it doesn’t get stuck. I have tried switching pro drivers, pro and pro 31 seem to work the best but still get the issue, and hifi driver works for a little while if I already used it to watch a show and still have that show open using the driver.

Ps: the exact same driver setup works flawlessly on my partners asus w/nvidia generic card 1U. I set up both plz help a scrub

Please post the terminal/konsole input and output as text (no pictures) from the following command:


I will, however, is there anyway to copy paste or do I have to do that manually??

If you don't want to copy from terminal, you can copy it from the Garuda Assistant tool (System Specs)

1 Like
  Kernel: 6.4.11-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc
    available: acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=15fed3aa-1ba2-483a-b96b-1ef5fa58448a rw rootflags=subvol=@ quiet quiet
    rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=b349b3b3-6566-4739-bf6b-e5eb8c56219c loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: HP product: HP Pavilion Gaming Laptop 16-a0xxx v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 87AF v: 32.32 serial: <superuser required> UEFI: AMI v: F.23 date: 03/29/2022
  ID-1: BAT0 charge: 46.3 Wh (100.0%) condition: 46.3/46.3 Wh (100.0%) volts: 13.0 min: 11.6
    model: HP Primary type: Li-ion serial: <filter> status: full cycles: 154
  Info: model: Intel Core i5-10300H bits: 64 type: MT MCP arch: Comet Lake gen: core 10 level: v3
    note: check built: 2020 process: Intel 14nm family: 6 model-id: 0xA5 (165) stepping: 2
    microcode: 0xF8
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 3600 high: 3603 min/max: 800/4500 scaling: driver: intel_pstate
    governor: powersave cores: 1: 3600 2: 3601 3: 3600 4: 3600 5: 3600 6: 3603 7: 3600 8: 3600
    bogomips: 39999
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Hewlett-Packard driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1 empty: none bus-ID: 00:02.0
    chip-ID: 8086:9bc4 class-ID: 0300
  Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: Hewlett-Packard driver: nvidia
    v: 535.98 alternate: nouveau,nvidia_drm non-free: 535.xx+ status: current (as of 2023-08)
    arch: Turing code: TUxxx process: TSMC 12nm FF built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 8 link-max: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:2191
    class-ID: 0300
  Device-3: Luxvisions Innotech HP TrueVision HD Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:2 chip-ID: 30c9:0013 class-ID: 0e02
    serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia unloaded: nouveau alternate: fbdev,intel,nv,vesa dri: iris gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x1602 built: 2019 res: 1920x1080 hz: 144 dpi: 137
    gamma: 1.2 size: 355x199mm (13.98x7.83") diag: 407mm (16") ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 23.1.6 renderer: Mesa Intel UHD Graphics (CML GT2) direct-render: Yes
  Device-1: Intel Comet Lake PCH cAVS vendor: Hewlett-Packard driver: sof-audio-pci-intel-cnl
    alternate: snd_hda_intel, snd_soc_skl, snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:06c8
    class-ID: 0401
  Device-2: NVIDIA TU116 High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:1aeb class-ID: 0403
  API: ALSA v: k6.4.11-zen2-1-zen status: kernel-api with: aoss type: oss-emulator tools: N/A
  Server-1: PipeWire v: 0.3.77 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 4000 bus-ID: 04:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: down mac: <filter>
ice-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: Hewlett-Packard
    driver: rtw_8822ce v: N/A modules: rtw88_8822ce pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000
    bus-ID: 05:00.0 chip-ID: 10ec:c822 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.0 speed: 12 Mb/s lanes: 1
    mode: 1.1 bus-ID: 1-7:3 chip-ID: 0bda:b00c class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block:
    hardware: no software: yes address: <filter> bt-v: 5.1 lmp-v: 10 status: discoverable: no
    pairing: no
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: 6060
    bus-ID: 00:17.0 chip-ID: 8086:282a rev: class-ID: 0104
  Local Storage: total: 504.19 GiB used: 348.05 GiB (69.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: HBRPEKNX0202AH size: 476.94 GiB
    block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 tech: SSD serial: <filter>
    fw-rev: HPS2 temp: 38.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Intel model: HBRPEKNX0202AHO size: 27.25 GiB
    block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 tech: SSD serial: <filter>
    fw-rev: HPS3 temp: 50.9 C
  ID-1: / raw-size: 467.84 GiB size: 467.84 GiB (100.00%) used: 348.05 GiB (74.4%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 467.84 GiB size: 467.84 GiB (100.00%) used: 348.05 GiB (74.4%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 467.84 GiB size: 467.84 GiB (100.00%) used: 348.05 GiB (74.4%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 467.84 GiB size: 467.84 GiB (100.00%) used: 348.05 GiB (74.4%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 7.53 GiB used: 4.88 GiB (64.8%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3
    maj-min: 259:3
  System Temperatures: cpu: 57.0 C pch: 54.0 C mobo: N/A
  Fan Speeds (rpm): cpu: 0 fan-2: 0
  Processes: 309 Uptime: 43m wakeups: 39170 Memory: total: 8 GiB available: 7.53 GiB
  used: 5.77 GiB (76.6%) Init: systemd v: 254 default: graphical tool: systemctl Compilers:
  gcc: 13.2.1 Packages: pm: pacman pkgs: 1822 libs: 522 tools: octopi,paru Client: shell wrapper
  v: 5.1.16-release inxi: 3.3.29
Garuda (2.6.16-1):
  System install date:     2023-08-23
  Last full system update: 2023-08-23
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:

As far as I can tell (I am not an audio expert) the Audio part seems fine to me.

Just to be sure, if you have Windows, check if everything works normally there (otherwise it could be a HW problem).
The only idea I can think of is to try other kernels to see if anything changes. Eg:

sudo pacman -S linux-lts linux-lts-headers
sudo pacman -S linux-mainline linux-mainline-headers

Remember that afterwards, at the grub menu, you’ll have to select the kernel you want to use in the Advanced Options menu

1 Like

I do not have a dual boot, but it did run windows before however I used the full disk for the garuda install. Disrespectfully, fk windows for not respecting my time and space. Alright, I'll hit the search on kernel switching. Thank you kindly for the guidance!! I will post results soon.

Update, my pc hated it lol. Boot went fine, loaded gtav, got downstairs and the hifi drover broke, switched to the other and drove like 10 ft and my pc crashed. Gaming laptops*

You can try reducing the sample rate to to 44100 (44.1 kHz), as described here:


Changing the default sample rate
By default PipeWire sets a fixed global sample rate of 48kHz. If you need to change it (e.g. you own a DAC supporting a higher value), you can set a new default:

/etc/pipewire/pipewire.conf (or ~/.config/pipewire/pipewire.conf)
context.properties = {
    default.clock.rate     = *sample_rate*

Put 44100 where it says *sample_rate*.

Another consideration would be trying a different governor for your CPU.

I’m not sure if that would make a difference or not, but it seems like it would be worth a shot. Try changing it to performance in Garuda Assistant and see if you notice a difference.


Awesomeness, I will review, attempt, and relay soon!! Thank you kindly for help and support

Update!! No issues since the update!! Thanks kindly​:snowflake:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.